Bug 42825 - bootstrap fails: /usr/bin/ld: can't locate file for: -lgcc_s.10.4
Summary: bootstrap fails: /usr/bin/ld: can't locate file for: -lgcc_s.10.4
Status: RESOLVED WONTFIX
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 4.5.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-21 13:36 UTC by Ed Smith-Rowland
Modified: 2013-11-22 19:58 UTC (History)
2 users (show)

See Also:
Host: powerpc-apple-darwin7.9.0
Target: powerpc-apple-darwin7.9.0
Build: powerpc-apple-darwin7.9.0
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Smith-Rowland 2010-01-21 13:36:50 UTC
While bootstrapping on MacOSX 10.3 a link error is found in stage3 while building libstdc++

The library in question is libgcc_s.10.4.
I've had a look at gcc/config/ and it seems this is supposed to be a 

There are several of these in

If a system library is required then we have these:
MacOSX:~/gcc/libstdc++-v3/include/tr1_impl ed$ ll /usr/lib/libgcc*
  /usr/lib/libgcc.a -> gcc/darwin/default/libgcc.a
  /usr/lib/libgcc_s.1.0.dylib
  /usr/lib/libgcc_s.1.dylib -> libgcc_s.1.0.dylib

Possibility: MacOSX 10.3 was dropped - it looks like the 
libgcc_s.10.4 and libgcc_s.10.5 are from MacOSX 10.4 and 10.5 respectively.
Should the link be against libgcc_s.1.0.dylib dot MacOSX10.3 instead?

Possibility: Should the link use the recently built libgcc_s.1 instead of a system library?

I might try to fake out the compile with a link from libgcc_s.10.4.dylib to libgcc_s.1.0.dylib

I'll report back.

I still think it's a config problem though.
Comment 1 Ed Smith-Rowland 2010-01-21 16:29:37 UTC
I had to run to work before I could make sure but I think the
  ln -s /usr/lib/libgcc_s.1.0.dylib /usr/lib/libgcc_s.10.4.dylib
trick may have "worked".
Comment 2 Ed Smith-Rowland 2010-01-22 00:02:46 UTC
The link hack worked.

This isn't really a fix but maybe it isn't a big deal.

Ed
Comment 3 Ed Smith-Rowland 2013-11-22 19:58:00 UTC
The workaround worked and in any case, the machine and OS is dead.