Bug 42731 - terminates with "virtual memory exhausted: Cannot allocate memory" in error recovery
Summary: terminates with "virtual memory exhausted: Cannot allocate memory" in error r...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 4.5.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: error-recovery, ice-on-invalid-code
Depends on:
Blocks:
 
Reported: 2010-01-13 17:09 UTC by Matthias Klose
Modified: 2011-05-08 09:10 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work: 4.4.3, 4.5.3, 4.6.1, 4.7.0
Known to fail: 4.5.0
Last reconfirmed:


Attachments
preprocessed source (223.88 KB, application/x-gzip)
2010-01-13 17:10 UTC, Matthias Klose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Klose 2010-01-13 17:09:56 UTC
seen with trunk 20100113

$ g++ -g -O2 -c kanjisaver.ii 
kanjisaver.cpp: In member function 'void kanjisaver::draw_kanji()':
kanjisaver.cpp:328:48: error: cannot call constructor 'QPoint::QPoint' directly
kanjisaver.cpp:328:48: note: for a function-style cast, remove the redundant '::QPoint'
kanjisaver.cpp:329:41: error: cannot call constructor 'QPoint::QPoint' directly
kanjisaver.cpp:329:41: note: for a function-style cast, remove the redundant '::QPoint'
kanjisaver.cpp:329:41: error: no matching function for call to 'QPoint::QPoint(int&, int, int&, int)'
/usr/share/qt3/include/qpoint.h:114:8: note: candidates are: QPoint::QPoint(int, int)
/usr/share/qt3/include/qpoint.h:111:8: note:                 QPoint::QPoint()
/usr/share/qt3/include/qpoint.h:50:1: note:                 QPoint::QPoint(const QPoint&)
kanjisaver.cpp:330:6: error: cannot call constructor 'QRect::QRect' directly
kanjisaver.cpp:330:6: note: for a function-style cast, remove the redundant '::QRect'
kanjisaver.cpp:365:48: error: cannot call constructor 'QPoint::QPoint' directly
kanjisaver.cpp:365:48: note: for a function-style cast, remove the redundant '::QPoint'
kanjisaver.cpp:366:41: error: cannot call constructor 'QPoint::QPoint' directly
kanjisaver.cpp:366:41: note: for a function-style cast, remove the redundant '::QPoint'
kanjisaver.cpp:366:41: error: no matching function for call to 'QPoint::QPoint(int&, int, int&, int)'
/usr/share/qt3/include/qpoint.h:114:8: note: candidates are: QPoint::QPoint(int, int)
/usr/share/qt3/include/qpoint.h:111:8: note:                 QPoint::QPoint()
/usr/share/qt3/include/qpoint.h:50:1: note:                 QPoint::QPoint(const QPoint&)
kanjisaver.cpp:367:6: error: cannot call constructor 'QRect::QRect' directly
kanjisaver.cpp:367:6: note: for a function-style cast, remove the redundant '::QRect'
virtual memory exhausted: Cannot allocate memory
Comment 1 Matthias Klose 2010-01-13 17:10:13 UTC
Created attachment 19576 [details]
preprocessed source
Comment 2 H.J. Lu 2010-01-13 17:47:57 UTC
I think this is a dup for PR 42701.
Comment 3 Paolo Carlini 2011-05-08 09:10:36 UTC
Works for me in the currently active branches.