Bug 42460 - man page errors for generated libstdc++ man pages
Summary: man page errors for generated libstdc++ man pages
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 4.5.0
: P3 normal
Target Milestone: 4.5.0
Assignee: Benjamin Kosnik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-22 11:39 UTC by Debian GCC Maintainers
Modified: 2010-04-06 11:22 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2010-02-04 18:28:04


Attachments
man pages with errors (212.38 KB, application/x-gzip)
2009-12-22 11:40 UTC, Debian GCC Maintainers
Details
patch fixing two typos (515 bytes, patch)
2009-12-22 11:42 UTC, Debian GCC Maintainers
Details | Diff
log of man page creation (43.78 KB, application/x-bzip2)
2010-01-07 18:37 UTC, Benjamin Kosnik
Details
fix \n quoting (317 bytes, patch)
2010-02-04 21:02 UTC, Debian GCC Maintainers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Debian GCC Maintainers 2009-12-22 11:39:37 UTC
the following errors are seen, when generating the man pages on a Debian system, two of them fixed in the attached patch.

  Matthias

C++Intro.3cxx  around line 32: table wider than line width

__gnu_cxx::enc_filebuf.3cxx 805: warning: macro `If' not defined
__gnu_cxx::stdio_sync_filebuf.3cxx 699: warning: macro `If' not defined
std::basic_filebuf.3cxx 905: warning: macro `If' not defined
std::basic_ios.3cxx 1123: warning: macro `Minimum' not defined
std::basic_istream.3cxx 988: warning: macro `)).' not defined
std::basic_istringstream.3cxx 1011: warning: macro `)).' not defined
std::basic_stringbuf.3cxx 723: warning: macro `If' not defined
std::exponential_distribution.3cxx 66: warning: numeric expression expected (got `m')
std::gamma_distribution.3cxx 79: normal or special character expected (got a space)
std::ios_base.3cxx 636: warning: macro `Minimum' not defined
std::linear_congruential_engine.3cxx 82: warning: numeric expression expected (got `f')
std::lognormal_distribution.3cxx 79: warning: numeric expression expected (got `r')
std::normal_distribution.3cxx 79: warning: numeric expression expected (got `g')
std::regex_constants.3cxx 200: warning: macro `,' not defined
std::regex_token_iterator.3cxx  Invalid or incomplete multibyte or wide character
std::regex_traits.3cxx  Invalid or incomplete multibyte or wide character
std::student_t_distribution.3cxx 76: warning: numeric expression expected (got `r')
std::weibull_distribution.3cxx 69: normal or special character expected (got a space)

SGIextensions.3cxx  Invalid or incomplete multibyte or wide character
__gnu_cxx.3cxx  Invalid or incomplete multibyte or wide character
__gnu_cxx::debug_allocator.3cxx  Invalid or incomplete multibyte or wide character
__gnu_cxx::malloc_allocator.3cxx  Invalid or incomplete multibyte or wide character
__gnu_cxx::new_allocator.3cxx  Invalid or incomplete multibyte or wide character
__gnu_cxx::stdio_filebuf.3cxx  Invalid or incomplete multibyte or wide character
__gnu_parallel.3cxx  Invalid or incomplete multibyte or wide character
std::basic_fstream.3cxx  Invalid or incomplete multibyte or wide character
std::basic_ifstream.3cxx  Invalid or incomplete multibyte or wide character
std::basic_iostream.3cxx  Invalid or incomplete multibyte or wide character
std::basic_ofstream.3cxx  Invalid or incomplete multibyte or wide character
std::basic_ostream.3cxx  Invalid or incomplete multibyte or wide character
std::basic_ostringstream.3cxx  Invalid or incomplete multibyte or wide character
std::basic_streambuf.3cxx  Invalid or incomplete multibyte or wide character
std::basic_stringstream.3cxx  Invalid or incomplete multibyte or wide character
std::deque.3cxx  Invalid or incomplete multibyte or wide character
Comment 1 Debian GCC Maintainers 2009-12-22 11:40:20 UTC
Created attachment 19368 [details]
man pages with errors
Comment 2 Debian GCC Maintainers 2009-12-22 11:42:20 UTC
Created attachment 19369 [details]
patch fixing two typos
Comment 3 Paolo Carlini 2009-12-30 01:21:31 UTC
Matthias, please apply your doc patchlet, thanks.
Comment 4 Paolo Carlini 2009-12-30 02:01:49 UTC
Matthias, sorry, please apply only the first hunk, I'm applying momentarily the patch from Ed fixing the second issue.
Comment 5 Paolo Carlini 2010-01-06 11:41:05 UTC
Done both.
Comment 6 Debian GCC Maintainers 2010-01-06 12:18:10 UTC
The "Invalid or incomplete multibyte or wide character" messages were generated due to an incorrect setup of the checking tool (lintian).
Comment 7 Paolo Carlini 2010-01-06 16:39:30 UTC
Ok, thanks. Can you summarize the present status, then? Outstanding issues, maybe more patchlets... ;)
Comment 8 Benjamin Kosnik 2010-01-07 18:37:19 UTC
Created attachment 19502 [details]
log of man page creation
Comment 9 Benjamin Kosnik 2010-01-07 18:40:02 UTC
The rest of these look bogus to me. 

__gnu_cxx::enc_filebuf.3cxx 805: warning: macro `If' not defined
__gnu_cxx::stdio_sync_filebuf.3cxx 699: warning: macro `If' not defined
std::basic_filebuf.3cxx 905: warning: macro `If' not defined
std::basic_ios.3cxx 1123: warning: macro `Minimum' not defined
std::basic_istream.3cxx 988: warning: macro `)).' not defined
std::basic_istringstream.3cxx 1011: warning: macro `)).' not defined
std::basic_stringbuf.3cxx 723: warning: macro `If' not defined

These look fine, and the generated file seems normal, ie this error looks like

.PP
If no file is currently open, this function immediately fails.
.PP

in the __gnu_cxx::enc_filebuf.3 file.

So it looks like this can be closed to me but I'll wait for confirmation.
Comment 10 Paolo Carlini 2010-01-20 13:12:09 UTC
Ok, let's close this one as fixed...
Comment 11 Matthias Klose 2010-01-20 13:58:30 UTC
the man pages still have problems with escape codes used (prefix backslashes); I didn't build and run the check tool yet again.

  Matthias
Comment 12 Paolo Carlini 2010-01-20 14:00:37 UTC
Ok, let's re-open to be safe: please provide as soon as possible to Benjamin the information he needs...
Comment 13 Matthias Klose 2010-01-21 14:30:51 UTC
std::basic_ios.3, std::basic_ofstream.3, std::basic_ostream.3, std::basic_ostringstream.3, std::ios_base.3:

.PP
Definition at line 657 of file ios_base.h.
.SS "\fBstreamsize\fP std::ios_base::width () const\fC [inline, inherited]\fP"
.PP
Flags access. \fBReturns:\fP
.RS 4
The minimum field width to generate on output operations.
.RE
.PP
'Minimum field width' refers to the number of characters. 
.PP

The ' should be escaped as \', or else the paragraph is just discarded; unsure how this should be formatted (quoting as \" for doxygen?). other places are quotations from the standard, like:

src/libstdc++-v3/include/std/streambuf

       *  'If it returns a positive value, then successive calls to
       *  @c underflow() will not return @c traits::eof() until at least that
       *  number of characters have been supplied.  If @c showmanyc()
       *  returns -1, then calls to @c underflow() or @c uflow() will fail.'
       *  [27.5.2.4.3]/1

Extraction into another streambuf. \fBParameters:\fP
.RS 4
\fIsb\fP A streambuf in which to store data. 
.RE
.PP
\fBReturns:\fP
.RS 4
*this
.RE
.PP
Returns \fCget\fP(sb,widen('
.br
')). 
.PP
Definition at line 365 of file istream.

libstdc++-v3/include/std/istream

       *  Returns @c get(sb,widen('\n')).

unqoted quote and unqoted backslash, so make this "\\\"\? There are other places.


std::linear_congruential_engine.3
A random number generator that produces pseudorandom numbers using the linear function $x_{i+1}\leftarrow(ax_{i} + c) \bmod m $.

std::exponential_distribution.3
The formula for the exponential probability density function is $ p(x|\lambda) = \lambda e^{-\lambda x} $.

Tex is used instead of eqn. Didn't see a directive to not include this not for the manpages.

So far, no bad checks from the checker, these all look like real problems.
Comment 14 Benjamin Kosnik 2010-02-03 23:07:41 UTC
Got it Matthias, fixing, thanks for explaining what's up.

How do you get these errors and validate the generated man pages? If it's a script can you attach it? Are you re-configuring doxygen? Or is this post-generation of the 'doc-man-doxygen' rule?
Comment 15 Benjamin Kosnik 2010-02-04 00:16:27 UTC
markup options

    /**
     *  @brief  Flags access.
     *  @return  The minimum field width to generate on output operations.
     *
     *  "Minimum field width" refers to the number of characters.
     *
     *  "
     *  Minimum field width
     *  "
     *  refers to the number of characters.
     *
     *  <em>
     *  Minimum field width
     *  </em>
     *  refers to the number of characters.
     *
     *  @a Minimum field width
     *  refers to the number of characters.
    */
 
Comment 16 Benjamin Kosnik 2010-02-04 18:20:53 UTC
Subject: Bug 42460

Author: bkoz
Date: Thu Feb  4 18:20:34 2010
New Revision: 156502

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=156502
Log:
2010-02-04  Benjamin Kosnik  <bkoz@redhat.com>

	PR libstdc++/42460
	* doc/doxygen/user.cfg.in: Update file list.
	* include/debug/safe_sequence.h: Doxygen markup fixes for '' and "".
	* include/debug/safe_base.h: Same.
	* include/debug/macros.h: Same.
	* include/tr1_impl/regex: Same.
	* include/std/iostream: Same.
	* include/std/streambuf: Same.
	* include/std/bitset: Same.
	* include/std/iosfwd: Same.
	* include/std/limits: Same.
	* include/std/fstream: Same.
	* include/std/istream: Same.
	* include/std/ostream: Same.
	* include/std/sstream: Same.
	* include/parallel/multiway_merge.h: Same.
	* include/parallel/for_each.h: Same.
	* include/parallel/workstealing.h: Same.
	* include/parallel/omp_loop_static.h: Same.
	* include/parallel/omp_loop.h: Same.
	* include/c_std/csignal: Same.
	* include/c_std/cstdlib: Same.
	* include/c_std/cstdio: Same.
	* include/c_std/cstdarg: Same.
	* include/c_std/cctype: Same.
	* include/c_std/cerrno: Same.
	* include/c_std/cmath: Same.
	* include/c_std/ciso646: Same.
	* include/c_std/ctime: Same.
	* include/c_std/clocale: Same.
	* include/c_std/climits: Same.
	* include/c_std/cassert: Same.
	* include/c_std/csetjmp: Same.
	* include/c_std/cwchar: Same.
	* include/c_std/cfloat: Same.
	* include/c_std/cstring: Same.
	* include/c_std/cstddef: Same.
	* include/c_std/cwctype: Same.
	* include/profile/iterator_tracker.h: Same.
	* include/profile/impl/profiler_trace.h: Same.
	* include/ext/vstring.h: Same.
	* include/ext/algorithm: Same.
	* include/ext/pb_ds/detail/pat_trie_/pat_trie_.h.pp: Same.
	* include/ext/pb_ds/detail/bin_search_tree_/bin_search_tree_.h.pp: Same.
	* include/ext/pb_ds/detail/type_utils.hpp: Same.
	* include/ext/pb_ds/detail/splay_tree_/splay_tree_.hpp: Same
	* include/ext/pb_ds/detail/rb_tree_map_/rb_tree_.hpp: Same.
	* include/ext/rc_string_base.h: Same.
	* include/ext/stdio_sync_filebuf.h: Same.
	* include/ext/functional: Same.
	* include/ext/mt_allocator.h: Same.
	* include/bits/basic_ios.h: Same.
	* include/bits/stl_map.h: Same.
	* include/bits/stl_algobase.h: Same.
	* include/bits/stl_queue.h: Same.
	* include/bits/locale_classes.h: Same.
	* include/bits/stl_set.h: Same.
	* include/bits/locale_facets.h: Same.
	* include/bits/stl_stack.h: Same.
	* include/bits/stl_iterator_base_types.h: Same.
	* include/bits/basic_string.h: Same.
	* include/bits/stl_multimap.h: Same.
	* include/bits/ios_base.h: Same.
	* include/bits/stl_deque.h: Same.
	* include/bits/stl_multiset.h: Same.
	* include/bits/stl_iterator_base_funcs.h: Same.
	* include/bits/char_traits.h: Same.
	* include/bits/stl_algo.h: Same.
	* include/bits/stl_iterator.h: Same.
	* include/bits/stl_tempbuf.h: Same.
	* include/bits/random.tcc: Same.
	* include/bits/stl_function.h: Same.
	* include/bits/cpp_type_traits.h: Same.
	* include/bits/random.h: Same.
	* include/bits/allocator.h: Same.
	* include/bits/locale_facets_nonio.h: Same.
	* include/c_global/csignal: Same.
	* include/c_global/cstdlib: Same.
	* include/c_global/cstdio: Same.
	* include/c_global/cstdarg: Same.
	* include/c_global/cctype: Same.
	* include/c_global/cerrno: Same.
	* include/c_global/cmath: Same.
	* include/c_global/ciso646: Same.
	* include/c_global/ctime: Same.
	* include/c_global/clocale: Same.
	* include/c_global/climits: Same.
	* include/c_global/cassert: Same.
	* include/c_global/csetjmp: Same.
	* include/c_global/cwchar: Same.
	* include/c_global/cfloat: Same.
	* include/c_global/cstring: Same.
	* include/c_global/cstddef: Same.
	* include/c_global/cwctype: Same.
	* include/tr1/hypergeometric.tcc: Same.
	* include/tr1/random.tcc: Same.
	* include/tr1/functional: Same.
	* include/tr1/random.h: Same.
	* include/backward/auto_ptr.h: Same.
	* include/backward/binders.h: Same.
	* testsuite/23_containers/deque/requirements/dr438/assign_neg.cc:
	Adjust line numbers.
	* testsuite/23_containers/deque/requirements/dr438/insert_neg.cc: Same.
	* testsuite/23_containers/deque/requirements/dr438/constructor_1_neg.cc:
	Same.
	* testsuite/23_containers/deque/requirements/dr438/constructor_2_neg.cc:
	Same.


Modified:
    trunk/libstdc++-v3/ChangeLog
    trunk/libstdc++-v3/doc/doxygen/user.cfg.in
    trunk/libstdc++-v3/include/backward/auto_ptr.h
    trunk/libstdc++-v3/include/backward/binders.h
    trunk/libstdc++-v3/include/bits/allocator.h
    trunk/libstdc++-v3/include/bits/basic_ios.h
    trunk/libstdc++-v3/include/bits/basic_string.h
    trunk/libstdc++-v3/include/bits/char_traits.h
    trunk/libstdc++-v3/include/bits/cpp_type_traits.h
    trunk/libstdc++-v3/include/bits/ios_base.h
    trunk/libstdc++-v3/include/bits/locale_classes.h
    trunk/libstdc++-v3/include/bits/locale_facets.h
    trunk/libstdc++-v3/include/bits/locale_facets_nonio.h
    trunk/libstdc++-v3/include/bits/random.h
    trunk/libstdc++-v3/include/bits/random.tcc
    trunk/libstdc++-v3/include/bits/stl_algo.h
    trunk/libstdc++-v3/include/bits/stl_algobase.h
    trunk/libstdc++-v3/include/bits/stl_deque.h
    trunk/libstdc++-v3/include/bits/stl_function.h
    trunk/libstdc++-v3/include/bits/stl_iterator.h
    trunk/libstdc++-v3/include/bits/stl_iterator_base_funcs.h
    trunk/libstdc++-v3/include/bits/stl_iterator_base_types.h
    trunk/libstdc++-v3/include/bits/stl_map.h
    trunk/libstdc++-v3/include/bits/stl_multimap.h
    trunk/libstdc++-v3/include/bits/stl_multiset.h
    trunk/libstdc++-v3/include/bits/stl_queue.h
    trunk/libstdc++-v3/include/bits/stl_set.h
    trunk/libstdc++-v3/include/bits/stl_stack.h
    trunk/libstdc++-v3/include/bits/stl_tempbuf.h
    trunk/libstdc++-v3/include/c_global/cassert
    trunk/libstdc++-v3/include/c_global/cctype
    trunk/libstdc++-v3/include/c_global/cerrno
    trunk/libstdc++-v3/include/c_global/cfloat
    trunk/libstdc++-v3/include/c_global/ciso646
    trunk/libstdc++-v3/include/c_global/climits
    trunk/libstdc++-v3/include/c_global/clocale
    trunk/libstdc++-v3/include/c_global/cmath
    trunk/libstdc++-v3/include/c_global/csetjmp
    trunk/libstdc++-v3/include/c_global/csignal
    trunk/libstdc++-v3/include/c_global/cstdarg
    trunk/libstdc++-v3/include/c_global/cstddef
    trunk/libstdc++-v3/include/c_global/cstdio
    trunk/libstdc++-v3/include/c_global/cstdlib
    trunk/libstdc++-v3/include/c_global/cstring
    trunk/libstdc++-v3/include/c_global/ctime
    trunk/libstdc++-v3/include/c_global/cwchar
    trunk/libstdc++-v3/include/c_global/cwctype
    trunk/libstdc++-v3/include/c_std/cassert
    trunk/libstdc++-v3/include/c_std/cctype
    trunk/libstdc++-v3/include/c_std/cerrno
    trunk/libstdc++-v3/include/c_std/cfloat
    trunk/libstdc++-v3/include/c_std/ciso646
    trunk/libstdc++-v3/include/c_std/climits
    trunk/libstdc++-v3/include/c_std/clocale
    trunk/libstdc++-v3/include/c_std/cmath
    trunk/libstdc++-v3/include/c_std/csetjmp
    trunk/libstdc++-v3/include/c_std/csignal
    trunk/libstdc++-v3/include/c_std/cstdarg
    trunk/libstdc++-v3/include/c_std/cstddef
    trunk/libstdc++-v3/include/c_std/cstdio
    trunk/libstdc++-v3/include/c_std/cstdlib
    trunk/libstdc++-v3/include/c_std/cstring
    trunk/libstdc++-v3/include/c_std/ctime
    trunk/libstdc++-v3/include/c_std/cwchar
    trunk/libstdc++-v3/include/c_std/cwctype
    trunk/libstdc++-v3/include/debug/macros.h
    trunk/libstdc++-v3/include/debug/safe_base.h
    trunk/libstdc++-v3/include/debug/safe_sequence.h
    trunk/libstdc++-v3/include/ext/algorithm
    trunk/libstdc++-v3/include/ext/functional
    trunk/libstdc++-v3/include/ext/mt_allocator.h
    trunk/libstdc++-v3/include/ext/pb_ds/detail/bin_search_tree_/bin_search_tree_.hpp
    trunk/libstdc++-v3/include/ext/pb_ds/detail/pat_trie_/pat_trie_.hpp
    trunk/libstdc++-v3/include/ext/pb_ds/detail/rb_tree_map_/rb_tree_.hpp
    trunk/libstdc++-v3/include/ext/pb_ds/detail/splay_tree_/splay_tree_.hpp
    trunk/libstdc++-v3/include/ext/pb_ds/detail/type_utils.hpp
    trunk/libstdc++-v3/include/ext/rc_string_base.h
    trunk/libstdc++-v3/include/ext/stdio_sync_filebuf.h
    trunk/libstdc++-v3/include/ext/vstring.h
    trunk/libstdc++-v3/include/parallel/for_each.h
    trunk/libstdc++-v3/include/parallel/multiway_merge.h
    trunk/libstdc++-v3/include/parallel/omp_loop.h
    trunk/libstdc++-v3/include/parallel/omp_loop_static.h
    trunk/libstdc++-v3/include/parallel/workstealing.h
    trunk/libstdc++-v3/include/profile/impl/profiler_trace.h
    trunk/libstdc++-v3/include/profile/iterator_tracker.h
    trunk/libstdc++-v3/include/std/bitset
    trunk/libstdc++-v3/include/std/fstream
    trunk/libstdc++-v3/include/std/iosfwd
    trunk/libstdc++-v3/include/std/iostream
    trunk/libstdc++-v3/include/std/istream
    trunk/libstdc++-v3/include/std/limits
    trunk/libstdc++-v3/include/std/ostream
    trunk/libstdc++-v3/include/std/sstream
    trunk/libstdc++-v3/include/std/streambuf
    trunk/libstdc++-v3/include/tr1/functional
    trunk/libstdc++-v3/include/tr1/hypergeometric.tcc
    trunk/libstdc++-v3/include/tr1/random.h
    trunk/libstdc++-v3/include/tr1/random.tcc
    trunk/libstdc++-v3/include/tr1_impl/regex
    trunk/libstdc++-v3/testsuite/23_containers/deque/requirements/dr438/assign_neg.cc
    trunk/libstdc++-v3/testsuite/23_containers/deque/requirements/dr438/constructor_1_neg.cc
    trunk/libstdc++-v3/testsuite/23_containers/deque/requirements/dr438/constructor_2_neg.cc
    trunk/libstdc++-v3/testsuite/23_containers/deque/requirements/dr438/insert_neg.cc

Comment 17 Benjamin Kosnik 2010-02-04 18:27:50 UTC
Hey. Can you re-check trunk now? I should have most of the quoting issues fixed.

I've uploaded man pages with the new markup here:
ftp://gcc.gnu.org/pub/libstdc++/doxygen/libstdc++-man.20100204.tar.bz2

Can you check these (or equivalent from trunk) please?
Comment 18 Debian GCC Maintainers 2010-02-04 18:39:57 UTC
this is a check run by the lintian tool to check .deb packages after they are built. for this check, lintian calls 'man --warnings -E UTF-8 -l <file>' for every generated manpage. Afaik Debian/Ubuntu do use another man implementation than Fedora, so I don't know if this option is available there as well.
Comment 19 Debian GCC Maintainers 2010-02-04 21:00:52 UTC
std::basic_fstream.3cxx.gz 1213: warning: macro `)).' not defined
std::basic_ifstream.3cxx.gz 1037: warning: macro `)).' not defined
std::basic_iostream.3cxx.gz 1172: warning: macro `)).' not defined
std::basic_istream.3cxx.gz 1002: warning: macro `)).' not defined
std::basic_istringstream.3cxx.gz 1025: warning: macro `)).' not defined
std::basic_stringstream.3cxx.gz 1202: warning: macro `)).' not defined
std::exponential_distribution.3cxx.gz 66: warning: numeric expression expected (got `m')
std::gamma_distribution.3cxx.gz 79: normal or special character expected (got a space)
std::linear_congruential_engine.3cxx.gz 82: warning: numeric expression expected (got `f')
std::lognormal_distribution.3cxx.gz 79: warning: numeric expression expected (got `r')
std::normal_distribution.3cxx.gz 79: warning: numeric expression expected (got `g')
std::regex_constants.3cxx.gz 200: warning: macro `,' not defined
std::student_t_distribution.3cxx.gz 76: warning: numeric expression expected (got `r')
std::weibull_distribution.3cxx.gz 69: normal or special character expected (got a space)

The one class of quoting problems seems to be fixed. 

remaining:

include/std/istream:403: Returns @c getline(s,n,widen(&apos;\n&apos;))
include/std/istream:363: Returns @c getline(s,n,widen(&apos;\n&apos;))
include/std/istream:330: Returns @c get(s,n,widen(&apos;\n&apos;))

which translates to:

.PP
Returns \fCget\fP(sb,widen('
.br
')). 
.PP

quoting the backslash, I get this output (man not complaining anymore)
   template<typename _CharT, typename _Traits> __istream_type& std::basic_istream< _CharT, _Traits >::get
       (char_type * __s, streamsize __n) [inline, inherited]
       Simple multiple-character extraction. Parameters:
           s Pointer to an array.
           n Maximum number of characters to store in s.

       Returns:
           *this

       Returns get(s,n,widen('\n')).

       Definition at line 333 of file istream.

the other errors in the *distribution man pages are from using latex macros.

  Matthias
Comment 20 Debian GCC Maintainers 2010-02-04 21:02:12 UTC
Created attachment 19806 [details]
fix \n quoting

fixes the manual page, didn't check the html output
Comment 21 Benjamin Kosnik 2010-02-09 04:50:11 UTC
Subject: Bug 42460

Author: bkoz
Date: Tue Feb  9 04:49:49 2010
New Revision: 156617

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=156617
Log:
2010-02-08  Benjamin Kosnik  <bkoz@redhat.com>

	PR libstdc++/42460
	* include/tr1_impl/regex: Fix quoting issues in doxygen markup.
	* include/bits/random.h: Fix multi-line doxygen function markup.

2010-02-08  Matthias Klose  <doko@debian.org>

	PR libstdc++/42460
	* include/std/istream: Fix '\' quoting in doxygen markup.


Modified:
    trunk/libstdc++-v3/ChangeLog
    trunk/libstdc++-v3/include/bits/random.h
    trunk/libstdc++-v3/include/std/istream
    trunk/libstdc++-v3/include/tr1_impl/regex

Comment 22 Paolo Carlini 2010-02-17 09:36:45 UTC
So... shall we close this as fixed?
Comment 23 Benjamin Kosnik 2010-02-18 19:09:30 UTC
Subject: Re:  man page errors for generated libstdc++
 man pages


> 2010-02-17 09:36 ------- So... shall we close this as fixed?

Remaining item is doxygen function markup is not working for man pages.
But this is an upstream (doxygen) doxygen, and this
closed. I do not see any other thing to do from a libstdc++ POV.

Original reporter calls?

-benjamin
Comment 24 Debian GCC Maintainers 2010-02-23 01:37:57 UTC
thanks for the fixes. I don't care that much about the function markups.

  Matthias
Comment 25 Richard Biener 2010-04-06 11:20:43 UTC
GCC 4.5.0 is being released.  Deferring to 4.5.1.
Comment 26 Paolo Carlini 2010-04-06 11:22:15 UTC
Let's just close it as fixed.