Bug 42417 - ICE in change_address_1 for 173.applu with -mvsx
ICE in change_address_1 for 173.applu with -mvsx
Status: RESOLVED DUPLICATE of bug 42416
Product: gcc
Classification: Unclassified
Component: target
4.5.0
: P3 normal
: ---
Assigned To: Not yet assigned to anyone
: ice-on-valid-code
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-17 22:15 UTC by Janis Johnson
Modified: 2010-01-08 18:01 UTC (History)
2 users (show)

See Also:
Host:
Target: powerpc64-linux
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janis Johnson 2009-12-17 22:15:30 UTC
GCC trunk gets a ICE when building SPEC CPU2000 test 173.applu and several others with "-O2 -mvsx -mno-altivec -ftree-vectorize", as demonstrated by this minimized testcase:

      subroutine ssor
      implicit real*8 (a-h,o-z)
      parameter (iar = 60)
      common/cgcon/ nx, ny, nz
      common/cvar/ u(5,iar,iar,iar), rsd(5,iar,iar,iar)
      common/ctscon/ itmax
      do istep = 1, itmax
         call jacld
         do k = 2, nz-1
            do j = 2, ny-1
               do i = 2, nx-1
                  do m = 1, 5
                     u( m, i, j, k ) = u( m, i, j, k )
     $                    + tmp * rsd( m, i, j, k )
                  end do
               end do
            end do
         end do
      end do
      return
      end

elm3b149% /home/janis/tools/gcc-trunk-anonsvn/bin/gfortran -O2 -mvsx -mno-altivec -ftree-vectorize -c bug.f
bug.f: In function ‘ssor’:
bug.f:21:0: internal compiler error: in change_address_1, at emit-rtl.c:1912
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.

VSX support is new in GCC 4.5 so this is not a regression from earlier releases.
Comment 1 revital eres 2009-12-22 08:58:08 UTC
(In reply to comment #0)
> GCC trunk gets a ICE when building SPEC CPU2000 test 173.applu and several
> others with "-O2 -mvsx -mno-altivec -ftree-vectorize", as demonstrated by this

-mvsx -mno-altivec should not be allowed as a compiler option.
Comment 2 Janis Johnson 2010-01-08 18:01:17 UTC

*** This bug has been marked as a duplicate of 42416 ***