Bug 42347 - [4.5/4.6 Regression] sched-deps.c:3840:1: internal compiler error: in fixup_reorder_chain, at cfglayout.c:796
Summary: [4.5/4.6 Regression] sched-deps.c:3840:1: internal compiler error: in fixup_r...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 4.5.0
: P2 normal
Target Milestone: 4.5.1
Assignee: Jakub Jelinek
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2009-12-10 10:15 UTC by Douglas Mencken
Modified: 2010-06-08 14:49 UTC (History)
4 users (show)

See Also:
Host: powerpc-gnu-linux-uclibc
Target: powerpc-gnu-linux-uclibc
Build: powerpc-gnu-linux-uclibc
Known to work:
Known to fail:
Last reconfirmed:


Attachments
sched-deps.i, generated by adding -save-temps (15.12 KB, text/plain)
2009-12-10 10:55 UTC, Douglas Mencken
Details
powerpc64-broken-unreachable.i (395 bytes, text/plain)
2010-05-17 07:53 UTC, Siarhei Siamashka
Details
gcc46-pr42347.patch (565 bytes, patch)
2010-05-17 13:24 UTC, Jakub Jelinek
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Douglas Mencken 2009-12-10 10:15:11 UTC
Bootstrap of gcc-4.5-2009120 resulted in an error: http://pastebin.com/m3047a96f

Current GCC:

Target: powerpc-pc-linux-uclibc
Configured with: ./configure --build=powerpc-pc-linux-uclibc --host=powerpc-pc-linux-uclibc --target=powerpc-pc-linux-uclibc --disable-nls --with-system-zlib --disable-checking --disable-werror --disable-multilib --disable-libssp --enable-languages=c,c++ --enable-shared --enable-threads=posix --disable-__cxa_atexit
Thread model: posix
gcc version 4.4.2 (GCC) 

gcc-4.5-20091203 was configured the same way:

./configure --build=powerpc-pc-linux-uclibc --host=powerpc-pc-linux-uclibc --target=powerpc-pc-linux-uclibc --disable-nls --with-system-zlib --disable-checking --disable-werror --disable-multilib --disable-libssp --enable-languages=c,c++ --enable-shared --enable-threads=posix --disable-__cxa_atexit

then just 'make'
Comment 1 Douglas Mencken 2009-12-10 10:55:34 UTC
Created attachment 19274 [details]
sched-deps.i, generated by adding -save-temps
Comment 2 Richard Biener 2009-12-10 12:09:39 UTC
As the host compiler is a same configured 4.4 this looks like a regression.
Comment 3 Douglas Mencken 2010-01-23 11:53:38 UTC
May I add that GCC 4.4.3 bootstraps perfectly with the same config without any single issue.
Comment 4 Steven Bosscher 2010-01-23 12:06:11 UTC
Don't use pastebin please. It's impossible to see what you dumped there.
Comment 5 Siarhei Siamashka 2010-04-03 17:39:18 UTC
Got exactly the same ICE on ARM, bootstrapping gcc:

/var/tmp/portage/sys-devel/gcc-4.5.0_alpha20100401/work/gcc-4.5-20100401/gcc/sched-deps.c: In function ‘get_dep_weak_1’:
/var/tmp/portage/sys-devel/gcc-4.5.0_alpha20100401/work/gcc-4.5-20100401/gcc/sched-deps.c:3841:1: internal compiler error: in fixup_reorder_chain, at cfglayout.c:796
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugs.gentoo.org/> for instructions.

But preprocessed source feeded to gcc-4.5-20100401 crosscompiler does not result in ICE. I'm going to try bootstrapping again with the patch from PR42509 and report back.
Comment 6 Siarhei Siamashka 2010-04-03 21:53:38 UTC
(In reply to comment #5)
> But preprocessed source feeded to gcc-4.5-20100401 crosscompiler does not
> result in ICE. I'm going to try bootstrapping again with the patch from PR42509
> and report back.

This patch alone did not help. Will try to bootstrap SVN head now and do a few more tests. It can take many hours because native compilation on ARM is relatively slow.
Comment 7 Siarhei Siamashka 2010-04-06 11:01:29 UTC
Long story short. This bootstrap failure seems to be related to --disable-checking configure option. Reproduced on powerpc-unknown-linux-gnu and armv7l-unknown-linux-gnueabi. I'm re-running the tests now to be completely sure.

Maybe it is caused by some bad assert with a side effect?
Comment 8 Steven Bosscher 2010-04-06 11:07:29 UTC
It would be really helpful if someone can explain how to reproduce this with a cross-compiler. I will analyze/fix this problem when this is reproducible with a cross.
Comment 9 Richard Biener 2010-04-06 11:20:43 UTC
GCC 4.5.0 is being released.  Deferring to 4.5.1.
Comment 10 Siarhei Siamashka 2010-04-06 14:44:30 UTC
(In reply to comment #8)
> It would be really helpful if someone can explain how to reproduce this with a
> cross-compiler. I will analyze/fix this problem when this is reproducible with
> a cross.

I'm afraid this is not (easily) reproducible with a cross-compiler.

Now I double checked everything and "--disable-checking" option really does break bootstrap on ppc and arm. Replacing it with "--enable-checking=assert" results in a successful build. It's also interesting that this bug does not affect x86 or x86-64.

I think a simple script can be used for bisecting and may help to find a problematic "gcc_assert" (if it's really a problem). But this all will probably take at least a few days to run till completion, neither arm nor ppc hardware that I have is particularly fast...

Avoiding the use of "--disable-checking" option can be used as a workaround for now.
Comment 11 Douglas Mencken 2010-04-27 17:07:23 UTC
GCC 4.5.0 bootstraps without --disable-checking (Configured with: ./configure --prefix=/usr --sysconfdir=/etc
--mandir=/usr/share/man --build=powerpc-gnu-linux-uclibc
--host=powerpc-gnu-linux-uclibc --target=powerpc-gnu-linux-uclibc
--with-system-zlib --enable-languages=c,c++,fortran --disable-nls
--disable-werror --disable-multilib --disable-libssp --enable-checking=assert
--enable-shared --enable-threads=posix --disable-__cxa_atexit
), with that, it fails again. Also, both "retail" (not-svn) 4.4.3, which bootstraps with --disable-checking, and "retail" 4.5.0, which doesn't, do actually have an another huge problem: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43911 (I don't know are they related to each other, just want you to know about that g++ problem).

I can't say how to reproduce this sched-deps bug in cross-toolchain (which cross toolchain exactly? or is it x86 host "by default"?), but I can try to bootstrap cross 4.5.0 as host-ppc build-ppc target-x86, if you will request it. I can also assist in "bisecting" to find bad commit for sched-deps bug (one bootstrap of native toolch on my hardware takes 10-12 hours).
Comment 12 Douglas Mencken 2010-04-27 19:13:48 UTC
$ cat /usr/lib/libgcc_s.so
/* GNU ld script
   Use the shared library, but some functions are only in
   the static library.  */
GROUP ( libgcc_s.so.1 libgcc.a )

$ readelf -s /usr/lib/libgcc_s.so.1 | grep Unwind
     3: 00010a80   580 FUNC    GLOBAL DEFAULT    9 _Unwind_Find_FDE@@GCC_3.0
    11: 0000bd78     8 FUNC    GLOBAL DEFAULT    9 _Unwind_GetIP@@GCC_3.0
    19: 0000e84c   496 FUNC    GLOBAL DEFAULT    9 _Unwind_Resume_or_Rethrow@@GCC_3.3
    26: 0000bda4     8 FUNC    GLOBAL DEFAULT    9 _Unwind_GetRegionStart@@GCC_3.0
    27: 0000ea74   456 FUNC    GLOBAL DEFAULT    9 _Unwind_Backtrace@@GCC_3.3
    30: 0000bccc     8 FUNC    GLOBAL DEFAULT    9 _Unwind_GetCFA@@GCC_3.3
    68: 0000e654   504 FUNC    GLOBAL DEFAULT    9 _Unwind_Resume@@GCC_3.0
    69: 0000ea3c    56 FUNC    GLOBAL DEFAULT    9 _Unwind_DeleteException@@GCC_3.0
    89: 0000e1e0   648 FUNC    GLOBAL DEFAULT    9 _Unwind_RaiseException@@GCC_3.0
    94: 0000bd94     8 FUNC    GLOBAL DEFAULT    9 _Unwind_SetIP@@GCC_3.0
   116: 0000bdec     8 FUNC    GLOBAL DEFAULT    9 _Unwind_GetTextRelBase@@GCC_3.0
   118: 0000bdac    56 FUNC    GLOBAL DEFAULT    9 _Unwind_FindEnclosingFunc@@GCC_3.3
   119: 0000bd9c     8 FUNC    GLOBAL DEFAULT    9 _Unwind_GetLanguageSpecif@@GCC_3.0
   122: 0000e468   492 FUNC    GLOBAL DEFAULT    9 _Unwind_ForcedUnwind@@GCC_3.0
   126: 0000bcd8   160 FUNC    GLOBAL DEFAULT    9 _Unwind_SetGR@@GCC_3.0
   132: 0000bc44   136 FUNC    GLOBAL DEFAULT    9 _Unwind_GetGR@@GCC_3.0
   136: 0000bde4     8 FUNC    GLOBAL DEFAULT    9 _Unwind_GetDataRelBase@@GCC_3.0
   159: 0000b6a4     4 FUNC    LOCAL  DEFAULT    9 _Unwind_DebugHook
   169: 0000debc   276 FUNC    LOCAL  DEFAULT    9 _Unwind_ForcedUnwind_Phas
   170: 0000dfd0   244 FUNC    LOCAL  DEFAULT    9 _Unwind_RaiseException_Ph
   189: 000100e8  1308 FUNC    LOCAL  DEFAULT    9 _Unwind_IteratePhdrCallba
   212: 0000bd80    20 FUNC    LOCAL  DEFAULT    9 _Unwind_GetIPInfo
   242: 00010a80   580 FUNC    GLOBAL DEFAULT    9 _Unwind_Find_FDE
   250: 0000bd78     8 FUNC    GLOBAL DEFAULT    9 _Unwind_GetIP
   258: 0000e84c   496 FUNC    GLOBAL DEFAULT    9 _Unwind_Resume_or_Rethrow
   265: 0000bda4     8 FUNC    GLOBAL DEFAULT    9 _Unwind_GetRegionStart
   266: 0000ea74   456 FUNC    GLOBAL DEFAULT    9 _Unwind_Backtrace
   269: 0000bccc     8 FUNC    GLOBAL DEFAULT    9 _Unwind_GetCFA
   307: 0000e654   504 FUNC    GLOBAL DEFAULT    9 _Unwind_Resume
   308: 0000ea3c    56 FUNC    GLOBAL DEFAULT    9 _Unwind_DeleteException
   328: 0000e1e0   648 FUNC    GLOBAL DEFAULT    9 _Unwind_RaiseException
   333: 0000bd94     8 FUNC    GLOBAL DEFAULT    9 _Unwind_SetIP
   355: 0000bdec     8 FUNC    GLOBAL DEFAULT    9 _Unwind_GetTextRelBase
   357: 0000bdac    56 FUNC    GLOBAL DEFAULT    9 _Unwind_FindEnclosingFunc
   358: 0000bd9c     8 FUNC    GLOBAL DEFAULT    9 _Unwind_GetLanguageSpecif
   361: 0000e468   492 FUNC    GLOBAL DEFAULT    9 _Unwind_ForcedUnwind
   365: 0000bcd8   160 FUNC    GLOBAL DEFAULT    9 _Unwind_SetGR
   371: 0000bc44   136 FUNC    GLOBAL DEFAULT    9 _Unwind_GetGR
   375: 0000bde4     8 FUNC    GLOBAL DEFAULT    9 _Unwind_GetDataRelBase
Comment 13 Richard Biener 2010-04-28 09:16:04 UTC
May be related to PR43740 which also sees cc1 miscompilation but even with
release checking.
Comment 14 Raúl Porcel 2010-04-29 19:36:35 UTC
I tried to bisect it, however there is an issue:

gcc failed to build since http://repo.or.cz/w/official-gcc.git/commit/598767c938d0d001bbbe41e0a189104bb53e3580

Gives this error:
/root/build/./prev-gcc/xgcc -B/root/build/./prev-gcc/ -B/usr/powerpc64-unknown-linux-gnu/bin/ -B/usr/powerpc64-unknown-linux-gnu/bin/ -B/usr/powerpc64-unknown-linux-gnu/lib/ -isystem /usr/powerpc64-unknown-linux-gnu/include -isystem /usr/powerpc64-unknown-linux-gnu/sys-include    -c  -m64 -O2 -pipe -gtoggle -DIN_GCC   -W -Wall -Wwrite-strings -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes -Wmissing-format-attribute -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings -Wold-style-definition -Wc++-compat   -DHAVE_CONFIG_H -I. -I. -I../../gcc/gcc -I../../gcc/gcc/. -I../../gcc/gcc/../include -I../../gcc/gcc/../libcpp/include  -I../../gcc/gcc/../libdecnumber -I../../gcc/gcc/../libdecnumber/dpd -I../libdecnumber    ../../gcc/gcc/lambda-code.c -o lambda-code.o
../../gcc/gcc/lambda-code.c: In function 'lambda_compute_access_matrices':
../../gcc/gcc/lambda-code.c:2844:1: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
make[3]: *** [lambda-code.o] Error 1

That error was fixed with http://repo.or.cz/w/official-gcc.git/commit/9dbb96fec5e08762f97dda771522283f1fe9710f

However we now got that error of what this bug is about.
Comment 15 Siarhei Siamashka 2010-05-03 23:45:14 UTC
As found by Raúl, indeed this regression was introduced in r150091. Reverting this change in gcc 4.5.0 release resolves the problem.

Apparently the use of __builtin_unreachable() in gcc_assert macro (activated by !ENABLE_ASSERT_CHECKING) is triggering some kind of wrong-code bug on non x86/x86-64 platforms (at least arm and powerpc) and causes this bootstrap failure.

There are some other __builtin_unreachable bugs in gcc bugzilla which are possibly related.
Comment 16 Siarhei Siamashka 2010-05-04 07:04:35 UTC
So basically what we have is that gcc miscompiles itself somewhere in the code where one of those ~7000 gcc_assert is used. The next step is to identify which one of them triggers this bad behaviour (bisecting not in the svn revisions, but in gcc source files by flipping the use of __builtin_unreachable-based vs. ordinary gcc_assert implementations) and extract a reduced testcase showing __builtin_unreachable failure.
Comment 17 Douglas Mencken 2010-05-09 14:56:48 UTC
../.././gcc -I../.././gcc/. -I../.././gcc/../include -I../.././gcc/../libcpp/include  -I../.././gcc/../libdecnumber -I../.././gcc/../libdecnumber/dpd -I../libdecnumber     ../.././gcc/rtlhooks.c -o rtlhooks.o
/root/build-farm/gcc-4.5.0.srcpkg/host-powerpc-gnu-linux-uclibc/prev-gcc/xgcc -B/root/build-farm/gcc-4.5.0.srcpkg/host-powerpc-gnu-linux-uclibc/prev-gcc/ -B/usr/powerpc-gnu-linux-uclibc/bin/ -B/usr/powerpc-gnu-linux-uclibc/bin/ -B/usr/powerpc-gnu-linux-uclibc/lib/ -isystem /usr/powerpc-gnu-linux-uclibc/include -isystem /usr/powerpc-gnu-linux-uclibc/sys-include    -c  -g -O2 -gtoggle -DIN_GCC   -W -Wall -Wwrite-strings -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes -Wmissing-format-attribute -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings -Wold-style-definition -Wc++-compat   -DHAVE_CONFIG_H -I. -I. -I../.././gcc -I../.././gcc/. -I../.././gcc/../include -I../.././gcc/../libcpp/include  -I../.././gcc/../libdecnumber -I../.././gcc/../libdecnumber/dpd -I../libdecnumber     ../.././gcc/sbitmap.c -o sbitmap.o
/root/build-farm/gcc-4.5.0.srcpkg/host-powerpc-gnu-linux-uclibc/prev-gcc/xgcc -B/root/build-farm/gcc-4.5.0.srcpkg/host-powerpc-gnu-linux-uclibc/prev-gcc/ -B/usr/powerpc-gnu-linux-uclibc/bin/ -B/usr/powerpc-gnu-linux-uclibc/bin/ -B/usr/powerpc-gnu-linux-uclibc/lib/ -isystem /usr/powerpc-gnu-linux-uclibc/include -isystem /usr/powerpc-gnu-linux-uclibc/sys-include    -c  -g -O2 -gtoggle -DIN_GCC   -W -Wall -Wwrite-strings -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes -Wmissing-format-attribute -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings -Wold-style-definition -Wc++-compat   -DHAVE_CONFIG_H -I. -I. -I../.././gcc -I../.././gcc/. -I../.././gcc/../include -I../.././gcc/../libcpp/include  -I../.././gcc/../libdecnumber -I../.././gcc/../libdecnumber/dpd -I../libdecnumber     ../.././gcc/sched-deps.c -o sched-deps.o
../.././gcc/sched-deps.c: In function 'get_dep_weak_1':
../.././gcc/sched-deps.c:3841:1: internal compiler error: in fixup_reorder_chain, at cfglayout.c:796
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
make[3]: *** [sched-deps.o] Error 1
make[3]: Leaving directory `/root/build-farm/gcc-4.5.0.srcpkg/host-powerpc-gnu-linux-uclibc/gcc'
make[2]: *** [all-stage2-gcc] Error 2
make[2]: Leaving directory `/root/build-farm/gcc-4.5.0.srcpkg'
make[1]: *** [stage2-bubble] Error 2
make[1]: Leaving directory `/root/build-farm/gcc-4.5.0.srcpkg'
make: *** [all] Error 2
Command exited with non-zero status 2
real    7h 47m 02s
user    5h 39m 43s
sys     13m 48.43s
----
Tried to bootstrap GCC 4.5.0. Again.
"How TO REPRODUCE IT WITH CROSS COMPILER"? No way. Just try to build it native. And not on x86 (i386, i486, i586, i586mmx, i686, ........, x86_64, x86_64_4cores, ......). AGAIN: NOT ON intel compatible x86 or 100% compatible amd or intel compatible.
Comment 18 Siarhei Siamashka 2010-05-17 07:53:45 UTC
Created attachment 20676 [details]
powerpc64-broken-unreachable.i

With the attached file (and '-O2 -c' options):
1. powerpc64 crosscompiler running on x86 box - always works fine
2. powerpc64 crosscompiler built with gcc 4.3.4 and running on powerpc64 box - works fine
3. powerpc64 crosscompiler built with gcc 4.5.0 and running on powerpc64 box - ICE
Comment 19 Siarhei Siamashka 2010-05-17 09:06:43 UTC
Can anybody knowledgeable verify whether it was commit r151790 ( http://repo.or.cz/w/official-gcc.git/commit/9dbb96fec5e08762f97dda771522283f1fe9710f ) that is causing troubles when __builtin_unreachable() is used in the default switch case? Unfortunately I could not add Andreas Krebbel to CC for this bug.
Comment 20 Jakub Jelinek 2010-05-17 09:08:14 UTC
Perhaps dup of PR44071 that got fixed recently?
Comment 21 Siarhei Siamashka 2010-05-17 10:07:56 UTC
(In reply to comment #18)
> Created an attachment (id=20676) [edit]
> powerpc64-broken-unreachable.i
> 
> With the attached file (and '-O2 -c' options):
> 1. powerpc64 crosscompiler running on x86 box - always works fine
> 2. powerpc64 crosscompiler built with gcc 4.3.4 and running on powerpc64 box -
> works fine

Hmm, that was happening because I compiled it with "--disable-checking". When built with "--enable-checking=release", the ICE reproduces just fine on x86 box with powerpc64-unknown-linux-gnu crosscompiler.

Well, getting ssh access to a fast powerpc64 box really did miracles :) Even though the problem does not seem to be that complex after all, painfully long compile times discouraged running more tests earlier, so even a small mistake easily could (and apparently did) lead to wrong track.

I'm going to check current 4.5 SVN branch now.
Comment 22 Siarhei Siamashka 2010-05-17 11:31:27 UTC
(In reply to comment #20)
> Perhaps dup of PR44071 that got fixed recently?

The problem is still reproducible with SVN rev 159480 in 'branches/gcc-4_5-branch', so the fix from PR44071 does not seem to help here.
Comment 23 Jakub Jelinek 2010-05-17 13:24:38 UTC
Created attachment 20679 [details]
gcc46-pr42347.patch

Ah, I see.  returnjump_p is considered onlyjump_p, yet it has side-effect that
prevent it from being optimized away into a normal return or jump to return.
Comment 24 Jakub Jelinek 2010-05-17 17:20:06 UTC
Subject: Bug 42347

Author: jakub
Date: Mon May 17 17:19:46 2010
New Revision: 159496

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=159496
Log:
	PR bootstrap/42347
	* cfglayout.c (fixup_reorder_chain): Allow returnjump_p
	to have no fallthru edge.

	* gcc.c-torture/compile/pr42347.c: New test.

Added:
    trunk/gcc/testsuite/gcc.c-torture/compile/pr42347.c
Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/cfglayout.c
    trunk/gcc/testsuite/ChangeLog

Comment 25 Jakub Jelinek 2010-05-17 17:26:48 UTC
Subject: Bug 42347

Author: jakub
Date: Mon May 17 17:26:22 2010
New Revision: 159499

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=159499
Log:
	PR bootstrap/42347
	* cfglayout.c (fixup_reorder_chain): Allow returnjump_p
	to have no fallthru edge.

	* gcc.c-torture/compile/pr42347.c: New test.

Added:
    branches/gcc-4_5-branch/gcc/testsuite/g++.dg/ext/asmgoto1.C
Modified:
    branches/gcc-4_5-branch/gcc/ChangeLog
    branches/gcc-4_5-branch/gcc/cfgcleanup.c
    branches/gcc-4_5-branch/gcc/testsuite/ChangeLog

Comment 26 Jakub Jelinek 2010-05-17 17:31:14 UTC
Subject: Bug 42347

Author: jakub
Date: Mon May 17 17:30:54 2010
New Revision: 159500

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=159500
Log:
	PR bootstrap/42347
	* cfglayout.c (fixup_reorder_chain): Allow returnjump_p
	to have no fallthru edge.

	* gcc.c-torture/compile/pr42347.c: New test.

Added:
    branches/gcc-4_5-branch/gcc/testsuite/gcc.c-torture/compile/pr42347.c
Modified:
    branches/gcc-4_5-branch/gcc/ChangeLog
    branches/gcc-4_5-branch/gcc/cfglayout.c
    branches/gcc-4_5-branch/gcc/testsuite/ChangeLog

Comment 27 Jakub Jelinek 2010-05-17 17:33:45 UTC
The http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=159499
commit was actually for PR44102.
Comment 28 Siarhei Siamashka 2010-05-18 10:09:35 UTC
Thanks, this patch fixes bootstrap for powerpc/powerpc64. But still fails for arm on all the same gcc_assert() in another place. Should a new bug be filed about this?
Comment 29 Jakub Jelinek 2010-05-18 10:58:46 UTC
Please file a new PR for that, with preprocessed source and all other relevant info for reproduction.
Comment 30 Siarhei Siamashka 2010-06-08 14:49:14 UTC
(In reply to comment #29)
> Please file a new PR for that, with preprocessed source and all other relevant
> info for reproduction.

Thanks, filed PR44469