User account creation filtered due to spam.

Bug 42149 - ICE:verify_gimple failed for avr target
Summary: ICE:verify_gimple failed for avr target
Status: RESOLVED WONTFIX
Alias: None
Product: gcc
Classification: Unclassified
Component: tree-optimization (show other bugs)
Version: 4.5.0
: P3 normal
Target Milestone: 4.6.0
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2009-11-22 16:58 UTC by Andy Hutchinson
Modified: 2012-01-30 21:42 UTC (History)
3 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: avr-unknown-none
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Hutchinson 2009-11-22 16:58:22 UTC
Test trunk/gcc/testsuite/gcc.dg/matrix/matrix-1.c (and friends) fails with ICE on AVR target.

Note there is existing open bug PR37165 - but the failure noted was not ICE.


Executing on host: /media/verbatim/gcchead/obj-dir/gcc/xgcc -B/media/verbatim/gcchead/obj-dir/gcc/ /media/verbatim/gcchead/trunk/gcc/testsuite/gcc.dg/matrix/matrix-1.c   -O3 -fipa-matrix-reorg -fdump-ipa-matrix-reorg -fwhole-program -combine -DSTACK_SIZE=2048 -DNO_TRAMPOLINES  -DSIGNAL_SUPPRESS -mmcu=atmega128  /home/andy/winavrfiles/avrtest/dejagnuboards/exit.c -Wl,-u,vfprintf -lprintf_flt -Wl,-Tbss=0x802000,--defsym=__heap_end=0x80ffff  -lm   -o ./matrix-1.exe    (timeout = 300)
/media/verbatim/gcchead/trunk/gcc/testsuite/gcc.dg/matrix/matrix-1.c: In function 'mem_init':
/media/verbatim/gcchead/trunk/gcc/testsuite/gcc.dg/matrix/matrix-1.c:52:1: error: type mismatch in array reference
struct __file *

struct __file *

D.3778 = __iob[2];

/media/verbatim/gcchead/trunk/gcc/testsuite/gcc.dg/matrix/matrix-1.c:52:1: error: type mismatch in array reference
struct __file *

struct __file *

D.3778 = __iob[2];

/media/verbatim/gcchead/trunk/gcc/testsuite/gcc.dg/matrix/matrix-1.c:52:1: internal compiler error: verify_gimple failed
Please submit a full bug report,
Comment 1 Michał Mirosław 2010-03-21 18:44:40 UTC
[looks like bug #39959]

The same happens with -combine on following code (arm-none-eabi target):

a.h:

struct a {
        int b;
        int c;
};

extern struct a *p asm("r4");

void d(int *);

b.c:

#include "a.h"
void t1()
{
        d(&p->b);
}

c.c:

#include "a.h"
void t2()
{
        d(&p->c);
}

gcc -combine -c b.c c.c
b.c: In function 't1':
b.c:2:6: error: type mismatch in indirect reference
struct a

struct a

D.2762 = &p.1->b;

b.c:2:6: internal compiler error: verify_gimple failed

code 'cat' together compiles.
Comment 2 Andrew Pinski 2010-03-21 19:02:15 UTC
Combine bug (PR 39959) is a different issue from the matrix testcase.
Comment 3 Andrew Pinski 2012-01-30 21:42:42 UTC
-combine has since been removed so closing as won't fix for 4.6.0.