Bug 42120 - gcc 4.4.2 build fails on classpath
Summary: gcc 4.4.2 build fails on classpath
Status: RESOLVED DUPLICATE of bug 38715
Alias: None
Product: classpath
Classification: Unclassified
Component: classpath (show other bugs)
Version: unspecified
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-20 15:49 UTC by jblaine@mitre.org
Modified: 2009-11-20 16:36 UTC (History)
7 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jblaine@mitre.org 2009-11-20 15:49:29 UTC
SunOS cairo 5.10 Generic_138888-08 sun4u sparc SUNW,Sun-Fire-280R

# echo $PATH
/usr/sfw/bin:/usr/bin:/usr/rcf/bin
#

# gcc --version
gcc (GCC) 3.4.3 (csl-sol210-3_4-branch+sol_rpath)
#

# ../gcc-4.4.2/configure --prefix=/cairo/tmp/jblaine/4.4.2 \
--with-as=/usr/ccs/bin/as --with-ld=/usr/ccs/bin/ld \
--disable-shared --without-gnu-ld --without-gnu-as 2>&1 | tee c.log
...

# make bootstrap 2>&1 | tee m.log

...
make[6]: Entering directory `/cairo/tmp/jblaine/gcc-build-442/sparc-sun-solaris2.10/sparcv9/libjava/classpath/tools'
Makefile:839: warning: overriding commands for target `gjdoc'
Makefile:774: warning: ignoring old commands for target `gjdoc'
find ../../../../../../gcc-4.4.2/libjava/classpath/tools/external/asm -name '*.java' -print > asm.lst
find ../../../../../../gcc-4.4.2/libjava/classpath/tools/gnu/classpath/tools \
     ../../../../../../gcc-4.4.2/libjava/classpath/tools/com/sun/javadoc \
     ../../../../../../gcc-4.4.2/libjava/classpath/tools/com/sun/tools/doclets ../../../../../../gcc-4.4.2/libjava/classpath/tools/com/sun/tools/javadoc \     ../../../../../../gcc-4.4.2/libjava/classpath/tools/com/sun/tools/javac \
../../../../../../gcc-4.4.2/libjava/classpath/tools/com/sun/tools/javah \
../../../../../../gcc-4.4.2/libjava/classpath/tools/sun/rmi/rmic \
-path '*gnu/classpath/tools/gjdoc' -prune -o -path '*gnu/classpath/tools/doclets' -prune -o -path '*gnu/classpath/tools/taglets' -prune -o -path '*com/sun/javadoc' -prune -o -path '*com/sun/tools/doclets' -prune -o -path '*com/sun/tools/javadoc' -prune -o \
-name '*.java' -print > classes.lst
find: bad option -path
find: [-H | -L] path-list predicate-list
make[6]: *** [tools.zip] Error 1
make[6]: Leaving directory `/cairo/tmp/jblaine/gcc-build-442/sparc-sun-solaris2.10/sparcv9/libjava/classpath/tools'
Comment 1 Andrew Pinski 2009-11-20 16:36:05 UTC

*** This bug has been marked as a duplicate of 38715 ***