Bug 41897 - Support TS 29113: "Further Interoperability of Fortran with C"
Summary: Support TS 29113: "Further Interoperability of Fortran with C"
Status: RESOLVED DUPLICATE of bug 84894
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.5.0
: P3 enhancement
Target Milestone: ---
Assignee: Not yet assigned to anyone
Depends on: 37577 48820
  Show dependency treegraph
Reported: 2009-11-01 17:58 UTC by Tobias Burnus
Modified: 2018-03-16 10:35 UTC (History)
3 users (show)

See Also:
Known to work:
Known to fail:
Last reconfirmed: 2010-06-11 13:47:11


Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Burnus 2009-11-01 17:58:53 UTC
There is a technical report (TR 29113) in preparation to allow "Further Interoperability of Fortran with C".
Last draft is:

One thing one presumably needs to change is the way ALLOCATBLE,INTENT(OUT) variables are auto-deallocated: Currently, it happens in the caller. I think for the TR one needs to make it happen in the callee.

Note: The draft N1761 is the result of the subgroup. Not all WG5/J3 members are happy with the proposal. At the February 2009 meeting it will be discussed with all members (cf. ftp://ftp.nag.co.uk/sc22wg5/N1751-N1800/N1794.txt).
Comment 2 Tobias Burnus 2010-06-11 13:58:29 UTC
Latest draft:  ftp://ftp.nag.co.uk/sc22wg5/N1801-N1850/N1808.pdf
Time line:     ftp://ftp.nag.co.uk/sc22wg5/N1801-N1850/N1812.txt (-> 2nd draft: 2010-10)
Comment 3 Damian Rouson 2018-03-15 23:13:18 UTC
With Fortran 2018 now in Committee Draft (CD) and likely to be published this year, it probably makes sense to close this bug report.  Any features from TS 29113 that will be in Fortran 2018 have already been incorporated into the CD and it's possible that the integration process could have led to changes so the CD would be the more appropriate reference now rather than the TS.
Comment 4 Dominique d'Humieres 2018-03-16 10:35:26 UTC
Marked as duplicate of pr84894.

*** This bug has been marked as a duplicate of bug 84894 ***