Bug 41696 - java.util.zip.Inflater:finished () returns false when it should return true
java.util.zip.Inflater:finished () returns false when it should return true
Status: RESOLVED FIXED
Product: classpath
Classification: Unclassified
Component: classpath
0.98
: P3 normal
: 0.99
Assigned To: Jeroen Frijters
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-13 16:31 UTC by Zoltan Varga
Modified: 2014-02-16 13:13 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2010-01-11 08:08:00


Attachments
testcase (29.75 KB, text/x-java)
2009-10-13 16:32 UTC, Zoltan Varga
Details
proposed fix (1.12 KB, patch)
2010-01-11 08:23 UTC, Jeroen Frijters
Details | Diff
better proposed fix (1.81 KB, patch)
2010-01-11 14:09 UTC, Jeroen Frijters
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltan Varga 2009-10-13 16:31:32 UTC
In the attached testcase, Inflater.finished () returns false, while it returns
true when running with sun's jdk. If I change the buffer size in the testcase to 828 instead of 827, it works fine. Tested with classpath-0.98 and jamvm 1.5.3. This prevents jgit from working with classpath based vms.

Expected output:
true
tree fb6e71c2fb6d12a0fff28a7d72c4f7d1b2e357dc
parent 2c9862ea088ea7dc15b0beb70fe7485783763fee
...

Actual output:
false
false
false
....
Comment 1 Zoltan Varga 2009-10-13 16:32:34 UTC
Created attachment 18795 [details]
testcase
Comment 2 Jeroen Frijters 2010-01-11 08:23:13 UTC
Created attachment 19536 [details]
proposed fix

I will check this patch in into GNU Classpath cvs after some more testing.
Comment 3 Jeroen Frijters 2010-01-11 14:09:42 UTC
Created attachment 19540 [details]
better proposed fix
Comment 4 Jeroen Frijters 2010-01-12 16:50:32 UTC
Committed the patch.
Comment 5 Andrew John Hughes 2012-02-15 23:26:49 UTC
Set milestone to 0.99.
Comment 6 Jackie Rosen 2014-02-16 13:13:00 UTC
*** Bug 260998 has been marked as a duplicate of this bug. ***
Seen from the domain http://volichat.com
Page where seen: http://volichat.com/adult-chat-rooms
Marked for reference. Resolved as fixed @bugzilla.