User account creation filtered due to spam.

Bug 41685 - [OOP] internal compiler error: verify_flow_info failed
Summary: [OOP] internal compiler error: verify_flow_info failed
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.5.0
: P3 normal
Target Milestone: 4.5.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-12 14:43 UTC by Salvatore Filippone
Modified: 2016-11-16 12:16 UTC (History)
2 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments
test case--file 1 (see comments above) (255 bytes, text/plain)
2009-10-12 14:44 UTC, Salvatore Filippone
Details
test case--file 2 (see comments above) (560 bytes, text/plain)
2009-10-12 14:44 UTC, Salvatore Filippone
Details
test case--file 3 (see comments above) (697 bytes, text/plain)
2009-10-12 14:45 UTC, Salvatore Filippone
Details
t (612 bytes, text/plain)
2009-10-12 14:45 UTC, Salvatore Filippone
Details
test case--file5 (see comments above) (289 bytes, text/plain)
2009-10-12 14:45 UTC, Salvatore Filippone
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Salvatore Filippone 2009-10-12 14:43:02 UTC
The attached source code(s) produce the subject error. 
Scenario: gfortran with provisional patches for PR41656 and PR 41581 applied. 
-------------------------------------------------------------------
[sfilippo@localhost T3]$ gfortran -c const_mod.f03 base_mat_mod.f03 s_base_mat_mod.f03 s_csr_mat_mod.f03 s_mat_mod.f03 
s_mat_mod.f03: In function ‘s_sizeof’:
s_mat_mod.f03:47:0: error: case labels not sorted: 
case 1: is greater than case 1: but comes before it.
s_mat_mod.f03:47:0: internal compiler error: verify_flow_info failed
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
--------------------------------------------------------------------
Interestingly enough if I glue the files together the ICE disappears 
(which is inconvenient for testing).
-------------------------------------------------------------------
[sfilippo@localhost T3]$ cat  const_mod.f03 base_mat_mod.f03 s_base_mat_mod.f03 s_csr_mat_mod.f03 s_mat_mod.f03  >test-der6.f03 
[sfilippo@localhost T3]$ gfortran -c test-der6.f03 
[sfilippo@localhost T3]$ /bin/rm *mod *o
[sfilippo@localhost T3]$ gfortran -c test-der6.f03 
[sfilippo@localhost T3]$ 
-----------------------------------------------------------------------
Comment 1 Salvatore Filippone 2009-10-12 14:44:24 UTC
Created attachment 18787 [details]
test case--file 1 (see comments above)
Comment 2 Salvatore Filippone 2009-10-12 14:44:49 UTC
Created attachment 18788 [details]
test case--file 2 (see comments above)
Comment 3 Salvatore Filippone 2009-10-12 14:45:11 UTC
Created attachment 18789 [details]
test case--file 3 (see comments above)
Comment 4 Salvatore Filippone 2009-10-12 14:45:27 UTC
Created attachment 18790 [details]
t
Comment 5 Salvatore Filippone 2009-10-12 14:45:56 UTC
Created attachment 18791 [details]
test case--file5 (see comments above)
Comment 6 janus 2009-10-12 16:40:57 UTC
(In reply to comment #0)
> Interestingly enough if I glue the files together the ICE disappears 
> (which is inconvenient for testing).

Hm, that sounds curiously like it may be connected to PR41583 (which was fixed in r152640). Which revision are you using?
Comment 7 Dominique d'Humieres 2009-10-12 17:38:39 UTC
Works for me at revision pr152662 and with the patches for pr41629 and pr41656 (latest avatars).
Comment 8 Salvatore Filippone 2009-10-13 10:44:50 UTC
(In reply to comment #7)
> Works for me at revision pr152662 and with the patches for pr41629 and pr41656
> (latest avatars).
> 

Yup, works for me at revision 152697 + pr41656.diff
Nice to see it fixed so fast :-) 
Comment 9 janus 2009-10-13 14:22:00 UTC
(In reply to comment #8)
> Yup, works for me at revision 152697 + pr41656.diff
> Nice to see it fixed so fast :-) 

Ok, so I assume it was indeed fixed by the patch for PR41583. Closing.