Bug 41546 - Revision 152389 breaks gcc.target/i386/ifcvt-onecmpl-abs-1.c
Summary: Revision 152389 breaks gcc.target/i386/ifcvt-onecmpl-abs-1.c
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: testsuite (show other bugs)
Version: 4.5.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-02 13:13 UTC by H.J. Lu
Modified: 2009-10-02 13:30 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2009-10-02 13:13:12 UTC
Revision 152389:

http://gcc.gnu.org/ml/gcc-cvs/2009-10/msg00038.html

breaks gcc.target/i386/ifcvt-onecmpl-abs-1.c on x86-64
since -mtune=i586 is invalid for x86-64. I think we
should use -mtune=generic.
Comment 1 hjl@gcc.gnu.org 2009-10-02 13:28:31 UTC
Subject: Bug 41546

Author: hjl
Date: Fri Oct  2 13:28:17 2009
New Revision: 152400

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=152400
Log:
2009-10-02  H.J. Lu  <hongjiu.lu@intel.com>

	PR testsuite/41546
	* gcc.target/i386/ifcvt-onecmpl-abs-1.c: Change -mtune=i586
	to -mtune=generic. 

Modified:
    trunk/gcc/testsuite/ChangeLog
    trunk/gcc/testsuite/gcc.target/i386/ifcvt-onecmpl-abs-1.c

Comment 2 H.J. Lu 2009-10-02 13:30:24 UTC
Fixed.