Bug 41263 - ICE in compute_antic, at tree-ssa-pre.c:2507
Summary: ICE in compute_antic, at tree-ssa-pre.c:2507
Status: RESOLVED DUPLICATE of bug 41101
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 4.5.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-checking, ice-on-valid-code, memory-hog
Depends on:
Blocks:
 
Reported: 2009-09-04 13:20 UTC by Jeroen Demeyer
Modified: 2009-09-04 17:50 UTC (History)
2 users (show)

See Also:
Host: x86_64-unknown-linux-gnu
Target: x86_64-unknown-linux-gnu
Build: x86_64-unknown-linux-gnu
Known to work:
Known to fail: 4.5.0
Last reconfirmed:


Attachments
Testcase (142 bytes, text/plain)
2009-09-04 13:21 UTC, Jeroen Demeyer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Demeyer 2009-09-04 13:20:19 UTC
When compiling the attached program with the command line 
gcc -v -save-temps -O2 bug.i
gcc uses all available memory.

gcc -v gives me
Using built-in specs.
Target: x86_64-unknown-linux-gnu
Configured with: ../gcc/configure CC=/usr/bin/gcc-4.3.4 --prefix=/home/jdemeyer/local --enable-checking=release
Thread model: posix
gcc version 4.5.0 20090904 (experimental) (GCC)
Comment 1 Jeroen Demeyer 2009-09-04 13:21:33 UTC
Created attachment 18493 [details]
Testcase
Comment 2 Richard Biener 2009-09-04 17:50:49 UTC
Dup of PR41101.

*** This bug has been marked as a duplicate of 41101 ***