Bug 41020 - [4.5 Regression] Can't declare an extern "C" friend of a builtin function
Summary: [4.5 Regression] Can't declare an extern "C" friend of a builtin function
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 4.5.0
: P1 normal
Target Milestone: 4.5.0
Assignee: Dodji Seketeli
URL:
Keywords: rejects-valid
Depends on:
Blocks:
 
Reported: 2009-08-09 21:30 UTC by Dave Korn
Modified: 2009-10-26 16:06 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2009-10-23 18:34:28


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Korn 2009-08-09 21:30:34 UTC
Attempting to declare a previously-declared extern "C" function as a friend within a class definition fails with an error that the friend declaration ambiguates the original extern "C" declaration.  It appears that the friend declaration is taken as an overload with "C++" linkage, since G++ then complains that the class members are private within the context of the extern "C" function definition.

$ cat friend.cxx

extern "C"
{
  int fork (void);
};

class frok
{
  int this_errno;
  friend int fork (void);
};

extern "C" int
fork (void)
{
  frok grouped;
  return grouped.this_errno;
}

$ g++-4 -c friend.cxx -o friend.o
friend.cxx:10:24: error: new declaration 'int fork()'
friend.cxx:4:7: error: ambiguates old declaration 'int fork()'
friend.cxx: In function 'int fork()':
friend.cxx:9:7: error: 'int frok::this_errno' is private
friend.cxx:17:18: error: within this context

$

  According to, for example, "C++ in a nutshell" (http://books.google.co.uk/books?id=91JTA9B_m44C&pg=PA170&lpg=PA170&dq=friend+%22storage+class%22&source=bl&ots=HrN4X1Y5wu&sig=N9rnB8r_YnxbH2hiWGqtbAWbWyk&hl=en&ei=oDt_SqmvGJKNjAe9k93wAQ&sa=X&oi=book_result&ct=result&resnum=5#v=onepage&q=friend%20%22storage%20class%22&f=false),
a function in a friend declaration should "retain its original linkage" when it has already been declared.  That is referring to the case of applying a storage class specifier (static) to the prior declaration that isn't syntactically valid within a friend declaration, but it seems like it should apply here too; the linkage should still be retained, even though I'm not changing the storage-class specifier.

  There may be some reason why this isn't valid C++, but I think it's probably a weakness in the parsing of friend declarations.

$ g++-4 -v
Using built-in specs.
Target: i686-pc-cygwin
Configured with: /gnu/gcc/gcc-patched/configure --prefix=/opt/gcc-tools -v --wit
h-gmp=/usr --with-mpfr=/usr --enable-bootstrap --enable-version-specific-runtime
-libs --enable-static --enable-shared --enable-shared-libgcc --disable-__cxa_ate
xit --with-gnu-ld --with-gnu-as --with-dwarf2 --disable-sjlj-exceptions --disabl
e-symvers --disable-libjava --disable-interpreter --program-suffix=-4 --disable-
libgomp --enable-libssp --enable-libada --enable-threads=posix --with-arch=i686
--with-tune=generic CC=gcc-4 CXX=g++-4 CC_FOR_TARGET=gcc-4 CXX_FOR_TARGET=g++-4
--with-ecj-jar=/usr/share/java/ecj.jar LD=/opt/gcc-tools/bin/ld.exe LD_FOR_TARGE
T=/opt/gcc-tools/bin/ld.exe AS=/opt/gcc-tools/bin/as.exe AS_FOR_TARGET=/opt/gcc-
tools/bin/as.exe --disable-win32-registry --disable-libgcj-debug --enable-langua
ges=c,c++,ada
Thread model: posix
gcc version 4.5.0 20090730 (experimental) (GCC)
Comment 1 Dave Korn 2009-08-09 21:31:52 UTC
(In reply to comment #0)
> $ g++-4 -v

  Yuck, that got horribly wrapped.  Here it is again, hopefully formatted a little better this time:

Using built-in specs.
Target: i686-pc-cygwin
Configured with: /gnu/gcc/gcc-patched/configure --prefix=/opt/gcc-tools -v --with-gmp=/usr --with-mpfr=/usr --enable-bootstrap --enable-version-specific-runtime-libs --enable-static --enable-shared --enable-shared-libgcc --disable-__cxa_atexit --with-gnu-ld --with-gnu-as --with-dwarf2 --disable-sjlj-exceptions --disable-symvers --disable-libjava --disable-interpreter --program-suffix=-4 --disable-libgomp --enable-libssp --enable-libada --enable-threads=posix --with-arch=i686 --with-tune=generic CC=gcc-4 CXX=g++-4 CC_FOR_TARGET=gcc-4 CXX_FOR_TARGET=g++-4 --with-ecj-jar=/usr/share/java/ecj.jar LD=/opt/gcc-tools/bin/ld.exe LD_FOR_TARGET=/opt/gcc-tools/bin/ld.exe AS=/opt/gcc-tools/bin/as.exe AS_FOR_TARGET=/opt/gcc-tools/bin/as.exe --disable-win32-registry --disable-libgcj-debug --enable-languages=c,c++,ada
Thread model: posix
gcc version 4.5.0 20090730 (experimental) (GCC) 

Comment 2 Jonathan Wakely 2009-08-10 10:40:22 UTC
Apart from the semi-colon after the extern "C" block the code is valid and this is a recent regression on trunk.
Comment 3 Dave Korn 2009-08-10 16:17:39 UTC
(In reply to comment #2)
> Apart from the semi-colon after the extern "C" block the code is valid and this
> is a recent regression on trunk.

I am fairly sure that a semi-colon after a block statement like that is unnecessary, but not actually invalid.  It certainly makes no difference to the testcase whether it is present or absent.
Comment 4 Jonathan Wakely 2009-08-10 17:05:25 UTC
It's irrelevant to this bug and is just me being more pedantic than -pedantic, however ... even with -pedantic GCC has always accepted stray semi-colons at namespace scope, but it's not valid.

At function scope a lone ';' is a valid expression-statement, but expression-statements are not allowed at namespace scope, only declarations are, and ';' is not a valid declaration.

Comment 5 Dave Korn 2009-08-10 17:16:23 UTC
(In reply to comment #4)
> It's irrelevant to this bug and is just me being more pedantic than -pedantic,
> however ... even with -pedantic GCC has always accepted stray semi-colons at
> namespace scope, but it's not valid.
> 
> At function scope a lone ';' is a valid expression-statement, but
> expression-statements are not allowed at namespace scope, only declarations
> are, and ';' is not a valid declaration.

  Well you learn something new every day!  Never realised that was a gnu extension, but it sure is, comeau online choked on my testcase:

"ComeauTest.c", line 5: error: extra ";" ignored,
        In C: A function definition does not end with a semicolon
        In C++: A non-member function definition, extern "C" block,
                or namespace does not end with a semicolon
  };
   ^
  Anyway.  Consider the testcase amended.  :-)

$ cat friend.cxx

extern "C"
{
  int fork (void);
}

class frok
{
  int this_errno;
  friend int fork (void);
};

extern "C" int
fork (void)
{
  frok grouped;
  return grouped.this_errno;
}

$ g++-4 -c friend.cxx -o friend.o
friend.cxx:10:24: error: new declaration 'int fork()'
friend.cxx:4:7: error: ambiguates old declaration 'int fork()'
friend.cxx: In function 'int fork()':
friend.cxx:9:7: error: 'int frok::this_errno' is private
friend.cxx:17:18: error: within this context

$
Comment 6 Andrew Pinski 2009-09-18 03:56:23 UTC
Confirmed.
Comment 7 Andrew Pinski 2009-10-04 19:13:51 UTC
This is related to builtins too because either using -fno-builtin or using fork1 allows this program to work.
Comment 8 Dodji Seketeli 2009-10-23 18:19:52 UTC
Subject: Re:  [4.5 Regression] Can't declare an extern "C"
	friend of a builtin function

Indeed. I am testing the patch below.

diff --git a/gcc/cp/decl.c b/gcc/cp/decl.c
index 5eb389f..7c01ee2 100644
--- a/gcc/cp/decl.c
+++ b/gcc/cp/decl.c
@@ -104,6 +104,7 @@ static void store_parm_decls (tree);
 static void initialize_local_var (tree, tree);
 static void expand_static_init (tree, tree);
 static tree next_initializable_field (tree);
+static int decls_match_1 (tree, tree, bool);
 
 /* The following symbols are subsumed in the cp_global_trees array, and
    listed here individually for documentation purposes.
@@ -899,6 +900,14 @@ push_local_name (tree decl)
 int
 decls_match (tree newdecl, tree olddecl)
 {
+  return decls_match_1 (newdecl, olddecl, /* newdecl_is_friend  */ false);
+}
+
+/* Subroutine of decls_match.  */
+
+static int
+decls_match_1 (tree newdecl, tree olddecl, bool newdecl_is_friend)
+{
   int types_match;
 
   if (newdecl == olddecl)
@@ -934,9 +943,11 @@ decls_match (tree newdecl, tree olddecl)
 
 #ifdef NO_IMPLICIT_EXTERN_C
       /* A new declaration doesn't match a built-in one unless it
-	 is also extern "C".  */
+	 is also extern "C". Friend function re-declarations retain the
+	 the linkage of the original declaration though.  */
       if (DECL_BUILT_IN (olddecl)
-	  && DECL_EXTERN_C_P (olddecl) && !DECL_EXTERN_C_P (newdecl))
+	  && DECL_EXTERN_C_P (olddecl) && !DECL_EXTERN_C_P (newdecl)
+	  && !newdecl_is_friend)
 	return 0;
 #endif
 
@@ -1122,7 +1133,7 @@ duplicate_decls (tree newdecl, tree olddecl, bool newdecl_is_friend)
   if (newdecl == olddecl)
     return olddecl;
 
-  types_match = decls_match (newdecl, olddecl);
+  types_match = decls_match_1 (newdecl, olddecl, newdecl_is_friend);
 
   /* If either the type of the new decl or the type of the old decl is an
      error_mark_node, then that implies that we have already issued an

Comment 9 Dodji Seketeli 2009-10-23 19:32:30 UTC
Subject: Re:   New: Can't declare an extern "C" friend.

Patch submitted to http://gcc.gnu.org/ml/gcc-patches/2009-10/msg01486.html

Comment 10 Dodji Seketeli 2009-10-26 14:40:35 UTC
Subject: Bug 41020

Author: dodji
Date: Mon Oct 26 14:40:16 2009
New Revision: 153552

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=153552
Log:
Fix PR c++/41020

gcc/cp/ChangeLog:

	PR c++/41020
	* decl.c (decls_match): Use DECL_IS_BUILTIN instead of
	DECL_BUILT_IN.

gcc/testsuite/ChangeLog:
	PR c++/41020
	* g++.dg/lookup/extern-c-redecl2.C: New test.
	* g++.dg/lookup/extern-c-redecl3.C: Likewise.
	* g++.dg/lookup/extern-c-redecl4.C: Likewise.
	* g++.dg/lookup/extern-c-redecl5.C: Likewise.

Added:
    trunk/gcc/testsuite/g++.dg/lookup/extern-c-redecl2.C
    trunk/gcc/testsuite/g++.dg/lookup/extern-c-redecl3.C
    trunk/gcc/testsuite/g++.dg/lookup/extern-c-redecl4.C
    trunk/gcc/testsuite/g++.dg/lookup/extern-c-redecl5.C
Modified:
    trunk/gcc/cp/ChangeLog
    trunk/gcc/cp/decl.c
    trunk/gcc/testsuite/ChangeLog

Comment 11 Dodji Seketeli 2009-10-26 16:06:13 UTC
Fixed in 4.5.0
Comment 12 Jakub Jelinek 2009-10-27 10:29:06 UTC
Subject: Bug 41020

Author: jakub
Date: Tue Oct 27 10:28:48 2009
New Revision: 153587

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=153587
Log:
	PR c++/41020
	* g++.dg/lookup/extern-c-redecl5.C: Fix up regexp.

Modified:
    trunk/gcc/testsuite/ChangeLog
    trunk/gcc/testsuite/g++.dg/lookup/extern-c-redecl5.C

Comment 13 Jeffrey A. Law 2009-10-29 16:50:13 UTC
Subject: Bug 41020

Author: law
Date: Thu Oct 29 16:48:00 2009
New Revision: 153715

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=153715
Log:
Recorded merge of revisions 153580-153581,153584,153586-153600,153604,153606,153610,153613,153615-153618,153621,153643,153646-153648,153650-153652,153654-153667,153669-153671 via svnmerge from 
svn+ssh://law@gcc.gnu.org/svn/gcc/trunk

........
  r153580 | gccadmin | 2009-10-26 18:17:26 -0600 (Mon, 26 Oct 2009) | 1 line
  
  Daily bump.
........
  r153581 | paolo | 2009-10-26 19:18:10 -0600 (Mon, 26 Oct 2009) | 6 lines
  
  2009-10-26  Paolo Carlini  <paolo.carlini@oracle.com>
  
  	* include/std/chrono (duration<>::duration(const duration<>&)): Fix
  	per the straightforward resolution of DR 974.
  	* testsuite/20_util/duration/cons/dr974.cc: Add.
........
  r153584 | carrot | 2009-10-27 03:06:36 -0600 (Tue, 27 Oct 2009) | 16 lines
  
  	* target.h (have_conditional_execution): Add a new target hook function.
  	* target-def.h (TARGET_HAVE_CONDITIONAL_EXECUTION): Likewise.
  	* targhooks.h (default_have_conditional_execution): Likewise.
  	* targhooks.c (default_have_conditional_execution): Likewise.
  	* doc/tm.texi (TARGET_HAVE_CONDITIONAL_EXECUTION): Document it.
  	* config/arm/arm.c (TARGET_HAVE_CONDITIONAL_EXECUTION): Define it.
  	(arm_have_conditional_execution): New function.
  	* ifcvt.c (noce_process_if_block, find_if_header,
  	cond_exec_find_if_block, dead_or_predicable): Change the usage of macro
  	HAVE_conditional_execution to a target hook call.
  	* recog.c (peephole2_optimize): Likewise.
  	* sched-rgn.c (add_branch_dependences): Likewise.
  	* final.c (asm_insn_count, final_scan_insn): Likewise.
  	* bb-reorder.c (HAVE_conditional_execution): Remove it.
........
  r153586 | ebotcazou | 2009-10-27 04:09:04 -0600 (Tue, 27 Oct 2009) | 1 line
  
  Fix nits
........
  r153587 | jakub | 2009-10-27 04:28:48 -0600 (Tue, 27 Oct 2009) | 3 lines
  
  	PR c++/41020
  	* g++.dg/lookup/extern-c-redecl5.C: Fix up regexp.
........
  r153588 | aldyh | 2009-10-27 05:18:12 -0600 (Tue, 27 Oct 2009) | 5 lines
  
  	PR bootstrap/41451
  	* fold-const.c (fold_binary_loc): Do not call
  	protected_set_expr_location.
........
  r153589 | rguenth | 2009-10-27 05:30:59 -0600 (Tue, 27 Oct 2009) | 5 lines
  
  2009-10-27  Richard Guenther  <rguenther@suse.de>
  
  	PR lto/41821
  	* gimple.c (gimple_types_compatible_p): Handle OFFSET_TYPE.
........
  r153590 | revitale | 2009-10-27 05:46:07 -0600 (Tue, 27 Oct 2009) | 1 line
  
  Fix PR40648 -- Fix misaligned store vectorizer patch
........
  r153591 | charlet | 2009-10-27 07:06:06 -0600 (Tue, 27 Oct 2009) | 16 lines
  
  2009-10-27  Arnaud Charlet  <charlet@adacore.com>
  
  	* exp_aggr.adb: Fix comment.
  
  2009-10-27  Emmanuel Briot  <briot@adacore.com>
  
  	* prj-err.adb (Error_Msg): take into account continuation lines when
  	computing whether we have a warning.
  
  2009-10-27  Vasiliy Fofanov  <fofanov@adacore.com>
  
  	* make.adb, s-os_lib.adb, s-os_lib.ads (Create_Temp_Output_File): New
  	routine that is designed to create temp file descriptor specifically
  	for redirecting an output stream.
........
  r153592 | charlet | 2009-10-27 07:16:48 -0600 (Tue, 27 Oct 2009) | 45 lines
  
  2009-10-27  Vincent Celier  <celier@adacore.com>
  
  	* makeutl.adb (Check_Source_Info_In_ALI): Do not recompile if a subunit
  	from the runtime is found, except if gnatmake switch -a is used and this
  	subunit cannot be found.
  
  2009-10-27  Ed Schonberg  <schonberg@adacore.com>
  
  	* gnatbind.adb (gnatbind): When the -R option is selected, list subunits
  	as well, for tools that need the complete closure of the main program.
  
  2009-10-27  Sergey Rybin  <rybin@adacore.com>
  
  	* gnat_ugn.texi: Minor updates.
  
  2009-10-27  Emmanuel Briot  <briot@adacore.com>
  
  	* prj-tree.adb (Free): Fix memory leak.
  
  2009-10-27  Vasiliy Fofanov  <fofanov@adacore.com>
  
  	* adaint.c, s-os_lib.adb (__gnat_create_output_file_new): New function
  	that ensures the file that is created is new. Use this function to make
  	sure there is no race condition if several processes are creating temp
  	files concurrently.
  
  	* s-os_lib.ads: Update comment.
  
  2009-10-27  Thomas Quinot  <quinot@adacore.com>
  
  	* sem_ch12.adb: Minor reformatting
  
  2009-10-27  Javier Miranda  <miranda@adacore.com>
  
  	* exp_ch4.ads (Integer_Promotion_Possible): New subprogram.
  	* exp_ch4.adb (Integer_Promotion_Possible): New subprogram.
  	(Expand_N_Type_Conversion): Replace code that checks if the integer
  	promotion of the operands is possible by a call to the new function
  	Integer_Promotion_Possible. Minor reformating because an enclosing
  	block is now not needed.
  	* checks.adb (Apply_Arithmetic_Overflow_Check): Add missing check to
  	see if the integer promotion is possible; in such case the runtime
  	checks are not generated.
........
  r153593 | charlet | 2009-10-27 07:22:25 -0600 (Tue, 27 Oct 2009) | 17 lines
  
  2009-10-27  Thomas Quinot  <quinot@adacore.com>
  
  	* sem_ch12.adb (Install_Formal_Packages): Do not omit installation of
  	visible entities when the formal package doesn't have a box.
  
  	* checks.adb: Minor reformatting.
  
  2009-10-27  Vincent Celier  <celier@adacore.com>
  
  	* prj-part.adb (Parse): Catch exception Types.Unrecoverable_Error and
  	set Project to Empty_Node.
  
  2009-10-27  Robert Dewar  <dewar@adacore.com>
  
  	* gnatbind.adb: Minor reformatting
........
  r153594 | charlet | 2009-10-27 07:51:46 -0600 (Tue, 27 Oct 2009) | 18 lines
  
  2009-10-27  Robert Dewar  <dewar@adacore.com>
  
  	* s-os_lib.ads, s-os_lib.adb, prj-err.adb, makeutl.adb: Minor
  	reformatting.
  
  2009-10-27  Ed Schonberg  <schonberg@adacore.com>
  
  	* sem.util.ads, sem_util.adb (Denotes_Same_Object,
  	Denotes_Same_Prefix): New functions to detect overlap between actuals
  	that are not by-copy in a call, when one of them is in-out.
  	* sem_warn.ads, sem_warn.adb (Warn_On_Overlapping_Actuals): New
  	procedure,  called on a subprogram call to warn when an in-out actual
  	that is not by-copy overlaps with another actual, thus leadind to
  	potentially dangerous aliasing in the body of the called subprogram.
  	Currently the warning is under control of the -gnatX switch.
  	* sem_res.adb (resolve_call): call Warn_On_Overlapping_Actuals.
........
  r153595 | charlet | 2009-10-27 08:02:58 -0600 (Tue, 27 Oct 2009) | 6 lines
  
  2009-10-27  Robert Dewar  <dewar@adacore.com>
  
  	* sem_warn.adb, sem_util.adb, sem_util.ads: Minor reformatting. Add
  	comments.
........
  r153596 | charlet | 2009-10-27 08:07:19 -0600 (Tue, 27 Oct 2009) | 2 lines
  
  Minor doc updates.
........
  r153597 | charlet | 2009-10-27 08:14:44 -0600 (Tue, 27 Oct 2009) | 6 lines
  
  2009-10-27  Robert Dewar  <dewar@adacore.com>
  
  	* s-fileio.adb, s-fileio.ads, sem_util.adb, sem_warn.adb,
  	sem_warn.ads: Minor reformatting
........
  r153598 | rguenth | 2009-10-27 09:16:35 -0600 (Tue, 27 Oct 2009) | 5 lines
  
  2009-10-27  Richard Guenther  <rguenther@suse.de>
  
  	* tree-complex.c (expand_complex_div_wide): Check for
  	INTEGER_CST, not TREE_CONSTANT on comparison folding result.
........
  r153599 | jakub | 2009-10-27 09:50:50 -0600 (Tue, 27 Oct 2009) | 6 lines
  
  	PR c/41842
  	* c-typeck.c (convert_arguments): Return -1 if any of the arguments is
  	error_mark_node.
  
  	* gcc.dg/pr41842.c: New test.
........
  r153600 | rguenth | 2009-10-27 09:52:44 -0600 (Tue, 27 Oct 2009) | 14 lines
  
  2009-10-27  Richard Guenther  <rguenther@suse.de>
  
  	* tree-ssa-structalias.c (find_func_aliases): In IPA mode
  	handle calls to externally visible functions like in regular mode.
  	(create_variable_info_for): Do not create function infos here.
  	(have_alias_info): Remove write-only variable.
  	(solve_constraints): New function split out from common code
  	in compute_points_to_sets and ipa_pta_execute.
  	(compute_points_to_sets): Adjust.
  	(ipa_pta_execute): Likewise.  Handle clones and externally visible
  	functions like in non-IPA mode.
  
  	* gcc.dg/torture/ipa-pta-1.c: Adjust testcase.
........
  r153604 | uros | 2009-10-27 11:03:47 -0600 (Tue, 27 Oct 2009) | 3 lines
  
  	* ChangeLog: Fix formatting.
  	* testsuite/ChangeLog: Ditto.
........
  r153606 | ktietz | 2009-10-27 11:14:47 -0600 (Tue, 27 Oct 2009) | 11 lines
  
  2009-10-27  Kai Tietz <kai.tietz@onevision.com>
  
          PR/41799
          * config/i386/mingw32.h (CHECK_EXECUTE_STACK_ENABLED): New macro.
          * config/i386/mingw.opt: Add fset-stack-executable.
          * config/i386/i386.c (ix86_trampoline_init): Make call to
          emit_library_call conditional, if CHECK_EXECUTE_STACK_ENABLED is
          defined and its value is not zero.
          * doc/invoke.texi
........
  r153610 | espindola | 2009-10-27 12:17:13 -0600 (Tue, 27 Oct 2009) | 7 lines
  
  2009-10-27  Dmitry Gorbachev  <d.g.gorbachev@gmail.com>
  
  	PR lto/41652
  	* configure.ac: Call AC_SYS_LARGEFILE before AC_OUTPUT.
  	* configure: Regenerate.
........
  r153613 | ebotcazou | 2009-10-27 13:41:13 -0600 (Tue, 27 Oct 2009) | 4 lines
  
  	* raise-gcc (db_region_for): Use _Unwind_GetIPInfo instead of
  	_Unwind_GetIP if HAVE_GETIPINFO is defined.
  	(db_action_for): Likewise.
........
  r153615 | rth | 2009-10-27 14:09:07 -0600 (Tue, 27 Oct 2009) | 7 lines
  
          PR c++/41819
          * tree-eh.c (eh_region_may_contain_throw_map): Rename from
          eh_region_may_contain_throw; update users.
          (eh_region_may_contain_throw): New function.
          (lower_catch): Check flag_exceptions before creating exception region.
          (lower_eh_filter, lower_eh_must_not_throw): Likewise.
          (lower_cleanup): Tidy existing flag_exceptions check to match.
........
  r153616 | ebotcazou | 2009-10-27 14:24:31 -0600 (Tue, 27 Oct 2009) | 3 lines
  
  	* gcc-interface/decl.c (purpose_member_field): New static function.
  	(annotate_rep): Use it instead of purpose_member.
........
  r153617 | jason | 2009-10-27 15:58:09 -0600 (Tue, 27 Oct 2009) | 10 lines
  
  	Allow no-capture lambdas to convert to function pointer.
  	* semantics.c (maybe_add_lambda_conv_op): New.
  	* parser.c (cp_parser_lambda_expression): Call it.
  	(cp_parser_lambda_declarator_opt): Make op() static if
  	no captures.
  	* mangle.c (write_closure_type_name): Adjust.
  	* semantics.c (finish_this_expr): Adjust.
  	* decl.c (grok_op_properties): Allow it.
  	* call.c (build_user_type_conversion_1): Handle static conversion op.
  	(build_op_call): And op().
........
  r153618 | rth | 2009-10-27 17:25:54 -0600 (Tue, 27 Oct 2009) | 1 line
  
          * cgraphunit.c (cgraph_optimize): Maintain timevar stack properly.
........
  r153621 | gccadmin | 2009-10-27 18:16:59 -0600 (Tue, 27 Oct 2009) | 1 line
  
  Daily bump.
........
  r153643 | kkojima | 2009-10-27 22:22:21 -0600 (Tue, 27 Oct 2009) | 4 lines
  
  	* config/sh/sh.md (stuff_delay_slot): Move const_int pattern
  	inside the unspec vector.
........
  r153646 | bonzini | 2009-10-28 03:49:58 -0600 (Wed, 28 Oct 2009) | 6 lines
  
  2009-10-28  Paolo Bonzini  <bonzini@gnu.org>
  
  	* config/sh/sh.md (cbranchfp4_media): Remove hack extending
  	cstore result to DImode.
........
  r153647 | bonzini | 2009-10-28 03:54:01 -0600 (Wed, 28 Oct 2009) | 6 lines
  
  2009-10-28  Paolo Bonzini  <bonzini@gnu.org>
  
  	* expmed.c (emit_store_flag): Check costs before
  	transforming to the opposite representation.
........
  r153648 | singler | 2009-10-28 04:04:03 -0600 (Wed, 28 Oct 2009) | 8 lines
  
  2009-10-28  Johannes Singler  <singler@kit.edu>
  
          PR libstdc++/40852
          * include/parallel/multiseq_selection.h
          (multiseq_partition, multiseq_selection):  Avoid intermediate
          values exceeding the integer type range for very large inputs.
........
  r153650 | bonzini | 2009-10-28 04:17:29 -0600 (Wed, 28 Oct 2009) | 15 lines
  
  2009-10-28  Paolo Bonzini  <bonzini@gnu.org>
  
  	PR rtl-optimization/40741
  	* config/arm/arm.c (thumb1_rtx_costs): IOR or XOR with
  	a small constant is cheap.
  	* config/arm/arm.md (andsi3, iorsi3): Try to place the result of
  	force_reg on the LHS.
  	(xorsi3): Likewise, and split the XOR if the constant is complex
  	and not in Thumb mode.
  
  2009-10-28  Paolo Bonzini  <bonzini@gnu.org>
  
  	PR rtl-optimization/40741
  	* gcc.target/arm/thumb-branch1.c: New.
........
  r153651 | bonzini | 2009-10-28 04:27:15 -0600 (Wed, 28 Oct 2009) | 13 lines
  
  2009-10-28  Paolo Bonzini  <bonzini@gnu.org>
  
  	PR rtl-optimization/39715
  	* combine.c (simplify_comparison): Use extensions to
  	widen comparisons.  Try an ANDing first.
  
  testsuite:
  2009-10-28  Paolo Bonzini  <bonzini@gnu.org>
  
  	PR rtl-optimization/39715
  	* gcc.target/arm/thumb-bitfld1.c: New.
........
  r153652 | bonzini | 2009-10-28 06:37:30 -0600 (Wed, 28 Oct 2009) | 13 lines
  
  2009-10-28  Paolo Bonzini  <bonzini@gnu.org>
  
  	PR rtl-optimization/41812
  
  	Revert:
  	2009-06-27  Paolo Bonzini  <bonzini@gnu.org>
  
  	* df-problems.c (df_md_scratch): New.
  	(df_md_alloc, df_md_free): Allocate/free it.
  	(df_md_local_compute): Only include live registers in init.
  	(df_md_transfer_function): Prune the in-set computed by
  	the confluence function, and the gen-set too.
........
  r153654 | paolo | 2009-10-28 07:07:00 -0600 (Wed, 28 Oct 2009) | 6 lines
  
  2009-10-28  Paolo Carlini  <paolo.carlini@oracle.com>
  
  	* include/bits/stl_iterator_base_funcs.h: (next): Change
  	template parameter name consistently with the resolution
  	of DR 1011 ([Ready] in Santa Cruz).
........
  r153655 | rguenth | 2009-10-28 07:28:32 -0600 (Wed, 28 Oct 2009) | 14 lines
  
  2009-10-28  Richard Guenther  <rguenther@suse.de>
  
  	PR middle-end/41855
  	* tree-ssa-alias.c (refs_may_alias_p_1): Deal with CONST_DECLs
  	(ref_maybe_used_by_call_p_1): Fix bcopy handling.
  	(call_may_clobber_ref_p_1): Likewise.
  	* tree-ssa-structalias.c (find_func_aliases): Likewise.
  	* alias.c (nonoverlapping_memrefs_p): Deal with CONST_DECLs.
  
  	* gfortran.dg/lto/20091028-1_0.f90: New testcase.
  	* gfortran.dg/lto/20091028-1_1.c: Likewise.
  	* gfortran.dg/lto/20091028-2_0.f90: Likewise.
  	* gfortran.dg/lto/20091028-2_1.c: Likewise.
........
  r153656 | charlet | 2009-10-28 07:31:51 -0600 (Wed, 28 Oct 2009) | 25 lines
  
  2009-10-28  Robert Dewar  <dewar@adacore.com>
  
  	* a-ztexio.adb, a-ztexio.ads, a-witeio.ads, a-witeio.adb,
  	a-textio.ads, a-textio.adb: Reorganize (moving specs from private part
  	to body).
  	(Initialize_Standard_Files): New procedure.
  	* a-tienau.adb: Minor change to make EOF directly visible
  	* a-tirsfi.ads, a-wrstfi.adb, a-wrstfi.ads, a-zrstfi.adb,
  	a-zrstfi.ads, a-tirsfi.adb: New unit, initial version.
  	* gnat_rm.texi: Add documentation for
  	Ada.[Wide_[Wide_]]Text_IO.Reset_Standard_Files.
  	* Makefile.rtl: Add entries for
  	Ada.[Wide_[Wide_]]Text_IO.Reset_Standard_Files
  
  2009-10-28  Thomas Quinot  <quinot@adacore.com>
  
  	* exp_ch9.ads: Minor reformatting
  	* sem_ch3.adb: Minor reformatting
  	* sem_aggr.adb: Minor reformatting.
  	* sem_attr.adb: Minor reformatting
  	* tbuild.adb, tbuild.ads, par-ch4.adb, exp_ch4.adb (Tbuild.New_Op_Node):
  	New subprogram.
  	Minor code reorganization/factoring.
........
  r153657 | charlet | 2009-10-28 07:41:05 -0600 (Wed, 28 Oct 2009) | 29 lines
  
  2009-10-28  Thomas Quinot  <quinot@adacore.com>
  
  	* exp_ch4.adb (Expand_N_Type_Conversion): Perform Integer promotion for
  	the operand of the unary minus and ABS operators.
  
  	* sem_type.adb (Covers): A concurrent type and its corresponding record
  	type are compatible.
  	* exp_attr.adb (Expand_N_Attribute_Reference): Do not rewrite a 'Access
  	attribute reference for the current instance of a protected type while
  	analyzing an access discriminant constraint in a component definition.
  	Such a reference is handled in the corresponding record's init proc,
  	while initializing the constrained component.
  	* exp_ch9.adb (Expand_N_Protected_Type_Declaration): When creating the
  	corresponding record type, propagate components'
  	Has_Per_Object_Constraint flag.
  	* exp_ch3.adb (Build_Init_Procedure.Build_Init_Statements):
  	For a concurrent type, set up concurrent aspects before initializing
  	components with a per object constrain, because they may be controlled,
  	and their initialization may call entries or protected subprograms of
  	the enclosing concurrent object.
  
  2009-10-28  Emmanuel Briot  <briot@adacore.com>
  
  	* prj-nmsc.adb (Add_If_Not_In_List): New subprogram, for better sharing
  	of code.
  	(Find_Source_Dirs): resolve links if Opt.Follow_Links_For_Dirs when
  	processing the directories specified explicitly in the project file.
........
  r153658 | charlet | 2009-10-28 07:50:10 -0600 (Wed, 28 Oct 2009) | 10 lines
  
  2009-10-28  Robert Dewar  <dewar@adacore.com>
  
  	* exp_attr.adb, exp_ch9.adb, prj-nmsc.adb, tbuild.adb, ali.adb,
  	types.ads: Minor reformatting
  
  2009-10-28  Tristan Gingold  <gingold@adacore.com>
  
  	* init.c: Fix __gnat_error_handler for Darwin10 (Snow Leopard)
........
  r153659 | rguenth | 2009-10-28 07:52:20 -0600 (Wed, 28 Oct 2009) | 11 lines
  
  2009-10-28  Richard Guenther  <rguenther@suse.de>
  
  	* tree.c (free_lang_data_in_type): Do not call get_alias_set.
  	(free_lang_data): Unconditionally compute alias sets for all
  	standard integer types.  Bail out if gate bailed out previously.
  	Do not reset the types_compatible_p langhook.
  	(gate_free_lang_data): Remove.
  	(struct pass_ipa_free_lang_data): Enable unconditionally.
  	* gimple.c (gimple_get_alias_set): Use the same alias-set for
  	all pointer types.
........
  r153660 | charlet | 2009-10-28 08:07:16 -0600 (Wed, 28 Oct 2009) | 2 lines
  
  	* gcc-interface/Make-lang.in: Update dependencies.
........
  r153661 | charlet | 2009-10-28 08:09:12 -0600 (Wed, 28 Oct 2009) | 22 lines
  
  2009-10-28  Vincent Celier  <celier@adacore.com>
  
  	* prj-nmsc.adb (Add_To_Or_Remove_From_List): New name of procedure
  	Add_If_Not_In_List to account to the fact that a directory may be
  	removed from the list. Only remove directory if Removed is True.
  
  2009-10-28  Gary Dismukes  <dismukes@adacore.com>
  
  	* a-textio.ads, a-textio.ads: Put back function EOF_Char in private
  	part. Put back body of function EOF_Char.
  	* a-tienau.adb: Remove with of Interfaces.C_Streams and change EOF back
  	to EOF_Char.
  
  2009-10-28  Emmanuel Briot  <briot@adacore.com>
  
  	* prj-tree.adb (Free): Fix memory leak.
  
  2009-10-28  Thomas Quinot  <quinot@adacore.com>
  
  	* s-fileio.adb: Minor reformatting
........
  r153662 | charlet | 2009-10-28 08:14:05 -0600 (Wed, 28 Oct 2009) | 9 lines
  
  2009-10-28  Thomas Quinot  <quinot@adacore.com>
  
  	* s-crtl.ads (System.CRTL.strerror): New function.
  
  2009-10-28  Ed Schonberg  <schonberg@adacore.com>
  
  	* sem_type.adb: Add guard to recover some type errors.
........
  r153663 | charlet | 2009-10-28 08:22:09 -0600 (Wed, 28 Oct 2009) | 12 lines
  
  2009-10-28  Bob Duff  <duff@adacore.com>
  
  	* s-fileio.adb: Give more information in exception messages.
  
  2009-10-28  Robert Dewar  <dewar@adacore.com>
  
  	* gnat_ugn.texi: Document new -gnatyt requirement for space after right
  	paren if next token starts with digit or letter.
  	* styleg.adb (Check_Right_Paren): New rule for space after if next
  	character is a letter or digit.
........
  r153664 | rguenth | 2009-10-28 08:33:17 -0600 (Wed, 28 Oct 2009) | 4 lines
  
  2009-10-28  Richard Guenther  <rguenther@suse.de>
  
          * gimple.c (gimple_get_alias_set): Fix comment typo.
........
  r153665 | jakub | 2009-10-28 08:36:28 -0600 (Wed, 28 Oct 2009) | 3 lines
  
  	* var-tracking.c (emit_note_insn_var_location): Get the mode of
  	a variable part from its REG, MEM or VALUE.
........
  r153666 | jakub | 2009-10-28 08:37:24 -0600 (Wed, 28 Oct 2009) | 4 lines
  
  	* var-tracking.c (emit_note_insn_var_location): Don't call the second
  	vt_expand_loc unnecessarily when location is not a register nor
  	memory.
........
  r153667 | jakub | 2009-10-28 08:39:06 -0600 (Wed, 28 Oct 2009) | 6 lines
  
  	PR target/41762
  	* config/i386/i386.c (ix86_pic_register_p): Don't call
  	rtx_equal_for_cselib_p for VALUEs discarded as useless.
  
  	* gcc.dg/pr41762.c: New test.
........
  r153669 | jakub | 2009-10-28 08:43:04 -0600 (Wed, 28 Oct 2009) | 6 lines
  
  	PR debug/41801
  	* builtins.c (get_builtin_sync_mem): Expand loc in ptr_mode,
  	call convert_memory_address on addr.
  
  	* g++.dg/ext/sync-3.C: New test.
........
  r153670 | jakub | 2009-10-28 08:45:03 -0600 (Wed, 28 Oct 2009) | 6 lines
  
  	PR middle-end/41837
  	* ipa-struct-reorg.c (find_field_in_struct_1): Return NULL if
  	fields don't have DECL_NAME.
  
  	* gcc.dg/pr41837.c: New test.
........
  r153671 | rguenth | 2009-10-28 08:48:34 -0600 (Wed, 28 Oct 2009) | 15 lines
  
  2009-10-28  Richard Guenther  <rguenther@suse.de>
  
  	PR lto/41808
  	PR lto/41839
  	* tree-ssa.c (useless_type_conversion_p): Do not treat
  	conversions to pointers to incomplete types as useless.
  	* gimple.c (gimple_types_compatible_p): Compare struct tags,
  	not typedef names.
  
  	* gcc.dg/lto/20091027-1_0.c: New testcase.
  	* gcc.dg/lto/20091027-1_1.c: Likewise.
  	* g++.dg/lto/20091026-1_0.C: Likewise.
  	* g++.dg/lto/20091026-1_1.C: Likewise.
  	* g++.dg/lto/20091026-1_a.h: Likewise.
........

Modified:
    branches/reload-v2a/   (props changed)

Propchange: branches/reload-v2a/
            ('svnmerge-integrated' modified)


Comment 14 hjl@gcc.gnu.org 2009-10-30 16:05:31 UTC
Subject: Bug 41020

Author: hjl
Date: Fri Oct 30 16:04:41 2009
New Revision: 153759

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=153759
Log:
2009-10-30  H.J. Lu  <hongjiu.lu@intel.com>

	Backport from mainline:
	2009-10-30  Dodji Seketeli  <dodji@redhat.com>

	PR c++/41863
	* g++.dg/template/sizeof12.C: New test.

	2009-10-29  Martin Jambor  <mjambor@suse.cz>

	PR tree-optimization/41775
	* g++.dg/torture/pr41775.C: New testcase.

	2009-10-28  Jakub Jelinek  <jakub@redhat.com>

	PR debug/41801
	* g++.dg/ext/sync-3.C: New test.

	2009-10-27  Jakub Jelinek  <jakub@redhat.com>

	PR c++/41020
	* g++.dg/lookup/extern-c-redecl5.C: Fix up regexp.

	2009-10-26  Jakub Jelinek  <jakub@redhat.com>

	PR bootstrap/41345
	* gcc.dg/pr41345.c: New test.

	2009-10-26  Dodji Seketeli  <dodji@redhat.com>

	PR c++/41785
	* g++.dg/cpp0x/variadic96.C: New test.

	2009-10-26  Dodji Seketeli  <dodji@redhat.com>

	PR c++/41020
	* g++.dg/lookup/extern-c-redecl2.C: New test.
	* g++.dg/lookup/extern-c-redecl3.C: Likewise.
	* g++.dg/lookup/extern-c-redecl4.C: Likewise.
	* g++.dg/lookup/extern-c-redecl5.C: Likewise.

	2009-10-23  Joseph Myers  <joseph@codesourcery.com>

	PR c/40033
	* gcc.dg/noncompile/pr40033-1.c: New test.

	2009-10-23  Joseph Myers  <joseph@codesourcery.com>

	PR c/41673
	* gcc.dg/Wstrict-aliasing-bogus-vla-1.c: New test.

	2009-10-21  Sebastian Pop  <sebastian.pop@amd.com>

	PR tree-optimization/41497
	* gcc.dg/tree-ssa/pr41497.c: New.

Added:
    branches/gcc-4_4-branch/gcc/testsuite/g++.dg/cpp0x/variadic96.C
      - copied unchanged from r153757, trunk/gcc/testsuite/g++.dg/cpp0x/variadic96.C
    branches/gcc-4_4-branch/gcc/testsuite/g++.dg/ext/sync-3.C
      - copied unchanged from r153757, trunk/gcc/testsuite/g++.dg/ext/sync-3.C
    branches/gcc-4_4-branch/gcc/testsuite/g++.dg/lookup/extern-c-redecl2.C
      - copied unchanged from r153757, trunk/gcc/testsuite/g++.dg/lookup/extern-c-redecl2.C
    branches/gcc-4_4-branch/gcc/testsuite/g++.dg/lookup/extern-c-redecl3.C
      - copied unchanged from r153757, trunk/gcc/testsuite/g++.dg/lookup/extern-c-redecl3.C
    branches/gcc-4_4-branch/gcc/testsuite/g++.dg/lookup/extern-c-redecl4.C
      - copied unchanged from r153757, trunk/gcc/testsuite/g++.dg/lookup/extern-c-redecl4.C
    branches/gcc-4_4-branch/gcc/testsuite/g++.dg/lookup/extern-c-redecl5.C
      - copied unchanged from r153757, trunk/gcc/testsuite/g++.dg/lookup/extern-c-redecl5.C
    branches/gcc-4_4-branch/gcc/testsuite/g++.dg/template/sizeof12.C
      - copied unchanged from r153757, trunk/gcc/testsuite/g++.dg/template/sizeof12.C
    branches/gcc-4_4-branch/gcc/testsuite/g++.dg/torture/pr41775.C
      - copied unchanged from r153757, trunk/gcc/testsuite/g++.dg/torture/pr41775.C
    branches/gcc-4_4-branch/gcc/testsuite/gcc.dg/Wstrict-aliasing-bogus-vla-1.c
      - copied unchanged from r153758, trunk/gcc/testsuite/gcc.dg/Wstrict-aliasing-bogus-vla-1.c
    branches/gcc-4_4-branch/gcc/testsuite/gcc.dg/noncompile/pr40033-1.c
      - copied unchanged from r153758, trunk/gcc/testsuite/gcc.dg/noncompile/pr40033-1.c
    branches/gcc-4_4-branch/gcc/testsuite/gcc.dg/pr41345.c
      - copied unchanged from r153757, trunk/gcc/testsuite/gcc.dg/pr41345.c
    branches/gcc-4_4-branch/gcc/testsuite/gcc.dg/tree-ssa/pr41497.c
      - copied unchanged from r153758, trunk/gcc/testsuite/gcc.dg/tree-ssa/pr41497.c
Modified:
    branches/gcc-4_4-branch/gcc/testsuite/ChangeLog