Bug 41003 - Array constructor gives seg fault
Array constructor gives seg fault
Status: RESOLVED DUPLICATE of bug 35810
Product: gcc
Classification: Unclassified
Component: fortran
4.3.3
: P3 normal
: ---
Assigned To: Not yet assigned to anyone
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-07 18:10 UTC by Tim Hopkins
Modified: 2009-08-07 19:27 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Hopkins 2009-08-07 18:10:22 UTC
program bug
integer :: a(5) = (/1,2,3,4,5/)
integer, allocatable:: b(:)

b = (/ a(1:5), a(1:5) /)
print *, b
endprogram bug
integer :: a(5) = (/1,2,3,4,5/)
integer, allocatable:: b(:)

b = (/ a(1:5), a(1:5) /)
print *, b
end


The assignment to b generates a seg fault. I believe this to be standard F2003
Comment 1 kargl 2009-08-07 19:27:34 UTC

*** This bug has been marked as a duplicate of 35810 ***