Bug 40985 - [4.4 regression] Bug 32893 come back (-msse -ftree-vectorize cause segfaults (zlib))
Summary: [4.4 regression] Bug 32893 come back (-msse -ftree-vectorize cause segfaults ...
Status: RESOLVED DUPLICATE of bug 40838
Alias: None
Product: gcc
Classification: Unclassified
Component: tree-optimization (show other bugs)
Version: 4.4.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on: 40838
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-06 12:10 UTC by Dzianis Kahanovich
Modified: 2009-08-18 04:50 UTC (History)
12 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
PR 40838 for gcc 4.4.1 (1.80 KB, patch)
2009-08-07 18:24 UTC, Dzianis Kahanovich
Details | Diff
patch (234 bytes, patch)
2009-08-11 13:00 UTC, Dzianis Kahanovich
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dzianis Kahanovich 2009-08-06 12:10:54 UTC
Primary combination: "-march=pentium4 -O3 ...",
minimal: "-O1 -march=i686 -msse -ftree-vectorize".
Rebuilding zlib v1.2.3 cause segfault on related apps (I use seamonkey, all under gentoo). All other apps built on pentium4/O3/gcc4.3.3.
Comment 1 Uroš Bizjak 2009-08-06 12:27:11 UTC
Please follow [1] on how to report bug.

[1] http://gcc.gnu.org/bugs.html
Comment 2 Dzianis Kahanovich 2009-08-06 13:49:43 UTC
(In reply to comment #1)
> Please follow [1] on how to report bug.
> 
> [1] http://gcc.gnu.org/bugs.html

With pleasure. If I will understand what I may to say more/else, exclude host type.
Comment 3 H.J. Lu 2009-08-06 16:44:24 UTC
(In reply to comment #0)
> Primary combination: "-march=pentium4 -O3 ...",
> minimal: "-O1 -march=i686 -msse -ftree-vectorize".
> Rebuilding zlib v1.2.3 cause segfault on related apps (I use seamonkey, all
> under gentoo). All other apps built on pentium4/O3/gcc4.3.3.
> 

Please add "-mincoming-stack-boundary=2" to CFLAGS and report what you got. 
Comment 4 H.J. Lu 2009-08-06 16:46:46 UTC

*** This bug has been marked as a duplicate of 32893 ***
Comment 5 Dzianis Kahanovich 2009-08-06 19:56:16 UTC
(In reply to comment #3)
> (In reply to comment #0)
> > Primary combination: "-march=pentium4 -O3 ...",
> > minimal: "-O1 -march=i686 -msse -ftree-vectorize".
> > Rebuilding zlib v1.2.3 cause segfault on related apps (I use seamonkey, all
> > under gentoo). All other apps built on pentium4/O3/gcc4.3.3.
> > 
> 
> Please add "-mincoming-stack-boundary=2" to CFLAGS and report what you got. 

No error.

PS A read 32893, but have no errors prior to v4.4.0 and think there are not same bug, sorry
Comment 6 H.J. Lu 2009-08-06 21:14:08 UTC
You can try my patch for PR 40838.
Comment 7 Dzianis Kahanovich 2009-08-07 18:21:46 UTC
(In reply to comment #6)
> You can try my patch for PR 40838.

No error.

Current i386.h must be fixed by hands. Next I attach gcc-4.4.1 version of this patch.
Comment 8 Dzianis Kahanovich 2009-08-07 18:24:27 UTC
Created attachment 18325 [details]
PR 40838 for gcc 4.4.1
Comment 9 Dzianis Kahanovich 2009-08-11 12:49:14 UTC
Simplest way to save Bug 32893 solution: replace MAX_STACK_ALIGNMENT by STACK_BOUNDARY in vect_can_force_dr_alignment_p (tree-vectorizer.c / ...). No error more.
Comment 10 Dzianis Kahanovich 2009-08-11 13:00:28 UTC
Created attachment 18340 [details]
patch

For gcc 4.4.1. Moved to tree-vect-data-refs.c in cvs.
Comment 11 H.J. Lu 2009-08-18 04:50:25 UTC

*** This bug has been marked as a duplicate of 40838 ***