Bug 40889 - "gtktoolkit" var in gtk_GtkToolkit.c requires NewGlobalRef
Summary: "gtktoolkit" var in gtk_GtkToolkit.c requires NewGlobalRef
Status: RESOLVED FIXED
Alias: None
Product: classpath
Classification: Unclassified
Component: awt (show other bugs)
Version: unspecified
: P3 normal
Target Milestone: 0.99
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-28 12:02 UTC by Ivan Maidanski
Modified: 2010-08-10 20:56 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
proposed bugfix (320 bytes, patch)
2009-12-10 15:08 UTC, Ivan Maidanski
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Maidanski 2009-07-28 12:02:17 UTC
In native/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkToolkit.c this line should be added (since "gtktoolkit" is a global var):
  gtktoolkit = (*env)->NewGlobalRef(env, gtktoolkit);
just after:
  gtktoolkit = (*env)->FindClass(env, "gnu/java/awt/peer/gtk/GtkMainThread");
Comment 1 Ivan Maidanski 2009-12-10 15:08:59 UTC
Created attachment 19275 [details]
proposed bugfix

The patch is against v0.93 but could be easily applied against the current CVS.