User account creation filtered due to spam.

Bug 40117 - [OOP][F2008] Type-bound procedure: allow list after PROCEDURE
Summary: [OOP][F2008] Type-bound procedure: allow list after PROCEDURE
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: unknown
: P3 normal
Target Milestone: 4.6.0
Assignee: janus
URL:
Keywords:
Depends on:
Blocks: 39627
  Show dependency treegraph
 
Reported: 2009-05-12 12:46 UTC by Tobias Burnus
Modified: 2016-11-16 13:19 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2010-06-12 02:23:57


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Burnus 2009-05-12 12:46:26 UTC
Put it here before it goes out of sight and submerges as minor item in the F2008 standard:

TYPE T
  CONTAINS
    PROCEDURE :: foo, bar

is invalid in F2003 since no list is allowed, but with F2008 there will be a list allowed; see item 6 - "Paper 09-208r1" at http://j3-fortran.org/pipermail/j3/attachments/20090512/817b9628/attachment.txt, which is the following paper:
http://j3-fortran.org/doc/year/09/09-208r2.txt

Disclaimer: Fortran 2008 is not yet a formal standard, the route to it is listed here: ftp://ftp.nag.co.uk/sc22wg5/N1751-N1800/N1781.txt
Comment 1 Tobias Burnus 2010-04-28 08:42:32 UTC
Fortran 2008 FDIS (ftp://ftp.nag.co.uk/sc22wg5/N1801-N1850/N1826.pdf) has:

R448 type-bound-procedure-stmt
     is  PROCEDURE [ [ , binding-attr -list ] :: ] type-bound-proc-decl -list
     or  PROCEDURE (interface-name), binding-attr -list :: binding-name-list
Comment 2 janus 2010-06-12 04:10:52 UTC
Subject: Bug 40117

Author: janus
Date: Sat Jun 12 04:10:25 2010
New Revision: 160646

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=160646
Log:
2010-06-12  Janus Weil  <janus@gcc.gnu.org>

	PR fortran/40117
	* decl.c (match_procedure_in_type): Allow procedure lists (F08).


2010-06-12  Janus Weil  <janus@gcc.gnu.org>

	PR fortran/40117
	* gfortran.dg/typebound_proc_4.f03: Modified error message.
	* gfortran.dg/typebound_proc_14.f03: New.
	* gfortran.dg/typebound_proc_15.f03: New.

Added:
    trunk/gcc/testsuite/gfortran.dg/typebound_proc_14.f03
    trunk/gcc/testsuite/gfortran.dg/typebound_proc_15.f03
Modified:
    trunk/gcc/fortran/ChangeLog
    trunk/gcc/fortran/decl.c
    trunk/gcc/testsuite/ChangeLog
    trunk/gcc/testsuite/gfortran.dg/typebound_proc_4.f03

Comment 3 janus 2010-06-12 04:12:46 UTC
Fixed with r160646. Closing.