Bug 39973 - [4.5 Regression] Revision 146817 miscompiled 416.gamess in SPEC CPU 2006
Summary: [4.5 Regression] Revision 146817 miscompiled 416.gamess in SPEC CPU 2006
Status: RESOLVED DUPLICATE of bug 40021
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.5.0
: P3 normal
Target Milestone: 4.5.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-30 04:55 UTC by H.J. Lu
Modified: 2009-05-04 21:53 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2009-04-30 04:55:19 UTC
On Linux/Intel64, revision 146991 miscompiles 416.gamess in SPEC CPU 2006
with

-O3 -msse2 -mfpmath=sse -ffast-math -funroll-loops -m32

I got

  Running 416.gamess ref base o3 default

416.gamess: copy #0 non-zero return code (rc=0, signal=11)


****************************************
Contents of h2ocu2+.gradient.err
****************************************
STOP IN ABRT

****************************************

****************************************
Contents of cytosine.2.err
****************************************
STOP IN ABRT

****************************************

Revision 146799 is OK.
Comment 1 H.J. Lu 2009-04-30 13:00:51 UTC
Revision 146817:

http://gcc.gnu.org/ml/gcc-cvs/2009-04/msg01459.html

is the cause.
Comment 2 H.J. Lu 2009-05-04 03:30:25 UTC
It is reproducible with test data, -i test.
Comment 3 H.J. Lu 2009-05-04 20:44:34 UTC
blas.fppized.f was miscompiled by

-m32 -c -O3 -msse2 -mfpmath=sse -ffast-math -fno-inline-functions -funroll-loops -ffixed-form
Comment 4 H.J. Lu 2009-05-04 21:53:07 UTC

*** This bug has been marked as a duplicate of 40021 ***