Bug 39972 - [4.5 Regression] Revision 146817 miscompiled 465.tonto in SPEC CPU 2006
Summary: [4.5 Regression] Revision 146817 miscompiled 465.tonto in SPEC CPU 2006
Status: RESOLVED DUPLICATE of bug 40021
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.5.0
: P3 normal
Target Milestone: 4.5.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-30 04:52 UTC by H.J. Lu
Modified: 2009-05-04 21:52 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2009-04-30 04:52:30 UTC
On Linux/Intel64, revision 146920 miscompiles 465.tonto in SPEC CPU 2006
with

-O3 -msse2 -mfpmath=sse -ffast-math -funroll-loops -m32

revision 146799 is OK.
Comment 1 H.J. Lu 2009-04-30 04:57:23 UTC
I got

  Running 465.tonto ref base o3 default
Error with '/export/gnu/import/rrs/spec/2006/spec/bin/specinvoke -E -d /export/g
nu/import/rrs/spec/2006/spec/benchspec/CPU2006/465.tonto/run/run_base_ref_o3.000
0 -c 1 -e compare.err -o compare.stdout -f compare.cmd': check file '/export/gnu
/import/rrs/spec/2006/spec/benchspec/CPU2006/465.tonto/run/run_base_ref_o3.0000/
.err'
*** Miscompare of stdout, see /export/gnu/import/rrs/spec/2006/spec/benchspec/CP
U2006/465.tonto/run/run_base_ref_o3.0000/stdout.mis
Comment 2 H.J. Lu 2009-04-30 13:02:45 UTC
Revision 146817:

http://gcc.gnu.org/ml/gcc-cvs/2009-04/msg01459.html

may be the cause.
Comment 3 H.J. Lu 2009-04-30 16:32:28 UTC
Revision 146817 is the cause. It is reproducible with test data, -i test.
Comment 4 H.J. Lu 2009-05-04 20:52:56 UTC
blas.f90 was miscompiled by

-m32 -O3 -msse2 -mfpmath=sse -ffast-math -fno-inline-functions -funroll-loops
Comment 5 H.J. Lu 2009-05-04 21:52:51 UTC

*** This bug has been marked as a duplicate of 40021 ***