User account creation filtered due to spam.

Bug 39925 - classpath build fails with "find: bad option -path"
Summary: classpath build fails with "find: bad option -path"
Status: RESOLVED DUPLICATE of bug 38715
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 4.4.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-27 03:39 UTC by Daniel Richard G.
Modified: 2009-04-28 14:16 UTC (History)
4 users (show)

See Also:
Host: alphaev56-dec-osf4.0g
Target: alphaev56-dec-osf4.0g
Build: alphaev56-dec-osf4.0g
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Richard G. 2009-04-27 03:39:10 UTC
The system find(1) command on this Tru64 box does not support the -path option. As far as I can tell, -path is not POSIX. I think it may be preferable to prune the output using grep(1).

gmake[4]: Entering directory `/tmp/gcc-build/alphaev56-dec-osf4.0g/libjava/classpath/tools'
Makefile:839: warning: overriding commands for target `gjdoc'
Makefile:774: warning: ignoring old commands for target `gjdoc'
find /tmp/gcc-4.4.0/libjava/classpath/tools/external/asm -name '*.java' -print > asm.lst
find /tmp/gcc-4.4.0/libjava/classpath/tools/gnu/classpath/tools \
             /tmp/gcc-4.4.0/libjava/classpath/tools/com/sun/javadoc \
             /tmp/gcc-4.4.0/libjava/classpath/tools/com/sun/tools/doclets \
             /tmp/gcc-4.4.0/libjava/classpath/tools/com/sun/tools/javadoc \
             /tmp/gcc-4.4.0/libjava/classpath/tools/com/sun/tools/javac \
             /tmp/gcc-4.4.0/libjava/classpath/tools/com/sun/tools/javah \
             /tmp/gcc-4.4.0/libjava/classpath/tools/sun/rmi/rmic \
             -path '*gnu/classpath/tools/gjdoc' -prune -o -path '*gnu/classpath/tools/doclets' -prune -o -path '*gnu/classpath/tools/taglets' -prune -o -path '*com/sun/javadoc' -prune -o -path '*com/sun/tools/doclets' -prune -o -path '*com/sun/tools/javadoc' -prune -o \
             -name '*.java' -print > classes.lst
find: bad option -path
gmake[4]: *** [tools.zip] Error 1
gmake[4]: Leaving directory `/tmp/gcc-build/alphaev56-dec-osf4.0g/libjava/classpath/tools'
gmake[4]: Entering directory `/tmp/gcc-build/alphaev56-dec-osf4.0g/libjava/classpath'
true  DO=all multi-do # gmake
gmake[4]: Leaving directory `/tmp/gcc-build/alphaev56-dec-osf4.0g/libjava/classpath'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/tmp/gcc-build/alphaev56-dec-osf4.0g/libjava/classpath'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/tmp/gcc-build/alphaev56-dec-osf4.0g/libjava'
gmake[1]: *** [all-target-libjava] Error 2
gmake[1]: Leaving directory `/tmp/gcc-build'
gmake: *** [all] Error 2
Comment 1 Erwin Manuel 2009-04-28 14:14:01 UTC
Same issue on Solaris 9.
SunOS xxxxxxx 5.9 Generic_122300-28 sun4u sparc SUNW,Sun-Fire

find ../../../../.././libjava/classpath/tools/gnu/classpath/tools \
             ../../../../.././libjava/classpath/tools/com/sun/javadoc \
             ../../../../.././libjava/classpath/tools/com/sun/tools/doclets \
             ../../../../.././libjava/classpath/tools/com/sun/tools/javadoc \
             ../../../../.././libjava/classpath/tools/com/sun/tools/javac \
             ../../../../.././libjava/classpath/tools/com/sun/tools/javah \
             ../../../../.././libjava/classpath/tools/sun/rmi/rmic \
             -path '*gnu/classpath/tools/gjdoc' -prune -o -path '*gnu/classpath/tools/doclets' -prune -o -path '*gnu/classpath/tools/taglets' -prune -o -path '*com/sun/javadoc' -prune -o -path '*com/sun/tools/doclets' -prune -o -path '*com/sun/tools/javadoc' -prune -o \
             -name '*.java' -print > classes.lst
find: bad option -path
find: path-list predicate-list
make[6]: *** [tools.zip] Error 1
make[6]: Leaving directory `/opt/home/xxx/dev/gcc-4.4.0/sparc-sun-solaris2.9/sparcv9/libjava/classpath/tools'
make[6]: Entering directory `/opt/home/xxx/dev/gcc-4.4.0/sparc-sun-solaris2.9/sparcv9/libjava/classpath'
true  DO=all multi-do # make
make[6]: Leaving directory `/opt/home/xxx/dev/gcc-4.4.0/sparc-sun-solaris2.9/sparcv9/libjava/classpath'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/opt/home/xxx/dev/gcc-4.4.0/sparc-sun-solaris2.9/sparcv9/libjava/classpath'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/opt/home/xxx/dev/gcc-4.4.0/sparc-sun-solaris2.9/sparcv9/libjava'
make[3]: *** [multi-do] Error 1
make[3]: Leaving directory `/opt/home/xxx/dev/gcc-4.4.0/sparc-sun-solaris2.9/libjava'
make[2]: *** [all-multi] Error 2
make[2]: Leaving directory `/opt/home/xxx/dev/gcc-4.4.0/sparc-sun-solaris2.9/libjava'
make[1]: *** [all-target-libjava] Error 2
make[1]: Leaving directory `/opt/home/xxx/dev/gcc-4.4.0'
make: *** [all] Error 2
Comment 2 Andrew Pinski 2009-04-28 14:16:44 UTC

*** This bug has been marked as a duplicate of 38715 ***