Bug 39424 - MinGW doesn't seem to work if main disk is not C:\
MinGW doesn't seem to work if main disk is not C:\
Status: RESOLVED FIXED
Product: gcc
Classification: Unclassified
Component: driver
unknown
: P3 normal
: ---
Assigned To: Not yet assigned to anyone
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 20:48 UTC by Josh
Modified: 2009-03-11 02:41 UTC (History)
1 user (show)

See Also:
Host:
Target: 4.3.3
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josh 2009-03-10 20:48:32 UTC
On this computer, the main disk is labeled H:\, and GCC won't so much as print its version. It repeatedly causes crss to throw a No Disk error, which doesn't accept cancel as an answer. Can't really isolate problem; don't have access to any other computers without C:\ as main drive, and since it won't even give me a version number...

Thanks, and best of luck.
Comment 1 Danny Smith 2009-03-11 02:41:33 UTC
This is fixed in  4.3.x by

2006-11-20  Carlos O'Donell  <carlos@codesourcery.com>
            Mark Mitchell  <mark@codesourcery.com>

        * cppdefault.c: Define cpp_PREFIX, cpp_PREFIX_len, and
        gcc_exec_prefix.
        (cpp_relocated): New function.
        * cppdefault.h: Declare cpp_PREFIX, cpp_PREFIX_len, gcc_exec_prefix
        and cpp_relocated.
        * Makefile.in (PREPROCESSOR_DEFINES): Add -DPREFIX option.
        * c-incpath.c (add_standard_paths): Call cpp_relocated. If relocated,
        replace configured prefix with gcc_exec_prefix.