Bug 39398 - verify_flow_info failed
Summary: verify_flow_info failed
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.3.3
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
Keywords: build
Depends on:
Reported: 2009-03-08 03:54 UTC by Timothy Madden
Modified: 2009-04-16 20:47 UTC (History)
2 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:

Source file to compile (9.63 KB, text/plain)
2009-03-08 03:56 UTC, Timothy Madden
File referenced in the error output (3.80 KB, text/plain)
2009-03-08 03:58 UTC, Timothy Madden

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Madden 2009-03-08 03:54:41 UTC
Here is the command line and the output:

adrian@darkstar:~/packages/gcc-4.3.3-obj/gcc$ /home/adrian/packages/gcc-4.3.3-obj/./prev-gcc/xgcc -B/home/adrian/packages/gcc-4.3.3-obj/./prev-gcc/ -B/usr/i686-pc-linux-gnu/bin/ -c -g -O2 -fomit-frame-pointer -fprofile-generate      -gnatpg -gnata -g -O1 -fno-inline \
>          -nostdinc -I- -I. -Iada -I../../gcc-4.3.3/gcc/ada ../../gcc-4.3.3/gcc/ada/a-except.adb -o ada/a-except.o
../../gcc-4.3.3/gcc/ada/a-except.adb: In function 'Ada.Exceptions.Raise_From_Controlled_Operation':
../../gcc-4.3.3/gcc/ada/a-except.adb:1305: error: control flow in the middle of basic block 20
../../gcc-4.3.3/gcc/ada/a-except.adb:1305: error: control flow in the middle of basic block 20
../../gcc-4.3.3/gcc/ada/a-except.adb:1305: error: control flow in the middle of basic block 20
../../gcc-4.3.3/gcc/ada/a-except.adb:1305: error: control flow in the middle of basic block 20
../../gcc-4.3.3/gcc/ada/a-except.adb:1305: error: control flow in the middle of basic block 20
+===========================GNAT BUG DETECTED==============================+
| 4.3.3 (i686-pc-linux-gnu) verify_flow_info failed                        |
| Error detected around ../../gcc-4.3.3/gcc/ada/a-except.adb:1305          |
| Please submit a bug report; see http://gcc.gnu.org/bugs.html.            |
| Use a subject line meaningful to you and us to track the bug.            |
| Include the entire contents of this bug box in the report.               |
| Include the exact gcc or gnatmake command that you entered.              |
| Also include sources listed below in gnatchop format                     |
| (concatenated together with no headers between files).                   |

Please include these source files with error report
Note that list may not be accurate in some cases,
so please double check that the problem can still
be reproduced with the set of files listed.

raised TYPES.UNRECOVERABLE_ERROR : comperr.adb:398
adrian@darkstar:~/packages/gcc-4.3.3-obj/gcc$ /home/adrian/packages/gcc-4.3.3-obj/./prev-gcc/xgcc -v
Using built-in specs.
Target: i686-pc-linux-gnu
Configured with: ../gcc-4.3.3/configure --prefix=/usr --enable-shared --enable-languages=ada,c,c++,fortran,java,objc,obj-c++,treelang --enable-threads=posix --enable-__cxa_atexit --disable-checking --with-gnu-ld --verbose --with-arch=athlon-4 --with-tune=athlon-4
Thread model: posix
gcc version 4.3.3 (GCC)

I started the build with make profiledbootstrap and I have
CFLAGS=-march=native -msse -mmmx -m3dnow -mfpmath=sse -O3
CXXFLAGS=-march=native -msse -mmmx -m3dnow -mfpmath=sse -O3
and gcc 4.2.4 currently installed (I have AMD Sempron 2200+,
no sse2)
Comment 1 Timothy Madden 2009-03-08 03:56:49 UTC
Created attachment 17417 [details]
Source file to compile

This is the file used on the command line
Comment 2 Timothy Madden 2009-03-08 03:58:10 UTC
Created attachment 17418 [details]
File referenced in the error output

This is the other file referenced in the error output
Comment 3 Timothy Madden 2009-03-11 20:15:55 UTC
If I compile gcc without an -O option in my CFALGS/CXXFLAGS than it works fine and I could install gcc 4.3.3

If I compile with -O2 instead of -O3 in my CFLAGS it would still not work.

I tried to bootstrap again, with the newly installed gcc 4.3.3 and -O3, and the bug is still there.