Bug 39395 - cloog link failure with non-gcc bootstrap compiler
Summary: cloog link failure with non-gcc bootstrap compiler
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 4.4.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-07 08:28 UTC by David Binderman
Modified: 2010-02-08 05:58 UTC (History)
1 user (show)

See Also:
Host: x86_64-suse-linux
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Binderman 2009-03-07 08:28:48 UTC
I usually bootstrap the weekly snapshot of gcc 4.4
with the Intel C compiler.

This usually works, but this week snapshot 20090306 didn't.

There seem to be some fun & games with linking together to
make cc1-dummy.

icc -g -fkeep-inline-functions -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prot
otypes -Wmissing-prototypes -Wcast-qual -Wold-style-definition -Wc++-compat -Wmi
ssing-format-attribute -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overle
ngth-strings -fno-common  -DHAVE_CONFIG_H  -o cc1-dummy c-lang.o stub-objc.o att
ribs.o c-errors.o c-lex.o c-pragma.o c-decl.o c-typeck.o c-convert.o c-aux-info.
o c-common.o c-opts.o c-format.o c-semantics.o c-ppoutput.o c-cppbuiltin.o c-obj
c-common.o c-dump.o c-pch.o c-parser.o i386-c.o c-gimplify.o tree-mudflap.o c-pr
etty-print.o c-omp.o dummy-checksum.o \
          main.o tree-browser.o libbackend.a ../libcpp/libcpp.a ../libdecnumber/
libdecnumber.a ../libcpp/libcpp.a   ../libiberty/libiberty.a ../libdecnumber/lib
decnumber.a -L/lib -lcloog -L/lib -lppl_c -lppl -lgmpxx -lmpfr -lgmp
libbackend.a(graphite.o): In function `cloog_finalize':
/usr/include/cloog/ppl_backend.h:54: undefined reference to `ppl_finalize'
libbackend.a(graphite.o): In function `schedule_to_scattering':
/home/dcb/gcc/20090306/working/gcc/../../src/gcc-4.4-20090306/gcc/graphite.c:666
: undefined reference to `cloog_matrix_alloc'
libbackend.a(graphite.o): In function `print_graphite_bb':
/home/dcb/gcc/20090306/working/gcc/../../src/gcc-4.4-20090306/gcc/graphite.c:708
: undefined reference to `cloog_matrix_print'
/home/dcb/gcc/20090306/working/gcc/../../src/gcc-4.4-20090306/gcc/graphite.c:747
: undefined reference to `cloog_matrix_print'
/home/dcb/gcc/20090306/working/gcc/../../src/gcc-4.4-20090306/gcc/graphite.c:748
: undefined reference to `cloog_matrix_free'
...

Given the number of function with names starting with "cloog", I'd guess
that something has gone wrong in the detection of the correct location
of the cloog libraries.

Using -L/lib for -lcloog looks deeply suspicious to me.
Even more so, -L/lib for -lppl_c and -lppl.
Comment 1 Sebastian Pop 2009-03-07 15:29:48 UTC
Subject: Re:  New: cloog link failure with non-gcc 
	bootstrap compiler

On Sat, Mar 7, 2009 at 02:28, dcb314 at hotmail dot com
<gcc-bugzilla@gcc.gnu.org> wrote:
> Using -L/lib for -lcloog looks deeply suspicious to me.
> Even more so, -L/lib for -lppl_c and -lppl.

Sounds like the problem is in the configure scripts.
What is the configure command that you are using?

Thanks,
Sebastian
Comment 2 David Binderman 2009-03-08 12:36:53 UTC
(In reply to comment #1)
> Sounds like the problem is in the configure scripts.

Righto. 

> What is the configure command that you are using?

CC="icc" ../whatever/configure --prefix=somewhereElse --enable-checking

It might be significant that the Intel compiler is 32 bit, but
running on a 64 bit box.
Comment 3 Sebastian Pop 2010-02-08 05:58:11 UTC
This should be fixed by now.
Please open again this PR if this is still a problem.

Sebastian