User account creation filtered due to spam.

Bug 38550 - EICALL PROBLEM in WINAVR GCC
Summary: EICALL PROBLEM in WINAVR GCC
Status: RESOLVED DUPLICATE of bug 38549
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: new-ra
: P3 blocker
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-17 10:34 UTC by ilyas
Modified: 2008-12-21 22:34 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ilyas 2008-12-17 10:34:12 UTC
Hello, i use winavr gcc for programming atmega2561 microcontroller.
2561 has 256 K program memory our code works good below 128 K but when our code becomes larger than 128 K byte, does not work properly. this is because eicall assembler command. there must be an EIND=1 command before accessing the memory after 128 K. when this is done, there is no problem.
you have to fix this problem as soon as possible. we cannot use half of our program memory right now.

http://sourceforge.net/tracker/index.php?func=detail&aid=2229892&group_id=68108&atid=520074

regards..
ilyas
Comment 1 Andrew Pinski 2008-12-21 22:34:25 UTC

*** This bug has been marked as a duplicate of 38549 ***