Bug 38436 - libgomp does not respect --disable-werror
Summary: libgomp does not respect --disable-werror
Status: RESOLVED DUPLICATE of bug 32193
Alias: None
Product: gcc
Classification: Unclassified
Component: libgomp (show other bugs)
Version: 4.3.2
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-07 19:26 UTC by Mike Frysinger
Modified: 2012-09-27 05:22 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail: 4.3.2, 4.4.0
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Frysinger 2008-12-07 19:26:19 UTC
the --disable-werror flag is very useful for distributions and dealing with a myriad of build systems / versions / etc...  unfortunately, libgomp doesnt respect this flag.

from libgomp/configure.ac:
# Add -Wall -Werror if we are using GCC.
if test "x$GCC" = "xyes"; then
  XCFLAGS="$XCFLAGS -Wall -Werror"
fi
Comment 1 Mike Frysinger 2012-09-27 05:22:27 UTC
dupe of bug 32193

*** This bug has been marked as a duplicate of bug 32193 ***