Bug 37781 - error: missing binary operator before token "("
Summary: error: missing binary operator before token "("
Status: RESOLVED DUPLICATE of bug 36453
Alias: None
Product: gcc
Classification: Unclassified
Component: preprocessor (show other bugs)
Version: 4.4.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-09 14:22 UTC by Jaroslav Suchanek
Modified: 2008-10-09 14:46 UTC (History)
6 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Suchanek 2008-10-09 14:22:40 UTC
Boost header is not procceeded correctly and ended with error:

/usr/local/include/boost/mpl/apply_wrap.hpp:81:31: error: missing binary operator before token "("

The code is:
#elif BOOST_PP_ITERATION_DEPTH() == 1

where BOOST_PP_ITERATION_DEPTH() is defined as (for example):
#define BOOST_PP_ITERATION_DEPTH() 2

System: FreeBSD 7.0 RELEASE
Arch: amd64
Gcc version: gcc-4.4.0_20081003
Comment 1 Andreas Schwab 2008-10-09 14:46:23 UTC

*** This bug has been marked as a duplicate of 36453 ***