User account creation filtered due to spam.

Bug 37094 - [4.4 Regression] Ada build broken for i586
Summary: [4.4 Regression] Ada build broken for i586
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.4.0
: P4 blocker
Target Milestone: 4.4.0
Assignee: Not yet assigned to anyone
URL:
Keywords: build, ice-on-valid-code
: 37136 (view as bug list)
Depends on:
Blocks: 36216
  Show dependency treegraph
 
Reported: 2008-08-12 12:50 UTC by Joel Sherrill
Modified: 2008-08-23 21:08 UTC (History)
4 users (show)

See Also:
Host:
Target: i[345]86-*-*
Build:
Known to work:
Known to fail:
Last reconfirmed: 2008-08-12 14:00:44


Attachments
Following patch should fix it, I will test it ASAP (300 bytes, patch)
2008-08-21 15:13 UTC, Jan Hubicka
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Sherrill 2008-08-12 12:50:24 UTC
This is with revision 

Compiler built for revision 138553 (20080802) with ACATS reported (http://gcc.gnu.org/ml/gcc-testresults/2008-08/msg00380.html)

/home/joel/work-gnat/svn/b-gcc2-i386/./gcc/xgcc -B/home/joel/work-gnat/svn/b-gcc2-i386/./gcc/ -nostdinc -B/home/joel/work-gnat/svn/b-gcc2-i386/i386-rtems4.9/newlib/ -isystem /home/joel/work-gnat/svn/b-gcc2-i386/i386-rtems4.9/newlib/targ-include -isystem /home/joel/work-gnat/svn/gcc/newlib/libc/include -B/home/joel/work-gnat/svn//install/i386-rtems4.9/bin/ -B/home/joel/work-gnat/svn//install/i386-rtems4.9/lib/ -isystem /home/joel/work-gnat/svn//install/i386-rtems4.9/include -isystem /home/joel/work-gnat/svn//install/i386-rtems4.9/sys-include -c -g -O2  -W -Wall -gnatpg  a-nllcef.ads -o a-nllcef.o
a-ngcefu.adb: In function 'Ada.Numerics.Long_Long_Complex_Elementary_Functions.Log':
a-ngcefu.adb:538: error: insn does not satisfy its constraints:
(insn 465 314 468 41 a-ngcefu.adb:533 (set (reg:XF 8 st [141])
        (const_double:XF -921707870 [0xc90fdaa2] 3.14159265358979323851280895940618620443274267018e+0 [0x0.c90fdaa22168c235p+2])) 76 {*movxf_integer} (nil))
+===========================GNAT BUG DETECTED==============================+
| 4.4.0 20080811 (experimental) [trunk revision 138957] (i386-pc-rtems4.9) GCC error:|
| in copyprop_hardreg_forward_1, at regrename.c:1589                       |
| Error detected around a-ngcefu.adb:538                                   |
| Please submit a bug report; see http://gcc.gnu.org/bugs.html.            |
| Use a subject line meaningful to you and us to track the bug.            |
| Include the entire contents of this bug box in the report.               |
| Include the exact gcc or gnatmake command that you entered.              |
| Also include sources listed below in gnatchop format                     |
| (concatenated together with no headers between files).                   |
+==========================================================================+

Please include these source files with error report
Note that list may not be accurate in some cases,
so please double check that the problem can still
be reproduced with the set of files listed.



raised TYPES.UNRECOVERABLE_ERROR : comperr.adb:424
Comment 1 Eric Botcazou 2008-08-12 14:00:44 UTC
See http://gcc.gnu.org/ml/gcc-patches/2008-08/msg00776.html
Comment 2 Joel Sherrill 2008-08-13 13:08:50 UTC
No surprise but still broke for rev 139039.
Comment 3 Andrew Pinski 2008-08-16 22:37:32 UTC
*** Bug 37136 has been marked as a duplicate of this bug. ***
Comment 4 Jan Hubicka 2008-08-21 15:13:44 UTC
Created attachment 16121 [details]
Following patch should fix it, I will test it ASAP
Comment 5 Eric Botcazou 2008-08-22 20:18:54 UTC
> Following patch should fix it, I will test it ASAP

Thanks, I can confirm that it does fix the problem.
Comment 6 Jan Hubicka 2008-08-23 20:03:32 UTC
Subject: Bug 37094

Author: hubicka
Date: Sat Aug 23 20:02:08 2008
New Revision: 139522

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=139522
Log:

	PR target/37094
	* i386.c (standard_80387_constant_p): Use optimize_size.

Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/config/i386/i386.c

Comment 7 Eric Botcazou 2008-08-23 21:08:11 UTC
The Ada compiler builds again.