Bug 37052 - ICE in find_reloads, at reload.c:3744
Summary: ICE in find_reloads, at reload.c:3744
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.3.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-08 00:43 UTC by Stephen R. Marenka
Modified: 2015-01-16 20:38 UTC (History)
5 users (show)

See Also:
Host: m68k-linux-gnu
Target: m68k-linux-gnu
Build: m68k-linux-gnu
Known to work: 4.4.0
Known to fail:
Last reconfirmed:


Attachments
Preprocessed file (1.36 KB, text/plain)
2008-08-08 00:46 UTC, Stephen R. Marenka
Details
reduced source from hdf5 (1.99 KB, text/plain)
2008-08-08 00:47 UTC, Stephen R. Marenka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen R. Marenka 2008-08-08 00:43:41 UTC
gcc -save-temps -v -O2 -fomit-frame-pointer -c testreloads.c

Dropping optimization from -O2 to -O1 or dropping -fomit-frame-pointer allows this to succeed.

Using built-in specs.
Target: m68k-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Debian 4.3.1-8' --with-bugurl=file:///usr/share/doc/gcc-4.3/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --with-gxx-include-dir=/usr/include/c++/4.3 --program-suffix=-4.3 --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-mpfr --disable-libssp --disable-werror --enable-checking=release --build=m68k-linux-gnu --host=m68k-linux-gnu --target=m68k-linux-gnu
Thread model: posix
gcc version 4.3.1 (Debian 4.3.1-8)
COLLECT_GCC_OPTIONS='-save-temps' '-v' '-O2' '-fomit-frame-pointer' '-c' '-m68020'
 /usr/lib/gcc/m68k-linux-gnu/4.3.1/cc1 -E -quiet -v testreloads.c -m68020 -fomit-frame-pointer -O2 -fpch-preprocess -o testreloads.i
ignoring nonexistent directory "/usr/local/include/m68k-linux-gnu"
ignoring nonexistent directory "/usr/lib/gcc/m68k-linux-gnu/4.3.1/../../../../m68k-linux-gnu/include"
ignoring nonexistent directory "/usr/include/m68k-linux-gnu"
#include "..." search starts here:
#include <...> search starts here:
 /usr/local/include
 /usr/lib/gcc/m68k-linux-gnu/4.3.1/include
 /usr/lib/gcc/m68k-linux-gnu/4.3.1/include-fixed
 /usr/include
End of search list.
COLLECT_GCC_OPTIONS='-save-temps' '-v' '-O2' '-fomit-frame-pointer' '-c' '-m68020'
 /usr/lib/gcc/m68k-linux-gnu/4.3.1/cc1 -fpreprocessed testreloads.i -quiet -dumpbase testreloads.c -m68020 -auxbase testreloads -O2 -version -fomit-frame-pointer -o testreloads.s
GNU C (Debian 4.3.1-8) version 4.3.1 (m68k-linux-gnu)
        compiled by GNU C version 4.3.1, GMP version 4.2.2, MPFR version 2.3.1.
GGC heuristics: --param ggc-min-expand=82 --param ggc-min-heapsize=98603
Compiler executable checksum: 941413abde0b2d7fe947ae106f766200
testreloads.c: In function 'dataset_readInd':
testreloads.c:123: warning: assignment makes pointer from integer without a cast
testreloads.c:125: warning: incompatible implicit declaration of built-in function 'printf'
testreloads.c:205: warning: incompatible implicit declaration of built-in function 'free'
testreloads.c:207: error: unable to generate reloads for:
(insn:QI 631 629 632 41 testreloads.c:94 (parallel [
            (set (cc0)
                (compare (reg/v:DI 0 %d0 [orig:117 j ] [117])
                    (reg:DI 4 %d4 [orig:115 pretmp.69 ] [115])))
            (clobber (reg:DI 273))
        ]) 12 {*m68k.md:521} (expr_list:REG_UNUSED (reg:DI 273)
        (nil)))
testreloads.c:207: internal compiler error: in find_reloads, at reload.c:3744
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.3/README.Bugs> for instructions.
Comment 1 Stephen R. Marenka 2008-08-08 00:46:34 UTC
Created attachment 16038 [details]
Preprocessed file
Comment 2 Stephen R. Marenka 2008-08-08 00:47:15 UTC
Created attachment 16039 [details]
reduced source from hdf5
Comment 3 Andreas Schwab 2008-12-29 22:48:27 UTC
No longer fails with 4.4 since the switch to IRA.
Comment 4 Jeffrey A. Law 2015-01-16 20:38:18 UTC
Fixed long ago with the change to IRA.