User account creation filtered due to spam.

Bug 36903 - Generic vectorizarion test failures
Summary: Generic vectorizarion test failures
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: testsuite (show other bugs)
Version: 4.4.0
: P3 normal
Target Milestone: 4.5.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-23 00:19 UTC by Andy Hutchinson
Modified: 2009-12-29 21:47 UTC (History)
2 users (show)

See Also:
Host:
Target: avr-unknown-none
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Hutchinson 2008-07-23 00:19:23 UTC
For AVR the following test fail. Probably since the day they were created.

For AVR there are no "vectypes"  so they all fail  message test

I don't know if these should be skipped as invalid or there is some significant issue that warrant XFAIL.


FAIL: gcc.dg/tree-ssa/gen-vect-11.c scan-tree-dump-times vect "vectorized 1 loops" 1
FAIL: gcc.dg/tree-ssa/gen-vect-11a.c scan-tree-dump-times vect "vectorized 1 loops" 1
FAIL: gcc.dg/tree-ssa/gen-vect-2.c scan-tree-dump-times vect "vectorized 1 loops" 1
FAIL: gcc.dg/tree-ssa/gen-vect-25.c scan-tree-dump-times vect "vectorized 2 loops" 1
FAIL: gcc.dg/tree-ssa/gen-vect-26.c scan-tree-dump-times vect "vectorized 1 loops" 1
FAIL: gcc.dg/tree-ssa/gen-vect-26.c scan-tree-dump-times vect "Alignment of access forced using peeling" 1
FAIL: gcc.dg/tree-ssa/gen-vect-28.c scan-tree-dump-times vect "vectorized 1 loops" 1
FAIL: gcc.dg/tree-ssa/gen-vect-28.c scan-tree-dump-times vect "Alignment of access forced using peeling" 1
FAIL: gcc.dg/tree-ssa/gen-vect-32.c scan-tree-dump-times vect "vectorized 1 loops" 1
Comment 1 Andy Hutchinson 2009-12-22 00:01:04 UTC
Subject: Bug 36903

Author: hutchinsonandy
Date: Tue Dec 22 00:00:50 2009
New Revision: 155382

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=155382
Log:
2009-12-21  Andy Hutchinson  <hutchinsonandy@gcc.gnu.org>

	PR testsuite/36903
	* gcc.dg/tree-ssa/gen-vect-11.c : Disable for avr target. It will not vectorize.
	* gcc.dg/tree-ssa/gen-vect-11a.c: Ditto.
	* gcc.dg/tree-ssa/gen-vect-2.c: Ditto.
	* gcc.dg/tree-ssa/gen-vect-25.c: Ditto.
	* gcc.dg/tree-ssa/gen-vect-26.c: Ditto.
	* gcc.dg/tree-ssa/gen-vect-28.c: Ditto.
	* gcc.dg/tree-ssa/gen-vect-32.c: Ditto.
	* gcc.dg/tree-ssa/pr23455.c: Test for 4 eliminations on avr target.
	* gcc.dg/tree-ssa/ssa-fre-26.c: XFAIL test for avr.
	* gcc.dg/tree-ssa/vrp47.c: Skip test for avr target due to low branch cost.

Modified:
    trunk/gcc/testsuite/ChangeLog
    trunk/gcc/testsuite/gcc.dg/tree-ssa/gen-vect-11.c
    trunk/gcc/testsuite/gcc.dg/tree-ssa/gen-vect-11a.c
    trunk/gcc/testsuite/gcc.dg/tree-ssa/gen-vect-2.c
    trunk/gcc/testsuite/gcc.dg/tree-ssa/gen-vect-25.c
    trunk/gcc/testsuite/gcc.dg/tree-ssa/gen-vect-26.c
    trunk/gcc/testsuite/gcc.dg/tree-ssa/gen-vect-28.c
    trunk/gcc/testsuite/gcc.dg/tree-ssa/gen-vect-32.c
    trunk/gcc/testsuite/gcc.dg/tree-ssa/pr23455.c
    trunk/gcc/testsuite/gcc.dg/tree-ssa/ssa-fre-26.c
    trunk/gcc/testsuite/gcc.dg/tree-ssa/vrp47.c

Comment 2 Andy Hutchinson 2009-12-22 00:16:55 UTC
Fixed 4.5. AVR wont vectorize with word size of 1 byte!