Bug 36482 - ICE in copyprop_hardreg_forward_1, at regrename.c:1613
Summary: ICE in copyprop_hardreg_forward_1, at regrename.c:1613
Status: RESOLVED DUPLICATE of bug 26515
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.2.3
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 39765 40232 (view as bug list)
Depends on: 23424
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 07:30 UTC by Hinko Kocevar
Modified: 2009-10-12 04:14 UTC (History)
5 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: cris-linux-uclibc
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments
preprocessed source that caused the internal compiler error (18.93 KB, application/octet-stream)
2008-06-10 07:31 UTC, Hinko Kocevar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hinko Kocevar 2008-06-10 07:30:28 UTC
This was created by a toolchain for cris architecture: gcc-4.2.3, uClibc-0.9.29, binutils-2.17 compiling openssl-0.9.8h.

hinkok@alala /work/stage/openwrt2/build_dir/cris/openssl-0.9.8h/crypto/cast $ cris-linux-uclibc-gcc -I.. -I../.. -I../../include -fPIC -DOPENSSL_PIC -DZLIB_SHARED -DZLIB -DDSO_DLFCN -DHAVE_DLFCN_H -I/work/stage/openwrt2/staging_dir/cris/usr/include -I/work/stage/openwrt2/staging_dir/cris/include -DOPENSSL_SMALL_FOOTPRINT -DOPENSSL_NO_ERR -DTERMIO -Os -fhonour-copts -fomit-frame-pointer -Wall   -c -o c_skey.o c_skey.c -v -save-temps
Using built-in specs.
Target: cris-linux-uclibc
Configured with: /work/stage/openwrt-trunk/build_dir/toolchain-cris_gcc4.2.3/gcc-4.2.3/configure --prefix=/work/stage/openwrt-trunk/staging_dir/toolchain-cris_gcc4.2.3 --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --target=cris-linux-uclibc --enable-languages=c --enable-shared --disable-__cxa_atexit --enable-target-optspace --with-gnu-ld --disable-nls --disable-libmudflap --disable-multilib
Thread model: posix
gcc version 4.2.3
 /work/stage/openwrt-trunk/staging_dir/toolchain-cris_gcc4.2.3/libexec/gcc/cris-linux-uclibc/4.2.3/cc1 -E -quiet -v -I.. -I../.. -I../../include -I/work/stage/openwrt2/staging_dir/cris/usr/include -I/work/stage/openwrt2/staging_dir/cris/include -D__arch_v10 -D__CRIS_arch_version=10 -DOPENSSL_PIC -DZLIB_SHARED -DZLIB -DDSO_DLFCN -DHAVE_DLFCN_H -DOPENSSL_SMALL_FOOTPRINT -DOPENSSL_NO_ERR -DTERMIO c_skey.c -march=v10 -Wall -fPIC -fhonour-copts -fomit-frame-pointer -Os -fpch-preprocess -o c_skey.i
ignoring nonexistent directory "/work/stage/openwrt-trunk/staging_dir/toolchain-cris_gcc4.2.3/lib/gcc/cris-linux-uclibc/4.2.3/../../../../cris-linux-uclibc/include"
#include "..." search starts here:
#include <...> search starts here:
 ..
 ../..
 ../../include
 /work/stage/openwrt2/staging_dir/cris/usr/include
 /work/stage/openwrt2/staging_dir/cris/include
 /work/stage/openwrt-trunk/staging_dir/toolchain-cris_gcc4.2.3/lib/gcc/cris-linux-uclibc/4.2.3/include
 /work/stage/openwrt-trunk/staging_dir/toolchain-cris_gcc4.2.3/lib/gcc/cris-linux-uclibc/4.2.3/../../../../cris-linux-uclibc/sys-include
End of search list.
 /work/stage/openwrt-trunk/staging_dir/toolchain-cris_gcc4.2.3/libexec/gcc/cris-linux-uclibc/4.2.3/cc1 -fpreprocessed c_skey.i -march=v10 -quiet -dumpbase c_skey.c -auxbase-strip c_skey.o -Os -Wall -version -fPIC -fhonour-copts -fomit-frame-pointer -o c_skey.s
GNU C version 4.2.3 (cris-linux-uclibc)
	compiled by GNU C version 4.1.2 (Gentoo 4.1.2 p1.1).
GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072
Compiler executable checksum: 410ae2227399308839bfc41a0a91c8c4
c_skey.c: In function 'CAST_set_key':
c_skey.c:165: error: insn does not satisfy its constraints:
(insn 2072 1053 2073 10 (set (reg:SI 9 r9)
        (zero_extend:SI (reg:HI 17 mof))) 53 {zero_extendhisi2} (nil)
    (expr_list:REG_DEAD (reg:HI 17 mof)
        (nil)))
c_skey.c:165: internal compiler error: in copyprop_hardreg_forward_1, at regrename.c:1613
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:https://dev.openwrt.org/> for instructions.
Comment 1 Hinko Kocevar 2008-06-10 07:31:44 UTC
Created attachment 15744 [details]
preprocessed source that caused the internal compiler error

Created with:
cris-linux-uclibc-gcc -I.. -I../.. -I../../include -fPIC -DOPENSSL_PIC -DZLIB_SHARED -DZLIB -DDSO_DLFCN -DHAVE_DLFCN_H -I/work/stage/openwrt2/staging_dir/cris/usr/include -I/work/stage/openwrt2/staging_dir/cris/include -DOPENSSL_SMALL_FOOTPRINT -DOPENSSL_NO_ERR -DTERMIO -Os -fhonour-copts -fomit-frame-pointer -Wall   -c -o c_skey.o c_skey.c -v -save-temps
Comment 2 Hinko Kocevar 2008-06-23 10:05:17 UTC
I can recreate the same error with gcc-4.3.1 and gcc-4.4-20080502. I also fails to compile linux kernel:
..
  CC      lib/zlib_deflate/deflate_syms.o
(const_int -13 [0xfffffff3])
net/core/stream.c: In function 'sk_stream_wait_connect':
net/core/stream.c:78: internal compiler error: output_operand: invalid operand for 'p' modifier
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
{standard input}: Assembler messages:
{standard input}:488: Warning: partial line at end of file ignored
make[3]: *** [net/core/stream.o] Error 1
make[2]: *** [net/core] Error 2
make[1]: *** [net] Error 2
make[1]: *** Waiting for unfinished jobs....
  CC      fs/jffs2/readinode.o
  CC      drivers/mtd/mtdsuper.o

..
Comment 3 Richard Biener 2009-05-24 11:42:49 UTC
*** Bug 39765 has been marked as a duplicate of this bug. ***
Comment 4 Richard Biener 2009-05-24 11:43:01 UTC
*** Bug 40232 has been marked as a duplicate of this bug. ***
Comment 5 Richard Biener 2009-05-24 11:46:09 UTC
PR39685 also looks related, but with a different instruction kind
Comment 6 Richard Biener 2009-05-24 11:48:26 UTC
Hm, also see PR23424.  HP - time to revisit these?
Comment 7 Hans-Peter Nilsson 2009-10-12 04:12:42 UTC
(In reply to comment #6)
> PR39685 also looks related, but with a different instruction kind

Huh?  That's a different port.

(In reply to comment #6)
> Hm, also see PR23424.

Why?  Wrong number?

>  HP - time to revisit these?

Now *that*'s true!  But... this was a duplicate.

Comment 8 Hans-Peter Nilsson 2009-10-12 04:14:52 UTC

*** This bug has been marked as a duplicate of 26515 ***