Bug 36290 - Excessive build time
Summary: Excessive build time
Status: RESOLVED DUPLICATE of bug 30052
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 4.2.3
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-21 14:07 UTC by Matteo Bertini
Modified: 2008-05-21 14:18 UTC (History)
16 users (show)

See Also:
Host:
Target: i486-linux-gnu
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
ii file (477.40 KB, application/octet-stream)
2008-05-21 14:08 UTC, Matteo Bertini
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matteo Bertini 2008-05-21 14:07:17 UTC
naufraghi@rosen:/opt/stuff/$ g++ -v -save-temps -c -pipe -fPIC -O3 -Wall -W -D_REENTRANT -DQT3_SUPPORT -DQT_NO_DEBUG -DQT_XML_LIB -DQT_SQL_LIB -DQT_NETWORK_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I. -I/opt/stuff/lib/build -I/usr/include/python2.5 -I/usr/mkspecs/linux-g++ -I/usr/include/qt4/Qt3Support -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtSvg -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtCore -I/usr/include/qt4 -I/usr/X11R6/include -o sipQtGuipart0.o lib/PyQt/_qt/sipQtGuipart0.cpp
g++: warning: -pipe ignored because -save-temps specified
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --with-gxx-include-dir=/usr/include/c++/4.2 --program-suffix=-4.2 --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-mpfr --enable-targets=all --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)
 /usr/lib/gcc/i486-linux-gnu/4.2.3/cc1plus -E -quiet -v -I. -I/opt/dacanc/caligola3d/lib/build -I/usr/include/python2.5 -I/usr/mkspecs/linux-g++ -I/usr/include/qt4/Qt3Support -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtSvg -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtCore -I/usr/include/qt4 -I/usr/X11R6/include -D_GNU_SOURCE -D_REENTRANT -DQT3_SUPPORT -DQT_NO_DEBUG -DQT_XML_LIB -DQT_SQL_LIB -DQT_NETWORK_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB lib/PyQt/_qt/sipQtGuipart0.cpp -mtune=generic -Wall -W -fPIC -O3 -fpch-preprocess -o sipQtGuipart0.ii
ignoring nonexistent directory "/usr/local/include/i486-linux-gnu"
ignoring nonexistent directory "/usr/lib/gcc/i486-linux-gnu/4.2.3/../../../../i486-linux-gnu/include"
ignoring nonexistent directory "/usr/include/i486-linux-gnu"
ignoring nonexistent directory "/usr/mkspecs/linux-g++"
ignoring nonexistent directory "/usr/X11R6/include"
#include "..." search starts here:
#include <...> search starts here:
 .
 /opt/dacanc/caligola3d/lib/build
 /usr/include/python2.5
 /usr/include/qt4/Qt3Support
 /usr/include/qt4/QtXml
 /usr/include/qt4/QtSql
 /usr/include/qt4/QtNetwork
 /usr/include/qt4/QtSvg
 /usr/include/qt4/QtOpenGL
 /usr/include/qt4/QtGui
 /usr/include/qt4/QtCore
 /usr/include/qt4
 /usr/include/c++/4.2
 /usr/include/c++/4.2/i486-linux-gnu
 /usr/include/c++/4.2/backward
 /usr/local/include
 /usr/lib/gcc/i486-linux-gnu/4.2.3/include
 /usr/include
End of search list.
 /usr/lib/gcc/i486-linux-gnu/4.2.3/cc1plus -fpreprocessed sipQtGuipart0.ii -quiet -dumpbase sipQtGuipart0.cpp -mtune=generic -auxbase-strip sipQtGuipart0.o -O3 -Wall -W -version -fPIC -fstack-protector -fstack-protector -o sipQtGuipart0.s
GNU C++ version 4.2.3 (Ubuntu 4.2.3-2ubuntu7) (i486-linux-gnu)
	compiled by GNU C version 4.2.3 (Ubuntu 4.2.3-2ubuntu7).
GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072
Compiler executable checksum: 9cf91ba46d80e564052e4fbab0d6561b

... and still forever
Comment 1 Matteo Bertini 2008-05-21 14:08:49 UTC
Created attachment 15662 [details]
ii file
Comment 2 Richard Biener 2008-05-21 14:18:21 UTC

*** This bug has been marked as a duplicate of 30052 ***