Bug 36284 - gcc.dg-struct-layout fails AVR target - multiple reasons
Summary: gcc.dg-struct-layout fails AVR target - multiple reasons
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: testsuite (show other bugs)
Version: 4.4.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-20 22:39 UTC by Andy Hutchinson
Modified: 2008-06-19 02:16 UTC (History)
2 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: avr-unknown-none
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Extract from gcc.log (2.20 KB, text/plain)
2008-05-20 22:41 UTC, Andy Hutchinson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Hutchinson 2008-05-20 22:39:11 UTC
gcc/testsuite/gcc/gcc.dg-struct-layout-1 fails multiple times for AVR target due to non-portable testcase.

This test has 28 generated variants, all fail.
Problems include:

1)Assumes int are 32 bit

gcc/gcc.dg-struct-layout-1//t001_test.h:119: error: width of 'a'

2) Assumes availability of DF mode
gcc.dg/compat/vector-defs.h:9: error: unable to emulate 'DF'

3) Some undefined problem - maybe size >32767?
short_enums30131.c:3: error: size of array 's' is negative


I will post snippet of log file to aid correction.
Comment 1 Andy Hutchinson 2008-05-20 22:41:52 UTC
Created attachment 15658 [details]
Extract from gcc.log

Extract from gcc.log showing failure details. For economy, not all 28 tests are shown.
Comment 2 Andy Hutchinson 2008-06-18 21:54:04 UTC
Subject: Bug 36284

Author: hutchinsonandy
Date: Wed Jun 18 21:53:20 2008
New Revision: 136920

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=136920
Log:
PR testsuite/36284
* gcc.dg/compat/struct-layout-1_generate.c (switchfiles): Require int32plus for generated main files.

Modified:
    trunk/gcc/testsuite/ChangeLog
    trunk/gcc/testsuite/gcc.dg/compat/struct-layout-1_generate.c

Comment 3 Andy Hutchinson 2008-06-19 02:16:08 UTC
Testcase fixed for 4.4