Bug 35971 - ICE on valid code with C_FUNPTR and transfer
Summary: ICE on valid code with C_FUNPTR and transfer
Status: RESOLVED DUPLICATE of bug 36463
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.4.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2008-04-18 08:20 UTC by Francois-Xavier Coudert
Modified: 2008-10-20 12:02 UTC (History)
5 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2008-04-20 21:19:39


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francois-Xavier Coudert 2008-04-18 08:20:46 UTC
From comp.lang.fortran: ICE on the following code

module funcs
   implicit none
! Interface block for function program fptr will invoke
! to get the C_FUNPTR
   interface
      function get_proc(mess) bind(C,name='BlAh')
         use ISO_C_BINDING
         implicit none
         character(kind=C_CHAR) mess(*)
         type(C_FUNPTR) get_proc
      end function get_proc
   end interface
end module funcs

module other_fun
   use ISO_C_BINDING
   implicit none
   private
! Message to be returned by procedure pointed to
! by the C_FUNPTR
   character, allocatable, save :: my_message(:)
! Interface block for the procedure pointed to
! by the C_FUNPTR
   public abstract_fun
   abstract interface
      function abstract_fun(x)
         use ISO_C_BINDING
         import my_message
         implicit none
         integer(C_INT) x(:)
         character(size(my_message),C_CHAR) abstract_fun(size(x))
      end function abstract_fun
   end interface
   contains
! Procedure to store the message and get the C_FUNPTR
      function gp(message) bind(C,name='BlAh')
         character(kind=C_CHAR) message(*)
         type(C_FUNPTR) gp
         integer(C_INT64_T) i

         i = 1
         do while(message(i) /= C_NULL_CHAR)
            i = i+1
         end do
         my_message = message(int(1,kind(i)):i-1)
         gp = get_funloc(make_mess,aux)
      end function gp

! Intermediate procedure to pass the function and get
! back the C_FUNPTR
      function get_funloc(x,y)
         procedure(abstract_fun) x
         type(C_FUNPTR) y
         external y
         type(C_FUNPTR) get_funloc
   
         get_funloc = y(x)
      end function get_funloc

! Procedure to convert the function to C_FUNPTR
      function aux(x)
         interface
            subroutine x() bind(C)
            end subroutine x
         end interface
         type(C_FUNPTR) aux

         aux = C_FUNLOC(x)
      end function aux
      
! Procedure pointed to by the C_FUNPTR
      function make_mess(x)
         integer(C_INT) x(:)
         character(size(my_message),C_CHAR) make_mess(size(x))
         
         make_mess = transfer(my_message,make_mess(1))
      end function make_mess
end module other_fun

program fptr
   use funcs
   use other_fun
   implicit none
   interface
      procedure(abstract_fun) fun
   end interface
   pointer(p,fun)
   type(C_FUNPTR) fp
         
   fp = get_proc('Hello, world'//achar(0))
   p = transfer(fp,p)
   write(*,'(a)') fun([1,2,3])
end program fptr




Program received signal SIGSEGV, Segmentation fault.
gfc_is_compile_time_shape (as=0x0) at ../../../trunk2/gcc/fortran/array.c:2095
2095      if (as->type != AS_EXPLICIT)
(gdb) bt
#0  gfc_is_compile_time_shape (as=0x0)
    at ../../../trunk2/gcc/fortran/array.c:2095
#1  0x00000000004680ec in resolve_symbol (sym=0x101bc00)
    at ../../../trunk2/gcc/fortran/resolve.c:6810
#2  0x0000000000473637 in traverse_ns (st=0x101bda0, 
    func=0x466490 <resolve_symbol>)
    at ../../../trunk2/gcc/fortran/symbol.c:2978
#3  0x0000000000462a40 in resolve_types (ns=0x101b4b0)
    at ../../../trunk2/gcc/fortran/resolve.c:9059
#4  0x000000000046646d in gfc_resolve (ns=0x0)
    at ../../../trunk2/gcc/fortran/resolve.c:9138
#5  0x00000000004667e9 in resolve_symbol (sym=0x1017150)
    at ../../../trunk2/gcc/fortran/resolve.c:8064
Comment 1 Thomas Koenig 2008-04-20 21:19:39 UTC
Confirmed.

Reduced testcase:

module other_fun
   use ISO_C_BINDING
   implicit none
   private
! Message to be returned by procedure pointed to
! by the C_FUNPTR
   character, allocatable, save :: my_message(:)
! Interface block for the procedure pointed to
! by the C_FUNPTR
   public abstract_fun
   abstract interface
      function abstract_fun(x)
         use ISO_C_BINDING
         import my_message
         implicit none
         integer(C_INT) x(:)
         character(size(my_message),C_CHAR) abstract_fun(size(x))
      end function abstract_fun
   end interface
   contains

! Intermediate procedure to pass the function and get
! back the C_FUNPTR
      function get_funloc(x,y)
         procedure(abstract_fun) x
         type(C_FUNPTR) y
         external y
         type(C_FUNPTR) get_funloc

         get_funloc = y(x)
      end function get_funloc
end module other_fun

Comment 2 janus 2008-06-29 08:58:07 UTC
The test case in comment #1 does compile for me without any ICE. The test case in comment #0 is actually invalid, triggering the following error message:

      procedure(abstract_fun) fun
              1
Error: PROCEDURE at (1) must be in a generic interface

One simply has to remove the interface statement from the main program:

program fptr
   use funcs
   use other_fun
   implicit none
   procedure(abstract_fun) fun
   pointer(p,fun)
   type(C_FUNPTR) fp

   fp = get_proc('Hello, world'//achar(0))
   p = transfer(fp,p)
   write(*,'(a)') fun([1,2,3])
end program fptr

With this I also get an ICE.
Comment 3 janus 2008-10-20 12:02:30 UTC

*** This bug has been marked as a duplicate of 36463 ***