Bug 35636 - [4.4 Regression] gcc.dg/tree-ssa/loop-25.c
Summary: [4.4 Regression] gcc.dg/tree-ssa/loop-25.c
Status: RESOLVED DUPLICATE of bug 35629
Alias: None
Product: gcc
Classification: Unclassified
Component: tree-optimization (show other bugs)
Version: 4.4.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-19 06:17 UTC by H.J. Lu
Modified: 2008-03-19 06:58 UTC (History)
5 users (show)

See Also:
Host:
Target: x86_64-unknown-linux-gnu
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2008-03-19 06:17:12 UTC
Gcc 4.4 revision 133314 has

FAIL: gcc.dg/tree-ssa/loop-25.c scan-tree-dump-times profile "Found latch edge" 5
FAIL: gcc.dg/tree-ssa/loop-25.c scan-tree-dump-times profile "Merged latch edges" 2
FAIL: gcc.dg/tree-ssa/loop-25.c scan-tree-dump-times profile "4 loops found" 2
FAIL: gcc.dg/tree-ssa/loop-25.c scan-tree-dump-times profile "3 loops found" 2
FAIL: gcc.dg/tree-ssa/loop-25.c scan-tree-dump-times profile "2 loops found" 1

Revision 133311 is OK. I think revision 133313

http://gcc.gnu.org/ml/gcc-cvs/2008-03/msg00531.html

is the cause.
Comment 1 Uroš Bizjak 2008-03-19 06:58:18 UTC

*** This bug has been marked as a duplicate of 35629 ***