User account creation filtered due to spam.

Bug 35508 - [avr] 4.3.0: undefined reference to `__ffshi2'
Summary: [avr] 4.3.0: undefined reference to `__ffshi2'
Status: RESOLVED DUPLICATE of bug 34210
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.3.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-08 09:24 UTC by Dmitry K.
Modified: 2008-03-23 03:04 UTC (History)
6 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry K. 2008-03-08 09:24:36 UTC
The next program is not linked (-Os option):

  int ffs (int);
  int main (int argc, char *argv[])
  {
    (void)argv;
    return ffs (argc);
  }

with undefined link to '__ffshi2'.

The used libc library (Avr-libc project) contains the ffs() funcion.
Comment 1 Andy Hutchinson 2008-03-22 23:51:00 UTC
This is same bug as:

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=34210

working on fix - to be posted soon.
Comment 2 Andy Hutchinson 2008-03-23 00:24:55 UTC
Patch posted

http://gcc.gnu.org/ml/gcc-patches/2008-03/msg01341.html
Comment 3 Eric Weddington 2008-03-23 03:04:22 UTC

*** This bug has been marked as a duplicate of 34210 ***
Comment 4 Andy Hutchinson 2008-04-07 23:16:23 UTC
Subject: Bug 35508

Author: hutchinsonandy
Date: Mon Apr  7 23:15:35 2008
New Revision: 133993

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=133993
Log:
PR target/34210 PR target/35508 * config.host (avr-*-*): Add avr cpu_type and avr tmake_file. * config/t-avr: New file. Build 16bit libgcc functions.

Added:
    trunk/libgcc/config/avr/
    trunk/libgcc/config/avr/t-avr
Modified:
    trunk/libgcc/ChangeLog
    trunk/libgcc/config.host