Bug 35129 - -pedantic changes code-generation for unsigned enumerators
Summary: -pedantic changes code-generation for unsigned enumerators
Status: RESOLVED DUPLICATE of bug 15236
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 4.3.0
: P3 enhancement
Target Milestone: ---
Assignee: Manuel López-Ibáñez
URL:
Keywords:
Depends on:
Blocks: 4.4pending
  Show dependency treegraph
 
Reported: 2008-02-07 19:54 UTC by Manuel López-Ibáñez
Modified: 2008-02-07 20:34 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Patch (1.66 KB, patch)
2008-02-07 19:56 UTC, Manuel López-Ibáñez
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel López-Ibáñez 2008-02-07 19:54:12 UTC
-pedantic converts enumerators to 'int', while without -pedantic they are handled as-is.
Comment 1 Manuel López-Ibáñez 2008-02-07 19:56:13 UTC
Created attachment 15117 [details]
Patch

Bootstrapped with --enable-languages=all and regression tested on x86_64-unknown-linux-gnu
Comment 2 Manuel López-Ibáñez 2008-02-07 19:57:38 UTC
Got the blocks/depends thing wrong, sorry.
Comment 3 Andrew Pinski 2008-02-07 20:34:05 UTC

*** This bug has been marked as a duplicate of 15236 ***