Bug 34616 - CBLAS_ICAMAX test from cblas fails
Summary: CBLAS_ICAMAX test from cblas fails
Status: RESOLVED DUPLICATE of bug 323
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.3.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-29 18:49 UTC by İsmail Dönmez
Modified: 2007-12-29 20:09 UTC (History)
52 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description İsmail Dönmez 2007-12-29 18:49:35 UTC
How to reproduce;

wget -c http://www.netlib.org/blas/blast-forum/cblas.tgz

unpack & build.

make all
make alltst

and run CBLAS_ICAMAX test to see :

[~/CBLAS]> ./testing/xccblat1
 Complex CBLAS Test Program Results


 Test of subprogram number  1         CBLAS_CDOTC
                                    ----- PASS -----

 Test of subprogram number  2         CBLAS_CDOTU
                                    ----- PASS -----

 Test of subprogram number  3         CBLAS_CAXPY
                                    ----- PASS -----

 Test of subprogram number  4         CBLAS_CCOPY
                                    ----- PASS -----

 Test of subprogram number  5         CBLAS_CSWAP
                                    ----- PASS -----

 Test of subprogram number  6         CBLAS_SCNRM2
                                    ----- PASS -----

 Test of subprogram number  7         CBLAS_SCASUM
                                    ----- PASS -----

 Test of subprogram number  8         CBLAS_CSCAL
                                    ----- PASS -----

 Test of subprogram number  9         CBLAS_CSSCAL
                                    ----- PASS -----

 Test of subprogram number 10         CBLAS_ICAMAX
                                       FAIL

 CASE  N INCX INCY MODE                                COMP                                TRUE     DIFFERENCE

   10  4    1 9999 9999                                   3                                   2           1
   10  4    2 9999 9999                                   3                                   2           1

Last test fails.

gcc says :

[~]> gcc -v
Using built-in specs.
Target: i686-pc-linux-gnu
Configured with: ../configure --prefix=/usr --bindir=/usr/i686-pc-linux-gnu/gcc/4.3.0 --includedir=/usr/lib/gcc/i686-pc-linux-gnu/4.3.0/include --datadir=/usr/share/gcc/i686-pc-linux-gnu/4.3.0 --mandir=/usr/share/gcc/i686-pc-linux-gnu/4.3.0/man --infodir=/usr/share/gcc/i686-pc-linux-gnu/4.3.0/info --with-gxx-include-dir=/usr/lib/gcc/i686-pc-linux-gnu/4.3.0/include/g++-v3 --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu --disable-libgcj --disable-libssp --disable-multilib --disable-nls --disable-werror --disable-mudflap --disable-libmudflap --enable-checking=release --enable-clocale=gnu --enable-__cxa_atexit --enable-languages=c,c++,fortran,objc --enable-libstdcxx-allocator=new --enable-shared --enable-ssp --enable-threads=posix --enable-version-specific-runtime-libs --without-included-gettext --without-system-libunwind --with-system-zlib --with-pkgversion='Pardus Linux' --with-bugurl=http://bugs.pardus.org.tr
Thread model: posix
gcc version 4.3.0 20071229 [trunk revision 131217] (Pardus Linux)
Comment 1 Andrew Pinski 2007-12-29 19:32:39 UTC
What happens if you add -ffloat-store ?
Comment 2 kargl 2007-12-29 19:44:29 UTC
How is this a Fortran issue?  CBLAS uses C.
What options did you use to build CBLAS?
Is the backing BLAS also built from netlib sources
and with what options was is it?
Comment 3 Andrew Pinski 2007-12-29 19:46:50 UTC
Anyways -ffloat-store fixes the issue so a dup of bug 323.

*** This bug has been marked as a duplicate of 323 ***
Comment 4 Jerry DeLisle 2007-12-29 20:09:34 UTC
CBLAS actually has a few Fortran programs in it.  The default build uses g77 on Linux.  Regardless, I was able to build -m64 and -m32 without any failures using gfortran.