Bug 34582 - JConsole throws an exception when initialising the RMI secure sockets factory
JConsole throws an exception when initialising the RMI secure sockets factory
Status: RESOLVED FIXED
Product: classpath
Classification: Unclassified
Component: classpath
unspecified
: P3 normal
: 0.97
Assigned To: Andrew John Hughes
:
Depends on:
Blocks: 34078
  Show dependency treegraph
 
Reported: 2007-12-25 04:25 UTC by Andrew John Hughes
Modified: 2008-02-15 21:29 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Mauve test for the bug (1.93 KB, text/x-patch)
2007-12-31 04:02 UTC, Andrew John Hughes
Details
Committed patch (1.32 KB, patch)
2007-12-31 04:30 UTC, Andrew John Hughes
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew John Hughes 2007-12-25 04:25:21 UTC
Type a hostname and port (doesn't have to actually work) and click Connect.  The class initializer of the ProxyClient class in JConsole will try to obtain a SslRmiClientSocketFactory whose constructor will throw an exception.

Exception in thread "JConsole.addHost" java.lang.ExceptionInInitializerError
   at sun.tools.jconsole.JConsole$3.run(JConsole.java:528)
Caused by: java.lang.NullPointerException
   at java.util.StringTokenizer.<init>(StringTokenizer.java:133)
   at java.util.StringTokenizer.<init>(StringTokenizer.java:116)
   at javax.rmi.ssl.SslRMIClientSocketFactory.getProp(SslRMIClientSocketFactory.java:99)
   at javax.rmi.ssl.SslRMIClientSocketFactory.<init>(SslRMIClientSocketFactory.java:89)
   at sun.tools.jconsole.ProxyClient.<clinit>(ProxyClient.java:84)
   at sun.tools.jconsole.JConsole$3.run(JConsole.java:528)
Comment 1 Andrew John Hughes 2007-12-31 04:02:32 UTC
Created attachment 14845 [details]
Mauve test for the bug
Comment 2 cvs-commit@developer.classpath.org 2007-12-31 04:30:13 UTC
Subject: Bug 34582

CVSROOT:	/cvsroot/classpath
Module name:	classpath
Changes by:	Andrew John Hughes <gnu_andrew>	07/12/31 04:29:32

Modified files:
	.              : ChangeLog 
	javax/rmi/ssl  : SslRMIClientSocketFactory.java 

Log message:
	2007-12-31  Andrew John Hughes  <gnu_andrew@member.fsf.org>
	
	        PR classpath/34582:
		* javax/rmi/ssl/SslRMIClientSocketFactory.java:
		(getProp(String)): Check for the property being null.

CVSWeb URLs:
http://cvs.savannah.gnu.org/viewcvs/classpath/ChangeLog?cvsroot=classpath&r1=1.9455&r2=1.9456
http://cvs.savannah.gnu.org/viewcvs/classpath/javax/rmi/ssl/SslRMIClientSocketFactory.java?cvsroot=classpath&r1=1.2&r2=1.3



Comment 3 Andrew John Hughes 2007-12-31 04:30:26 UTC
Created attachment 14846 [details]
Committed patch
Comment 4 Andrew John Hughes 2007-12-31 04:30:52 UTC
Fix committed. Closing.