Bug 33708 - Building X.org 6.9.0
Summary: Building X.org 6.9.0
Status: RESOLVED DUPLICATE of bug 30052
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.2.2
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-09 09:26 UTC by Philip
Modified: 2007-10-09 11:44 UTC (History)
14 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip 2007-10-09 09:26:28 UTC
System type: Linux Slackware 2.6.22.5 #1 SMP Fri Aug 24 13:40:28 CEST 2007 i686 unknown unknown GNU/Linux

gcc -m32 -c -O2 -fno-strength-reduce -fno-strict-aliasing -ansi -Wall -Wpointer-arith -Wundef    -I../../../../../programs/Xserver/hw/xfree86/common -I../../../../../programs/Xserver/hw/xfree86/os-support -I../../../../../programs/Xserver/hw/xfree86/os-support/bus           -I../../../../../programs/Xserver/include -I../../../../../programs/Xserver/os    -I../../../../../exports/include/X11 -I../../../../../programs/Xserver/Xext -I../../../../../include/extensions          -I../../../../../programs/Xserver/Xi            -I../../../../../lib/font/include -I../../../../../programs/Xserver/hw/xfree86/parser              -I../../../../../programs/Xserver/hw/xfree86/loader  -I../../../../../programs/Xserver/hw/xfree86/rac  -I../../../../.. -I../../../../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L                            -D_POSIX_SOURCE -D_XOPEN_SOURCE             D_BSD_SOURCE -D_SVID_SOURCE                                 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64                           -D_GNU_SOURCE                           -DSHAPE -DXINPUT -DXKB -DLBX -DXAPPGROUP  -DXCSECURITY -DTOGCUP   -DXF86BIGFONT -DDPMSExtension   -DXPRINT -DPIXPRIV -DPANORAMIX   -DRENDER -DRANDR       -DXFIXES -DDAMAGE -DCOMPOSITE -DXEVIE       -DGCCUSESGAS -DAVOID_GLYPHBLT -DPIXPRIV -DSINGLEDEPTH                          -DXFreeXDGA -DXvExtension                               -DXFree86LOADER -DDLOPEN_HACK -DXFree86Server                              -DXF86VIDMODE                           -DXvMCExtension                                 -DSMART_SCHEDULE                                -DBUILDDEBUG -DXResExtension                               -DX_BYTE_ORDER=X_LITTLE_ENDIAN                          -DXORG_VERSION_CURRENT="(((6) * 10000000) + ((9) * 100000) + ((0) * 1000) + 0)" -DNDEBUG   -DFUNCPROTO=15 -DNARROWPROTO      xf86ScanPci.c
gcc: Internal error: Killed (program cc1)
Please submit a full bug report.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
make[6]: *** [xf86ScanPci.o] Error 1
make[6]: Leaving directory `/usr/src/xc/build/programs/Xserver/hw/xfree86/scanpci'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/usr/src/xc/build/programs/Xserver/hw/xfree86'
make[4]: *** [hw/xfree86] Error 2
make[4]: Leaving directory `/usr/src/xc/build/programs/Xserver'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/usr/src/xc/build/programs'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/usr/src/xc/build'
make[1]: *** [World] Error 2
make[1]: Leaving directory `/usr/src/xc/build'
make: *** [World] Error 2
Comment 1 Pawel Sikora 2007-10-09 09:40:22 UTC
duplicate of PR30052
Comment 2 Andrew Pinski 2007-10-09 10:32:11 UTC
>gcc: Internal error: Killed (program cc1)

How much memory do you have?

Comment 3 Philip 2007-10-09 10:55:56 UTC
512 MB
Comment 4 Richard Biener 2007-10-09 11:44:30 UTC

*** This bug has been marked as a duplicate of 30052 ***