User account creation filtered due to spam.

Bug 33678 - [4.2.0 regression] __do_catch, __do_upcast ABI change
Summary: [4.2.0 regression] __do_catch, __do_upcast ABI change
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 4.2.1
: P1 blocker
Target Milestone: 4.2.2
Assignee: Not yet assigned to anyone
URL:
Keywords: ABI
: 35081 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-10-06 15:59 UTC by Benjamin Kosnik
Modified: 2008-02-04 20:18 UTC (History)
6 users (show)

See Also:
Host:
Target:
Build:
Known to work: 3.4.0 4.0.0 4.1.0 4.2.0
Known to fail: 4.2.1
Last reconfirmed: 2007-10-08 08:54:30


Attachments
fix (534 bytes, patch)
2007-10-06 16:04 UTC, Benjamin Kosnik
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Kosnik 2007-10-06 15:59:39 UTC
First reported by Daniel Jacobowitz here:
http://gcc.gnu.org/ml/libstdc++/2007-10/msg00036.html

The patch is as attached.
Comment 1 Benjamin Kosnik 2007-10-06 16:04:13 UTC
Created attachment 14311 [details]
fix
Comment 2 Benjamin Kosnik 2007-10-06 23:40:43 UTC
Subject: Bug 33678

Author: bkoz
Date: Sat Oct  6 23:40:32 2007
New Revision: 129058

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=129058
Log:
2007-10-06  Benjamin Kosnik  <bkoz@redhat.com>

	PR libstdc++/33678	
	* libsupc++/typeinfo (typeinfo): Revert ordering of virtual components.


Modified:
    trunk/libstdc++-v3/ChangeLog
    trunk/libstdc++-v3/libsupc++/typeinfo

Comment 3 Benjamin Kosnik 2007-10-06 23:48:42 UTC
Subject: Bug 33678

Author: bkoz
Date: Sat Oct  6 23:48:31 2007
New Revision: 129061

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=129061
Log:
2007-10-06  Benjamin Kosnik  <bkoz@redhat.com>

	PR libstdc++/33678	
	* libsupc++/typeinfo (typeinfo): Revert ordering of virtual components.


Modified:
    branches/gcc-4_2-branch/libstdc++-v3/ChangeLog
    branches/gcc-4_2-branch/libstdc++-v3/libsupc++/typeinfo

Comment 4 Benjamin Kosnik 2007-10-08 20:42:56 UTC
Fixed.
Comment 5 Andrew Pinski 2008-02-04 20:18:48 UTC
*** Bug 35081 has been marked as a duplicate of this bug. ***