Bug 33195 - [4.2 Regression] ICE: calc_dfs_tree, at dominance.c:374
Summary: [4.2 Regression] ICE: calc_dfs_tree, at dominance.c:374
Status: RESOLVED DUPLICATE of bug 31947
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.2.1
: P1 normal
Target Milestone: 4.2.3
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2007-08-26 15:43 UTC by mi@aldan.algebra.com
Modified: 2008-01-16 13:28 UTC (History)
8 users (show)

See Also:
Host: x86_64-portbld-freebsd6.2
Target: x86_64-portbld-freebsd6.2
Build: x86_64-portbld-freebsd6.2
Known to work: 4.1.2 4.3.0
Known to fail: 4.2.1
Last reconfirmed: 2007-08-27 08:09:50


Attachments
The pre-processed vital_timing.cc -- the test case (100.34 KB, text/x-c++; charset=us-ascii)
2007-08-26 15:45 UTC, mi@aldan.algebra.com
Details
reduced testcase (381 bytes, text/plain)
2007-08-27 08:08 UTC, Richard Biener
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mi@aldan.algebra.com 2007-08-26 15:43:22 UTC
Trying to compile the attached file with 4.2.1 20070712 fails with -O2:


-O works.

vital_timing.cc: In function 'array_type<long long int> L4ieee_Q12vital_timing_Y22vitalextendtofilldelay_i259(const array_type<long long int>&)':
vital_timing.cc:1055: internal compiler error: in calc_dfs_tree, at dominance.c:374

Or, when using the properly pre-processed file:

vital_timing.i: In function 'array_type<long long int> L4ieee_Q12vital_timing_Y22vitalextendtofilldelay_i259(const array_type<long long int>&)':
vital_timing.i:21623: internal compiler error: in calc_dfs_tree, at dominance.c:374
Comment 1 mi@aldan.algebra.com 2007-08-26 15:45:36 UTC
Created attachment 14118 [details]
The pre-processed vital_timing.cc -- the test case
Comment 2 Richard Biener 2007-08-27 07:45:54 UTC
reducing
Comment 3 Richard Biener 2007-08-27 08:08:20 UTC
Created attachment 14122 [details]
reduced testcase
Comment 4 Richard Biener 2007-08-27 08:09:50 UTC
Confirmed.
Comment 5 Mark Mitchell 2007-10-09 19:20:47 UTC
Change target milestone to 4.2.3, as 4.2.2 has been released.
Comment 6 David Fang 2007-10-09 19:44:00 UTC
tastes like PR 31947 ?
Comment 7 Richard Biener 2008-01-16 13:28:59 UTC

*** This bug has been marked as a duplicate of 31947 ***