Bug 33174 - Testsuite: unexpected failures
Summary: Testsuite: unexpected failures
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.3.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
: 33175 (view as bug list)
Depends on:
Reported: 2007-08-24 12:45 UTC by Dale Ranta
Modified: 2007-10-02 11:20 UTC (History)
3 users (show)

See Also:
Host: i686-pc-cygwin
Target: i686-pc-cygwin
Known to work:
Known to fail:
Last reconfirmed:

testsuite output (2.22 KB, text/plain)
2007-08-24 12:46 UTC, Dale Ranta

Note You need to log in before you can comment on or make changes to this bug.
Description Dale Ranta 2007-08-24 12:45:41 UTC
Some of my programs run Ok with gfortran on the Macintosh and Linux, but fail on CYGWIN and MSYS - so I ran the testsuite. Several unexpected failures were found -

                === gcc Summary ===

# of expected passes            47388
# of unexpected failures        60
# of unexpected successes       1
# of expected failures          140
# of unresolved testcases       2
# of untested testcases         42
# of unsupported tests          433

                === gfortran Summary ===

# of expected passes            19496
# of unexpected failures        1
# of expected failures          9
# of unsupported tests          86
Comment 1 Dale Ranta 2007-08-24 12:46:50 UTC
Created attachment 14101 [details]
testsuite output
Comment 2 Tobias Burnus 2007-08-24 15:05:43 UTC
*** Bug 33175 has been marked as a duplicate of this bug. ***
Comment 3 Francois-Xavier Coudert 2007-08-24 16:24:52 UTC
cygwin or msys? What is the host, what is the target?

As far as I see, there is only one gfortran failure:

FAIL: gfortran.fortran-torture/compile/pr32417.f90,  "-O"   (internal compiler error)

I don't see it on a fresh mingw native compiler (rev 127394M).
Comment 4 Dale Ranta 2007-08-24 18:40:35 UTC
The Host and the Target was cygwin. There 60 unexpected failures in the gcc testsuite and one in the fortran testsuite. 

I have the latest version of gcc (3.4.4) that the cygwin site gives out. Is that the "fresh mingw native compiler" ?

The gcc and gfortran are version 4.3.0 20070723 from svn, built on the cygwin system.

Comment 5 Dale Ranta 2007-08-24 19:27:39 UTC
> gfortran --v

Using built-in specs.

Target: i686-pc-cygwin

Configured with: ../gcc/configure --disable-bootstrap --enable-multilib --prefix=/usr/local/gfortran --enable-languages=c,fortran --with-gmp=/usr/local/lib --with-mpfr=/usr/local/lib

Thread model: single

gcc version 4.3.0 20070723 (experimental)


Comment 6 Francois-Xavier Coudert 2007-08-27 10:10:49 UTC
So everything (target == host) is cygwin. I'm sorry for the confusion, but as you talked about MSYS in your original report, I thought it would be some kind of cygwin-hosted mingw compiler...

About the failures themselves:
  * it is currently expected that gfortran.fortran-torture/execute/intrinsic_integer.f90 fails, because of a bug in the cygwin math library; I'm surprised that it doesn't fail for you
  * could you try to compile pr32417.f90 yourself, and produce a backtrace of the ICE? Use "gfortran -v pr32417.f90", from the output of that command, look at the command-line for the "f951" command, run it under gdb (gdb -args /path/to/f951 .....), set a breakpoint on fancy_abort ("break fancy_abort") and when the breakpoint (or a segfault) is hit, ask for backtrace ("backtrace"). Copy-paste the result here.
Comment 7 Dale Ranta 2007-08-27 13:12:23 UTC
My programs fail in the save way on MSYS and GYGWIN, but on none of the other versions of gfortran. 

I tried intrinsic_integer.f90 by hand and it does not fail on my gfortran version.

Here is the traceback for pr32417.f90 -

(gdb) run
Starting program: /usr/local/gfortran/libexec/gcc/i686-pc-cygwin/4.3.0/f951.exe pr32417.f90 -quiet -dumpbase pr32417.f90 -mtune=generic -auxbase pr32417 -O -version -fintrinsic-modules-path /usr/local/gfortran/lib/gcc/i686-pc-cygwin/4.3.0/finclude
Loaded symbols for /cygdrive/d/WINDOWS/system32/ntdll.dll
Loaded symbols for /cygdrive/d/WINDOWS/system32/kernel32.dll
Loaded symbols for /usr/bin/cygwin1.dll
Loaded symbols for /cygdrive/d/WINDOWS/system32/advapi32.dll
Loaded symbols for /cygdrive/d/WINDOWS/system32/rpcrt4.dll
Loaded symbols for /usr/bin/cygiconv-2.dll
Loaded symbols for /usr/bin/cygintl-8.dll
GNU F95 version 4.3.0 20070723 (experimental) (i686-pc-cygwin)
        compiled by GNU C version 3.4.4 (cygming special, gdc 0.12, using dmd 0.125), GMP version 4.1.4, MPFR version 2.2.0.
GGC heuristics: --param ggc-min-expand=30 --param ggc-min-heapsize=4096

Breakpoint 1, fancy_abort (file=0xbc554b "../../gcc/gcc/tree.c", line=3077, function=0xbc5f2f "build2_stat") at ../../gcc/gcc/diagnostic.c:656
656       internal_error ("in %s, at %s:%d", function, trim_filename (file), line);
(gdb) traceback
Undefined command: "traceback".  Try "help".
(gdb) backtrace
#0  fancy_abort (file=0xbc554b "../../gcc/gcc/tree.c", line=3077, function=0xbc5f2f "build2_stat") at ../../gcc/gcc/diagnostic.c:656
#1  0x004bb42e in build2_stat (code=MINUS_EXPR, tt=0x7ff90cb0, arg0=0x7fcbef60, arg1=0x7fcbef40) at ../../gcc/gcc/tree.c:3101
#2  0x0056a7a7 in fold_build2_stat (code=MINUS_EXPR, type=0x7ff90cb0, op0=0x7fcbef60, op1=0x7fcbef40) at ../../gcc/gcc/fold-const.c:13097
#3  0x00561937 in fold_binary (code=PLUS_EXPR, type=0x7ff90cb0, op0=0x7fcbeea0, op1=0x7fcbef20) at ../../gcc/gcc/fold-const.c:9278
#4  0x0056a77f in fold_build2_stat (code=PLUS_EXPR, type=0x7ff90cb0, op0=0x7fcbeea0, op1=0x7fcbef20) at ../../gcc/gcc/fold-const.c:13095
#5  0x005fdd3a in add_to_parts (parts=0x7fcbeea0, elt=0x7ff90cb0) at ../../gcc/gcc/tree-ssa-address.c:426
#6  0x005fe0ab in create_mem_ref (bsi=0x22c810, type=0x7ff90b60, addr=0x22c790) at ../../gcc/gcc/tree-ssa-address.c:546
#7  0x0097c8da in rewrite_use (data=0x22ca10, use=0x1ef97a0, cand=0x1f0db90) at ../../gcc/gcc/tree-ssa-loop-ivopts.c:5091
#8  0x0097edf3 in tree_ssa_iv_optimize_loop (data=0x22ca10, loop=<incomplete type>) at ../../gcc/gcc/tree-ssa-loop-ivopts.c:5179
#9  0x009801ce in tree_ssa_iv_optimize () at ../../gcc/gcc/tree-ssa-loop-ivopts.c:5382
#10 0x00a55b8b in tree_ssa_loop_ivopts () at ../../gcc/gcc/tree-ssa-loop.c:514
#11 0x006dc1e8 in execute_one_pass (pass=0xb8e6e0) at ../../gcc/gcc/passes.c:1125
#12 0x006dc38e in execute_pass_list (pass=0xb8ea20) at ../../gcc/gcc/passes.c:1178
#13 0x006dc3a1 in execute_pass_list (pass=0xb8dc30) at ../../gcc/gcc/passes.c:1179
#14 0x006dc3a1 in execute_pass_list (pass=0xb8b350) at ../../gcc/gcc/passes.c:1179
#15 0x00714298 in tree_rest_of_compilation (fndecl=0x7fc9b900) at ../../gcc/gcc/tree-optimize.c:406
#16 0x006dd380 in cgraph_expand_function (node=0x7fc9ba80) at ../../gcc/gcc/cgraphunit.c:1073
#17 0x006def9f in cgraph_optimize () at ../../gcc/gcc/cgraphunit.c:1142
#18 0x0046ca1f in gfc_be_parse_file (set_yydebug=0) at ../../gcc/gcc/fortran/f95-lang.c:305
#19 0x00523800 in toplev_main (argc=12, argv=0x1eb2d58) at ../../gcc/gcc/toplev.c:1044
#20 0x004b131a in main (argc=12, argv=0x1eb2d58) at ../../gcc/gcc/main.c:35

Comment 8 Andrew Pinski 2007-08-29 20:42:02 UTC
That ICE is most likely PR 33140.
Comment 9 Francois-Xavier Coudert 2007-09-23 09:35:03 UTC
PR 33140 disappeared from mainline around 2007-09-08. Dale, can you still see the ICE you reported?
Comment 10 Dale Ranta 2007-09-28 20:34:13 UTC
I have tried twice, but I cannot get the testsuite to work. After I added "--enable-checking", The "make -k check-fortran" does a little and fails with -

ERROR:runtest.exe does not exit.

I not sure what is happening - it was working.
Comment 11 Francois-Xavier Coudert 2007-10-02 11:20:21 UTC
Hi Dale,

pr32417.f90 doesn't ICE any more, closing this PR. Please reopen if you have more information.