Bug 31984 - Infinite loop (eating all mem) compiling xorg 1.3.0.0
Summary: Infinite loop (eating all mem) compiling xorg 1.3.0.0
Status: RESOLVED DUPLICATE of bug 30052
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: memory-hog
Depends on:
Blocks:
 
Reported: 2007-05-18 02:52 UTC by Max Vegni
Modified: 2007-05-18 10:14 UTC (History)
8 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Max Vegni 2007-05-18 02:52:57 UTC
While compiling xorg-server-1.3.0.0/hw/xfree86/scanpci/xf86ScanPci.c gcc goes into an infinite loop eating up all memory. Compiling flags were: -g -O2 (defaults).

Output (with virtual memory limited to 512000k) follows.

make[1]: Entering directory `/opt/src/xorg-server-1.3.0.0/hw/xfree86/scanpci'
if /bin/sh ../../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../../../include -I../../../include -I../../../include -I../../../include -I../../../include -I../../../include -I../../../include -I../../../include -I../../../hw/xfree86 -I../../../hw/xfree86/include -I../../../hw/xfree86/common -I../../../hw/xfree86/os-support -I../../../hw/xfree86/os-support/bus -I../../../os   -DHAVE_XORG_CONFIG_H -DXF86PM -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I/usr/X11R6/include   -I../../../include -I../../../include -I../../../Xext -I../../../composite -I../../../damageext -I../../../xfixes -I../../../Xi -I../../../mi -I../../../miext/shadow  -I../../../miext/damage -I../../../render -I../../../randr -I../../../fb -g -O2 -MT xf86ScanPci.lo -MD -MP -MF ".deps/xf86ScanPci.Tpo" -c -o xf86ScanPci.lo xf86ScanPci.c; \
        then mv -f ".deps/xf86ScanPci.Tpo" ".deps/xf86ScanPci.Plo"; else rm -f ".deps/xf86ScanPci.Tpo"; exit 1; fi
 gcc -DHAVE_CONFIG_H -I. -I. -I../../../include -I../../../include -I../../../include -I../../../include -I../../../include -I../../../include -I../../../include -I../../../include -I../../../hw/xfree86 -I../../../hw/xfree86/include -I../../../hw/xfree86/common -I../../../hw/xfree86/os-support -I../../../hw/xfree86/os-support/bus -I../../../os -DHAVE_XORG_CONFIG_H -DXF86PM -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I/usr/X11R6/include -I../../../include -I../../../include -I../../../Xext -I../../../composite -I../../../damageext -I../../../xfixes -I../../../Xi -I../../../mi -I../../../miext/shadow -I../../../miext/damage -I../../../render -I../../../randr -I../../../fb -g -O2 -MT xf86ScanPci.lo -MD -MP -MF .deps/xf86ScanPci.Tpo -c xf86ScanPci.c  -fPIC -DPIC -o .libs/xf86ScanPci.o

cc1: out of memory allocating 4064 bytes after a total of 494673920 bytes
make[1]: *** [xf86ScanPci.lo] Error 1
make[1]: Leaving directory `/opt/src/xorg-server-1.3.0.0/hw/xfree86/scanpci'
make: *** [all] Error 2
Comment 1 Pawel Sikora 2007-05-18 06:08:18 UTC
this is a dup of PR30052
Comment 2 Richard Biener 2007-05-18 10:14:52 UTC

*** This bug has been marked as a duplicate of 30052 ***