Bug 31348 - Error in compilation
Summary: Error in compilation
Status: RESOLVED INVALID
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 4.1.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-25 18:15 UTC by Gabriel Muñumel
Modified: 2008-09-03 02:00 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Muñumel 2007-03-25 18:15:27 UTC
Version exacta: gcc version 4.1.0
System type: Windows Vista
		Manufacturer: Dell
		Model: Inspiron I6400
		Rating: Windows Experience Index: Unrated
		Processor: Genuine Intel(R) CPU  T2060 @ 1.60GHz 1.60 GHz
		Memory(Ram): 1022 Mb
		System type: 32-bit Operating System
Gcc configured/built: Environment Variables :  path (things)\;C:\DJGPP\bin;C:\DJGPP\programasC
Command line that triggers the bug: gcc hola.c -o hola.exe
Compiler output: gcc.exe: Internal error: (null) (program cc1)
			Please submit a full bug report.
			See <URL:http://gcc.gnu.org/bugs.html> for instructions.
Preprocessed file: cc1 -E -quiet -v -iprefix c:/djgpp/bin/../lib/gcc/dgjpp/4.10/ -remap -imacros 
		c :/djgpp/bin/../lib/gcc/djgpp/4.10/djgpp.ver hola.c -mtune=pentium                             		-fpch-preprocess -o hola.i
Comment 1 Andrew Pinski 2007-03-25 18:22:23 UTC
Vista is not support right now IIRC.
Comment 2 Andrew Pinski 2007-03-25 18:23:03 UTC

*** This bug has been marked as a duplicate of 30972 ***
Comment 3 DJ Delorie 2007-03-26 21:36:33 UTC
30972 is Windows, this is DJGPP - different operating systems.

Are you using the stock 2.03 files, or the 2.04 (beta) files?  There are known incompatibilities in XP and Vista that require the 2.04 builds of the GNU tools, so if you're still using 2.03 (current), please replace them with the 2.04 (beta) versions, and try again.

If 2.04 solves it, then this is not a gcc bug.
Comment 4 Manuel López-Ibáñez 2008-01-08 17:46:58 UTC
Waiting for feedback.
Comment 5 Andrew Pinski 2008-09-03 02:00:34 UTC
No feedback in 3 months so closing.