User account creation filtered due to spam.

Bug 31275 - ICE During Gettext Build
Summary: ICE During Gettext Build
Status: RESOLVED DUPLICATE of bug 29826
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.1.2
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-20 07:17 UTC by arcangelpip
Modified: 2007-03-20 15:20 UTC (History)
4 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-mingw32
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Preprocessed output from the file. (10.10 KB, text/plain)
2007-03-20 07:18 UTC, arcangelpip
Details

Note You need to log in before you can comment on or make changes to this bug.
Description arcangelpip 2007-03-20 07:17:21 UTC
msgl-check.c: In function 'plural_help':
msgl-check.c:194: error: unrecognizable insn:
(insn 41 40 42 4 msgl-check.c:179 (set (reg:SI 75)
        (const:SI (plus:SI (mem:SI (symbol_ref:SI ("#i.plural_table") <var_decl 0xb7e11b58 plural_table>) [0 S4 A8])
                (const_int 4 [0x4])))) -1 (nil)
    (nil))
msgl-check.c:194: internal compiler error: in extract_insn, at recog.c:2084
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.

I get this when I try to cross compile gettext for mingw from linux.

It is being compiled with this command line.

/crosstools/crosscc/bin/i686-pc-mingw32-gcc -DLOCALEDIR="/crosstools/crosscc/share/locale" 
-DBISON_LOCALEDIR="" -DLOCALE_ALIAS_PATH="/crosstools/crosscc/share/locale" -DUSEJEXE=1 
-DGETTEXTJEXEDIR="/crosstools/crosscc/lib/gettext" 
-DGETTEXTJAR="/crosstools/crosscc/share/gettext/gettext.jar" 
-DLIBDIR="/crosstools/crosscc/lib" 
-DGETTEXTDATADIR="/crosstools/crosscc/share/gettext" 
-DPROJECTSDIR="/crosstools/crosscc/share/gettext/projects" -DHAVE_CONFIG_H -c -I. -I.. 
-I../libgrep -I../libuniname -I../gnulib-lib -I../intl -I../../gettext-runtime/intl -I/crosstools/crosscc/include -g -O2 msgl-check.c -o msgl-check.o

This is the output for i686-pc-mingw32-gcc -v

Using built-in specs.
Target: i686-pc-mingw32
Configured with: ../gcc-4.1.2/configure --prefix=/crosstools/crosscc --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --target=i686-pc-mingw32 --enable-shared --enable-threads --disable-nls --enable-c99 --enable-long-long --disable-multilib --enable-languages=c,c++,java,objc,obj-c++,fortran --enable-libgcj --enable-boehm-gc --with-gcj --enable-sjlj-exceptions
Thread model: win32
gcc version 4.1.2
Comment 1 arcangelpip 2007-03-20 07:18:31 UTC
Created attachment 13237 [details]
Preprocessed output from the file.

Added the preprocessed output.
Comment 2 Danny Smith 2007-03-20 08:21:57 UTC
This is a dup of  PR 29826.
The testcase (and 29826) succeeds on gcc version 4.2.0 20070319 (prerelease)
and on  gcc version 4.3.0 20070318 (experimental) with mingw32

Danny
Comment 3 arcangelpip 2007-03-20 13:58:14 UTC
I just tried with the latest sources for 4.1 and it still ICE with that. Same place same message. It may work on 4.2 and 4.3 but it doesn't work for me on 4.1.
Comment 4 Andrew Pinski 2007-03-20 15:20:05 UTC

*** This bug has been marked as a duplicate of 29826 ***