Bug 31172 - [4.2 Regression] Compiling xf86ScanPci.c from xorg-server 1.2.99.901 takes up loads of memory at -O1 and higher
Summary: [4.2 Regression] Compiling xf86ScanPci.c from xorg-server 1.2.99.901 takes up...
Status: RESOLVED DUPLICATE of bug 30052
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-14 11:11 UTC by bero
Modified: 2007-03-14 14:15 UTC (History)
6 users (show)

See Also:
Host: i586-pc-linux-gnu
Target: i586-pc-linux-gnu
Build: i586-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bero 2007-03-14 11:11:26 UTC
Compiling xf86ScanPci.c from xorg-server 1.2.99.901 with gcc 4.2 branch (SVN 118519) takes much longer than with older versions of gcc, and takes loads of memory (approx. 3 GB).

Works as expected with older gccs and with 4.2 and -O0.
Comment 1 Pawel Sikora 2007-03-14 11:18:39 UTC
this is a dup of PR30052
Comment 2 bero 2007-03-14 11:21:52 UTC
The difference between this and 30052 is that 30052 claims x86 is ok and the problem occurs only on x86_64 -- it happens here with x86 (non-64).

Uploading preprocessed source currently gives a "bugzilla internal error".
Comment 3 Richard Biener 2007-03-14 14:15:26 UTC
same source, same problem.

*** This bug has been marked as a duplicate of 30052 ***