Bug 30906 - gnu.xml.dom is not compatible with Xerces2
Summary: gnu.xml.dom is not compatible with Xerces2
Status: RESOLVED FIXED
Alias: None
Product: classpath
Classification: Unclassified
Component: xml (show other bugs)
Version: unspecified
: P3 normal
Target Milestone: ---
Assignee: chris burdess
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-21 10:07 UTC by Andrew Haley
Modified: 2007-03-08 09:59 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2007-02-21 10:10:05


Attachments
Workaround (2.21 KB, patch)
2007-02-22 09:00 UTC, chris burdess
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Haley 2007-02-21 10:07:50 UTC
If you put Xerces' jaxp_parser_impl.jar in the classpath, DomDocumentBuilderFactory.java.newDocumentBuilder() exits with a ParserConfigurationException.  This seems to be because gnu.xml.dom uses a configuration interface that is incompatible with Xerces2.
Comment 1 chris burdess 2007-02-22 09:00:12 UTC
Created attachment 13091 [details]
Workaround

Selects an LS implementation that supports the parameters required rather than the first LS implementation.
Comment 2 Gary Benson 2007-03-08 09:59:07 UTC
Fixed with the addition of resource/META-INF/services/org.w3c.dom.DOMImplementationSourceList.