User account creation filtered due to spam.

Bug 30900 - relocation R_X86_64_PC32 BUG
Summary: relocation R_X86_64_PC32 BUG
Status: RESOLVED DUPLICATE of bug 19664
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 4.1.2
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
Depends on:
Reported: 2007-02-20 23:17 UTC by Centi
Modified: 2007-02-22 23:58 UTC (History)
29 users (show)

See Also:
Host: linux x86_64
Known to work:
Known to fail:
Last reconfirmed:

this package not compile (468.84 KB, application/x-bzip)
2007-02-20 23:23 UTC, Centi
this package is needed by gaol (720.21 KB, application/x-bzip)
2007-02-20 23:25 UTC, Centi

Note You need to log in before you can comment on or make changes to this bug.
Description Centi 2007-02-20 23:17:43 UTC
 relocation R_X86_64_PC32  BUG

libtool: link: warning: library `/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../lib64//' was moved.
g++ -shared -nostdlib /usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../lib64/crti.o /usr/lib64/gcc/x86_64-suse-linux/4.1.2/crtbeginS.o  .libs/gaol_interval.o .libs/gaol_profile.o .libs/gaol_common.o .libs/gaol_parser.o .libs/gaol_expression.o .libs/dtoa.o .libs/gaol_interval_parser.o .libs/gaol_interval_lexer.o .libs/gaol_port.o .libs/gaol_flt_output.o .libs/gaol_exceptions.o .libs/gaol_init_cleanup.o .libs/s_nextafter.o  -Wl,--rpath -Wl,/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../lib64/ -Wl,--rpath -Wl,/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../lib64/ /usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../lib64// -L/usr/lib64/gcc/x86_64-suse-linux/4.1.2 -L/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../lib64 -L/lib/../lib64 -L/usr/lib/../lib64 -L/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../x86_64-suse-linux/lib -L/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../.. -lstdc++ -lm -lc -lgcc_s /usr/lib64/gcc/x86_64-suse-linux/4.1.2/crtendS.o /usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../lib64/crtn.o  -m64 -Wl,-soname -Wl, -o .libs/
/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../x86_64-suse-linux/bin/ld: .libs/gaol_interval.o: relocation R_X86_64_PC32 against `std::basic_stringbuf<char, std::char_traits<char>, std::allocator<char> >::str() const@@GLIBCXX_3.4' can not be used when making a shared object; recompile with -fPIC
/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../x86_64-suse-linux/bin/ld: final link failed: Bad value

 GCC Version

linux-370u:/home/centiped/gaol-2.0.2-mvc6-mcv2003-x86_64 # g++ -v
Using built-in specs.
Target: x86_64-suse-linux
Configured with: ../configure --enable-threads=posix --prefix=/usr --with-local-prefix=/usr/local --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib64 --libexecdir=/usr/lib64 --enable-languages=c,c++,objc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.1.2 --enable-ssp --disable-libssp --disable-libgcj --with-slibdir=/lib64 --with-system-zlib --enable-shared --enable-__cxa_atexit --enable-libstdcxx-allocator=new --program-suffix=-4.1 --enable-version-specific-runtime-libs --without-system-libunwind --with-cpu=generic --host=x86_64-suse-linux
Thread model: posix
gcc version 4.1.2 20061115 (prerelease) (SUSE Linux)
Comment 1 Centi 2007-02-20 23:23:50 UTC
Created attachment 13079 [details]
this package not compile
Comment 2 Centi 2007-02-20 23:25:28 UTC
Created attachment 13080 [details]
this package is needed by gaol
Comment 3 Centi 2007-02-20 23:27:11 UTC
 this bugs appears on Suse 10.2 in a AMD x86_64 system. First compile the mathlib and install it in the system the try to compile gaol. This fail at the end on linker stage.
Comment 4 Andrew Pinski 2007-02-22 23:58:40 UTC
This is a bug in libstdc++ which was fixed in 4.2.0.

But note the code uses "-fvisibility-inlines-hidden -fvisibility=hidden" without testing if the system library has been fixed.  It only checks if those options work.

*** This bug has been marked as a duplicate of 19664 ***