Bug 30615 - c++: Internal error: Killed: 9 (program cc1plus)
Summary: c++: Internal error: Killed: 9 (program cc1plus)
Status: RESOLVED INVALID
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.4.4
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: memory-hog
Depends on:
Blocks:
 
Reported: 2007-01-27 17:56 UTC by Kevin Reiter
Modified: 2007-02-09 22:13 UTC (History)
2 users (show)

See Also:
Host: FreeBSD 6.0-RELEASE i386
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Reiter 2007-01-27 17:56:00 UTC
When building mysql server 5.0.33 from ports on FreeBSD 6.0-RELEASE, I get the following c++ error:

root@nagios [/usr/ports/databases/mysql50-server]# make WITH_OPENSSL=yes WITHOUT_INNODB=yes
===>  Building for mysql-server-5.0.33
make  all-recursive
Making all in include
make  all-am
Making all in Docs
Making all in strings
Making all in mysys
Making all in dbug
Making all in extra
make  all-recursive
Making all in regex
Making all in bdb
cd build_unix && make all
Making all in myisam
Making all in myisammrg
Making all in heap
Making all in vio
Making all in sql
make  all-recursive
Making all in share
if c++ -DMYSQL_SERVER  -DDEFAULT_MYSQL_HOME="\"/usr/local\""  -DDATADIR="\"/var/db/mysql\""  -DSHAREDIR="\"/usr/local/share/mysql\""  -DHAVE_CONFIG_H -I. -I. -I.. -I../bdb/build_unix    -I../include -I../include  -I../regex -I.  -I/usr/local/include     -DDBUG_OFF -O2 -fno-strict-aliasing -pipe -O2 -fno-strict-aliasing -pipe   -felide-constructors -fno-rtti -fno-exceptions   -fno-implicit-templates -fno-exceptions -fno-rtti -DMYSQLD_NET_RETRY_COUNT=1000000 -MT sql_handler.o -MD -MP -MF ".deps/sql_handler.Tpo" -c -o sql_handler.o sql_handler.cc;  then mv -f ".deps/sql_handler.Tpo" ".deps/sql_handler.Po"; else rm -f ".deps/sql_handler.Tpo"; exit 1; fi
c++: Internal error: Killed: 9 (program cc1plus)
Please submit a full bug report.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
*** Error code 1

Stop in /usr/ports/databases/mysql50-server/work/mysql-5.0.33/sql.
*** Error code 1

Stop in /usr/ports/databases/mysql50-server/work/mysql-5.0.33/sql.
*** Error code 1

Stop in /usr/ports/databases/mysql50-server/work/mysql-5.0.33/sql.
*** Error code 1

Stop in /usr/ports/databases/mysql50-server/work/mysql-5.0.33.
*** Error code 1

Stop in /usr/ports/databases/mysql50-server/work/mysql-5.0.33.
*** Error code 1

Stop in /usr/ports/databases/mysql50-server.

==========================================
kevin@nagios [~]$ gcc -v
Using built-in specs.
Configured with: FreeBSD/i386 system compiler
Thread model: posix
gcc version 3.4.4 [FreeBSD] 20050518

kevin@nagios [~]$ uname -a
FreeBSD nagios.unixfun.net 6.0-RELEASE FreeBSD 6.0-RELEASE #0: Thu Nov  3 09:36:13 UTC 2005     root@x64.samsco.home:/usr/obj/usr/src/sys/GENERIC  i386


Please let me know what other info you need from me.

Thanks,
Kevin
Comment 1 Andrew Pinski 2007-01-27 19:05:54 UTC
How much memory do you have?  This internal error is caused by the kernel killing the process because it ran over the memory limits.
Comment 2 Kevin Reiter 2007-01-29 00:05:16 UTC
(In reply to comment #1)
> How much memory do you have?  This internal error is caused by the kernel
> killing the process because it ran over the memory limits.
> 

That would be the case.  The box has 128MB of RAM.  I've tried compiling a few other apps and had the same thing happen.  This item can be closed.

Thanks,
Kevin
Comment 3 Volker Reichelt 2007-02-09 22:13:03 UTC
Not a GCC issue, just too few RAM.
Closing by request of submitter.