Bug 30459 - FAIL: g++.dg/eh/ia64-2.C (test for excess errors)
FAIL: g++.dg/eh/ia64-2.C (test for excess errors)
Status: RESOLVED FIXED
Product: gcc
Classification: Unclassified
Component: testsuite
4.1.2
: P3 normal
: ---
Assigned To: Not yet assigned to anyone
:
: 31168 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-14 00:41 UTC by John David Anglin
Modified: 2008-01-09 03:28 UTC (History)
1 user (show)

See Also:
Host: hppa1.1-hp-hpux10.20
Target: hppa1.1-hp-hpux10.20
Build: hppa1.1-hp-hpux10.20
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John David Anglin 2007-01-14 00:41:34 UTC
Executing on host: /xxx/gnu/gcc/objdir/gcc/testsuite/g++/../../g++ -B/xxx/gnu/gc
c/objdir/gcc/testsuite/g++/../../ /xxx/gnu/gcc/gcc/gcc/testsuite/g++.dg/eh/ia64-
2.C  -nostdinc++ -I/xxx/gnu/gcc/objdir/hppa1.1-hp-hpux10.20/libstdc++-v3/include
/hppa1.1-hp-hpux10.20 -I/xxx/gnu/gcc/objdir/hppa1.1-hp-hpux10.20/libstdc++-v3/in
clude -I/xxx/gnu/gcc/gcc/libstdc++-v3/libsupc++ -I/xxx/gnu/gcc/gcc/libstdc++-v3/
include/backward -I/xxx/gnu/gcc/gcc/libstdc++-v3/testsuite -fmessage-length=0  -
O2    -L/xxx/gnu/gcc/objdir/hppa1.1-hp-hpux10.20/./libstdc++-v3/src/.libs  -L/xx
x/gnu/gcc/objdir/hppa1.1-hp-hpux10.20/./libstdc++-v3/src/.libs -L/xxx/gnu/gcc/ob
jdir/hppa1.1-hp-hpux10.20/./libiberty  -lm   -o ./ia64-2.exe    (timeout = 600)
/xxx/gnu/gcc/gcc/gcc/testsuite/g++.dg/eh/ia64-2.C:18: warning: weak declaration
of 'p' not supported
output is:
/xxx/gnu/gcc/gcc/gcc/testsuite/g++.dg/eh/ia64-2.C:18: warning: weak declaration
of 'p' not supported

FAIL: g++.dg/eh/ia64-2.C (test for excess errors)
Excess errors:
/xxx/gnu/gcc/gcc/gcc/testsuite/g++.dg/eh/ia64-2.C:18: warning: weak declaration
of 'p' not supported

Setting LD_LIBRARY_PATH to .:/xxx/gnu/gcc/objdir/hppa1.1-hp-hpux10.20/./libstdc+
+-v3/src/.libs:/xxx/gnu/gcc/objdir/hppa1.1-hp-hpux10.20/./libstdc++-v3/src/.libs
:/xxx/gnu/gcc/objdir/gcc:.:/xxx/gnu/gcc/objdir/hppa1.1-hp-hpux10.20/./libstdc++-
v3/src/.libs:/xxx/gnu/gcc/objdir/hppa1.1-hp-hpux10.20/./libstdc++-v3/src/.libs:/
xxx/gnu/gcc/objdir/gcc
PASS: g++.dg/eh/ia64-2.C execution test
Comment 1 John David Anglin 2007-05-04 23:53:38 UTC
*** Bug 31168 has been marked as a duplicate of this bug. ***
Comment 2 John David Anglin 2008-01-09 03:15:00 UTC
Subject: Bug 30459

Author: danglin
Date: Wed Jan  9 03:14:15 2008
New Revision: 131410

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=131410
Log:
	PR testsuite/30459
	g++.dg/eh/ia64-2.C: Require weak support.


Modified:
    trunk/gcc/testsuite/ChangeLog
    trunk/gcc/testsuite/g++.dg/eh/ia64-2.C

Comment 3 John David Anglin 2008-01-09 03:26:54 UTC
Subject: Bug 30459

Author: danglin
Date: Wed Jan  9 03:26:10 2008
New Revision: 131411

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=131411
Log:
	PR testsuite/30459
	g++.dg/eh/ia64-2.C: Require weak support.


Modified:
    branches/gcc-4_2-branch/gcc/testsuite/ChangeLog
    branches/gcc-4_2-branch/gcc/testsuite/g++.dg/eh/ia64-2.C

Comment 4 John David Anglin 2008-01-09 03:28:58 UTC
Fixed.